]> git.pld-linux.org Git - packages/OpenIPMI.git/blob - OpenIPMI.spec
- %install not parallel make safe
[packages/OpenIPMI.git] / OpenIPMI.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build wxPython-based GUI
4 #
5 Summary:        IPMI abstraction layer
6 Summary(pl):    Warstwa abstrakcji IPMI
7 Name:           OpenIPMI
8 Version:        2.0.6
9 Release:        1
10 License:        LGPL (library), GPL (ipmicmd)
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
13 # Source0-md5:  43be79ea0693dbde0420202e721b5232
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-python.patch
16 URL:            http://openipmi.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gcc >= 5:3.2
20 BuildRequires:  gdbm-devel
21 BuildRequires:  glib2-devel >= 2.0
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  ncurses-devel
24 BuildRequires:  net-snmp-devel
25 BuildRequires:  perl-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRequires:  python-devel
29 %{?with_gui:BuildRequires:      python-wxPython}
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  swig-perl >= 1.3.25
32 BuildRequires:  swig-python >= 1.3.25
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 OpenIPMI project aims to develop an open code base to allow access to
37 platform information using Intelligent Platform Management Interface
38 (IPMI).
39
40 %description -l pl
41 Celem projektu OpenIPMI jest stworzenie otwartej podstawy kodu
42 pozwalaj±cego na dostêp do informacji o platformie pzy u¿yciu
43 interfejsu IPMI (Intelligent Platform Management Interface -
44 interfejsu inteligentnego zarz±dzania platform±)
45
46 %package devel
47 Summary:        Development part of OpenIPMI Toolkit libraries
48 Summary(pl):    Programistyczna cze¶æ bibliotek OpenIPMI
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Development part of OpenIPMI libraries.
54
55 %description devel -l pl
56 Programistyczna cze¶æ bibliotek OpenIPMI.
57
58 %package static
59 Summary:        Static OpenIPMI libraries
60 Summary(pl):    Statyczne biblioteki OpenIPMI
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static OpenIPMI Toolkit libraries.
66
67 %description static -l pl
68 Statyczne biblioteki OpenIPMI.
69
70 %package -n perl-%{name}
71 Summary:        Perl interface to OpenIPMI
72 Summary(pl):    Perlowy interfejs do OpenIPMI
73 Group:          Development/Languages/Perl
74 Requires:       %{name} = %{version}-%{release}
75
76 %description -n perl-%{name}
77 Perl interface to OpenIPMI.
78
79 %description -n perl-%{name} -l pl
80 Perlowy interfejs do OpenIPMI.
81
82 %package -n python-%{name}
83 Summary:        Python interface to OpenIPMI
84 Summary(pl):    Pythonowy interfejs do OpenIPMI
85 Group:          Development/Languages/Python
86 Requires:       %{name} = %{version}-%{release}
87 %pyrequires_eq  python-libs
88
89 %description -n python-%{name}
90 Python interface to OpenIPMI.
91
92 %description -n perl-%{name} -l pl
93 Pythonowy interfejs do OpenIPMI.
94
95 %package gui
96 Summary:        OpenIPMI GUI
97 Summary(pl):    Graficzny interfejs u¿ytkownika do OpenIPMI
98 Group:          X11/Applications
99 Requires:       python-%{name} = %{version}-%{release}
100 Requires:       python-wxPython
101
102 %description gui
103 OpenIPMI GUI.
104
105 %description gui -l pl
106 Graficzny interfejs u¿ytkownika do OpenIPMI.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__automake}
118 CPPFLAGS="-I/usr/include/ncurses"
119 %configure \
120         --without-glib12 \
121         %{!?with_gui:--without-wxpython}
122 %{__make} \
123         PYTHON_INSTALL_DIR=%{py_sitedir}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install -j1 \
129         DESTDIR=$RPM_BUILD_ROOT \
130         PYTHON_INSTALL_DIR=%{py_sitedir}
131
132 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a} \
133         $RPM_BUILD_ROOT%{py_sitedir}/openipmigui/*.py
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc ChangeLog FAQ README* TODO
144 %attr(755,root,root) %{_bindir}/ipmi*
145 %attr(755,root,root) %{_bindir}/openipmicmd
146 %attr(755,root,root) %{_bindir}/openipmish
147 %attr(755,root,root) %{_bindir}/rmcp_ping
148 %attr(755,root,root) %{_bindir}/solterm
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
150 %{_mandir}/man[178]/*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/*.la
156 %{_includedir}/%{name}
157 %{_pkgconfigdir}/*.pc
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/lib*.a
162
163 %files -n perl-%{name}
164 %defattr(644,root,root,755)
165 %{perl_vendorarch}/OpenIPMI.pm
166 %dir %{perl_vendorarch}/auto/OpenIPMI
167 %attr(755,root,root) %{perl_vendorarch}/auto/OpenIPMI/OpenIPMI.so
168
169 %files -n python-%{name}
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{py_sitedir}/_OpenIPMI.so
172 %{py_sitedir}/OpenIPMI.py[co]
173
174 %if %{with gui}
175 %files gui
176 %defattr(644,root,root,755)
177 %doc swig/python/openipmigui/TODO
178 %attr(755,root,root) %{_bindir}/openipmigui
179 %dir %{py_sitedir}/openipmigui
180 %{py_sitedir}/openipmigui/*.py[co]
181 %endif
This page took 0.038841 seconds and 4 git commands to generate.