]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
- added idl-gtk-doc patch (adjust orbit-idl-2 to generate code parsable by current...
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # gtk-doc based API documentation
4 %bcond_without  static_libs     # static libraries
5
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.19
11 Release:        10
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        https://download.gnome.org/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7082d317a9573ab338302243082d10d1
17 Patch0:         %{name}-pthread.patch
18 Patch1:         %{name}-build-fix.patch
19 Patch2:         %{name}-idl-gtk-doc.patch
20 URL:            https://developer.gnome.org/ORBit2/
21 BuildRequires:  autoconf >= 2.54
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  docbook-dtd412-xml
24 BuildRequires:  flex
25 BuildRequires:  glib2-devel >= 1:2.14.1
26 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
27 BuildRequires:  indent
28 BuildRequires:  libIDL-devel >= 0.8.10
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig >= 1:0.18
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.197
33 Requires:       glib2 >= 1:2.14.1
34 Requires:       libIDL >= 0.8.10
35 Provides:       linc = 1.1.1
36 Obsoletes:      ORBit2-automake < 1:2.12.5
37 Obsoletes:      libORBit2_0
38 Obsoletes:      linc
39 Conflicts:      libbonobo < 2.3.2
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 ORBit is a high-performance CORBA (Common Object Request Broker
44 Architecture) ORB (object request broker). It allows programs to send
45 requests and receive replies from other programs, regardless of the
46 locations of the two programs. CORBA is an architecture that enables
47 communication between program objects, regardless of the programming
48 language they're written in or the operating system they run on.
49
50 %description -l fr.UTF-8
51 ORBit est un ORB CORBA avec support pour le language C. Il permet a
52 des programmes d'envoyer des requètes et recevoir de réponses d'autres
53 programmes, indépendement de l'endroit ou sont les deux programmes.
54
55 %description -l pl.UTF-8
56 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
57 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
58 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
59 tych dwóch programów.
60
61 %package apidocs
62 Summary:        ORBit API documentation
63 Summary(pl.UTF-8):      Dokumentacja API ORBit
64 Group:          Documentation
65 Requires:       gtk-doc-common
66 BuildArch:      noarch
67
68 %description apidocs
69 ORBit API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API ORBit.
73
74 %package devel
75 Summary:        Header files, and utilities for ORBit
76 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
77 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 Requires:       glib2-devel >= 1:2.14.1
81 Requires:       indent
82 Requires:       libIDL-devel >= 0.8.10
83 Provides:       linc-devel = 1.1.1
84 Obsoletes:      libORBit2_0-devel
85 Obsoletes:      linc-devel
86
87 %description devel
88 devel ORBit is a high-performance CORBA ORB with support for the C
89 language. It allows programs to send requests and receive replies from
90 other programs, regardless of the locations of the two programs.
91
92 This package includes the header files and utilities neecessary to
93 write programs that use CORBA technology.
94
95 %description devel -l fr.UTF-8
96 Librairies statiques et fichiers entête requis pour le development ou
97 la compilation de programmes utilisant ORBit.
98
99 %description devel -l pl.UTF-8
100 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
101 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
102 programów bez znajomości położenia tych dwóch programów.
103
104 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
105 programów używających technologi CORBA.
106
107 %package static
108 Summary:        Static libraries for ORBit
109 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112 Provides:       linc-static = 1.1.1
113 Obsoletes:      linc-static
114
115 %description static
116 ORBit is a high-performance CORBA ORB with support for the C language.
117 It allows programs to send requests and receive replies from other
118 programs, regardless of the locations of the two programs.
119
120 This package includes static libraries neecessary to write programs
121 statically linked that use CORBA technology.
122
123 %description static -l pl.UTF-8
124 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
125 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
126 programów bez znajomości położenia tych dwóch programów.
127
128 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
129 skonsolidowanych statycznie używających technologii CORBA.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136
137 %if %{without apidocs}
138 echo 'EXTRA_DIST=' > gtk-doc.make
139 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
140 %endif
141
142 %build
143 %{?with_apidocs:%{__gtkdocize}}
144 %{__libtoolize}
145 %{__aclocal}
146 %{__autoconf}
147 %{__autoheader}
148 %{__automake}
149 %configure \
150         --with-html-dir=%{_gtkdocdir} \
151         %{!?with_static_libs:--disable-static} \
152         %{?with_apidocs:--enable-gtk-doc}
153 %{__make} -j1
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157
158 %{__make} -j1 install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 # obsoleted by pkg-config
162 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
163 # no static module - shut up check-files
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.la
165 %if %{with static_libs}
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.a
167 %endif
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post   -p /sbin/ldconfig
173 %postun -p /sbin/ldconfig
174
175 %files
176 %defattr(644,root,root,755)
177 %doc AUTHORS NEWS README
178 %attr(755,root,root) %{_bindir}/ior-decode-2
179 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
180 %attr(755,root,root) %{_bindir}/orbit-idl-2
181 %attr(755,root,root) %{_bindir}/typelib-dump
182 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
184 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
186 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
188 %dir %{_libdir}/orbit-2.0
189 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
190 %{_datadir}/idl/orbit-2.0
191
192 %if %{with apidocs}
193 %files apidocs
194 %defattr(644,root,root,755)
195 %{_gtkdocdir}/%{name}
196 %endif
197
198 %files devel
199 %defattr(644,root,root,755)
200 %doc ChangeLog
201 %attr(755,root,root) %{_bindir}/orbit2-config
202 %attr(755,root,root) %{_libdir}/libORBit-2.so
203 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
204 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
205 # static-only library
206 %{_libdir}/libname-server-2.a
207 %{_includedir}/orbit-2.0
208 %{_pkgconfigdir}/ORBit-2.0.pc
209 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
210 %{_pkgconfigdir}/ORBit-idl-2.0.pc
211 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
212 %{_aclocaldir}/ORBit2.m4
213
214 %if %{with static_libs}
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libORBit-2.a
218 %{_libdir}/libORBit-imodule-2.a
219 %{_libdir}/libORBitCosNaming-2.a
220 %endif
This page took 0.235901 seconds and 3 git commands to generate.