]> git.pld-linux.org Git - packages/NetworkManager-applet.git/blob - NetworkManager-applet.spec
up to 1.16.0
[packages/NetworkManager-applet.git] / NetworkManager-applet.spec
1 #
2 # Conditional build:
3 %bcond_with     appindicator    # application indicators instead of xembed systray support
4 %bcond_with     libnm_gtk       # build deprecated libnm-gtk lib (depends on libnm-glib dropped in NetworkManager 1.20)
5 #
6 %define         nmversion 2:1.8
7 Summary:        Network Manager for GNOME
8 Summary(pl.UTF-8):      Zarządca sieci dla GNOME
9 Name:           NetworkManager-applet
10 Version:        1.16.0
11 Release:        1
12 License:        GPL v2
13 Group:          X11/Applications
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/network-manager-applet/1.16/network-manager-applet-%{version}.tar.xz
15 # Source0-md5:  9652c2757e85d6caba657405cf794fbd
16 URL:            https://wiki.gnome.org/Projects/NetworkManager
17 BuildRequires:  ModemManager-devel >= 1.0.0
18 BuildRequires:  NetworkManager-devel >= %{nmversion}
19 %if %{with libnm_gtk}
20 BuildRequires:  NetworkManager-devel < 2:1.20
21 %endif
22 BuildRequires:  dbus-devel >= 1.2.6
23 BuildRequires:  dbus-glib-devel >= 0.74
24 BuildRequires:  gcr-devel >= 3.14
25 BuildRequires:  gcr-ui-devel >= 3.14
26 BuildRequires:  gettext-tools >= 0.19.8
27 BuildRequires:  glib2-devel >= 1:2.38
28 BuildRequires:  gobject-introspection-devel >= 0.9.6
29 BuildRequires:  gtk+3-devel >= 3.10
30 BuildRequires:  gtk-doc >= 1.0
31 BuildRequires:  iso-codes
32 BuildRequires:  jansson-devel >= 2.7
33 %{?with_appindicator:BuildRequires:     libappindicator-gtk3-devel >= 0.1}
34 %{?with_appindicator:BuildRequires:     libdbusmenu-gtk3-devel >= 16.04.0}
35 BuildRequires:  libnma-devel >= 1.8.27
36 BuildRequires:  libnotify-devel >= 0.7.0
37 BuildRequires:  libsecret-devel >= 0.18
38 BuildRequires:  libselinux-devel
39 BuildRequires:  meson >= 0.46.0
40 BuildRequires:  mobile-broadband-provider-info-devel
41 BuildRequires:  ninja
42 BuildRequires:  pkgconfig
43 BuildRequires:  rpmbuild(macros) >= 1.736
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  udev-glib-devel >= 1:147
46 BuildRequires:  xz
47 Requires(post,postun):  glib2 >= 1:2.38
48 Requires(post,postun):  gtk-update-icon-cache
49 Requires:       NetworkManager >= %{nmversion}
50 Requires:       dbus >= 1.2.6
51 Requires:       dbus-glib >= 0.74
52 Requires:       glib2 >= 1:2.38
53 Requires:       hicolor-icon-theme
54 Requires:       jansson >= 2.7
55 Requires:       libnma >= 1.8.27
56 Requires:       libsecret >= 0.18
57 Requires:       mobile-broadband-provider-info
58 Requires:       polkit-gnome
59 Suggests:       dbus(org.freedesktop.Notifications)
60 Obsoletes:      NetworkManager-applet-devel
61 Obsoletes:      gnome-bluetooth-plugin-nma < 1.2.2
62 # sr@Latn vs. sr@latin
63 Conflicts:      glibc-misc < 6:2.7
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 Network Manager Applet for GNOME.
68
69 %description -l pl.UTF-8
70 Aplet zarządcy sieci dla GNOME.
71
72 %prep
73 %setup -q -n network-manager-applet-%{version}
74
75 %build
76 %meson build \
77         -Dappindicator=%{?with_appindicator:yes}%{!?with_appindicator:no} \
78         -Dgtk_doc=true \
79         -Dlibnm_gtk=%{__true_false libnm_gtk}
80 %ninja_build -C build
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-vpn-properties
85
86 %ninja_install -C build
87
88 %find_lang %{name} --with-gnome --all-name
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %update_icon_cache hicolor
95 %glib_compile_schemas
96
97 %postun
98 %update_icon_cache hicolor
99 if [ "$1" = "0" ]; then
100         %glib_compile_schemas
101 fi
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc AUTHORS CONTRIBUTING ChangeLog
106 %attr(755,root,root) %{_bindir}/nm-applet
107 %attr(755,root,root) %{_bindir}/nm-connection-editor
108 %{_datadir}/GConf/gsettings/nm-applet.convert
109 %dir %{_datadir}/gnome-vpn-properties
110 %{_datadir}/metainfo/nm-connection-editor.appdata.xml
111 %{_sysconfdir}/xdg/autostart/nm-applet.desktop
112 %{_desktopdir}/nm-applet.desktop
113 %{_desktopdir}/nm-connection-editor.desktop
114 %{_mandir}/man1/nm-applet.1*
115 %{_mandir}/man1/nm-connection-editor.1*
116 %{_iconsdir}/hicolor/*x*/apps/nm-*.png
117 %{_iconsdir}/hicolor/scalable/apps/nm-*.svg
This page took 0.048618 seconds and 3 git commands to generate.