]> git.pld-linux.org Git - packages/Glide_V3-DRI.git/blob - Glide_V3-DRI.spec
- use %%rpmcflags, added _with_3dnow (using AMD 3Dnow! instructions)
[packages/Glide_V3-DRI.git] / Glide_V3-DRI.spec
1 #
2 # _with_3dnow   - with 3Dnow! instructions
3 %define snapdate 20010309
4 Summary:        Glide runtime for 3Dfx Voodoo Banshee and Voodoo3 boards
5 Summary(pl):    Biblioteki Glide dla kart 3Dfx Voodoo Banshee oraz Voodoo3
6 Name:           Glide_V3-DRI
7 Version:        3.10.0
8 Release:        0.%{snapdate}
9 Epoch:          1
10 Group:          X11/Libraries
11 Group(de):      X11/Libraries
12 Group(es):      X11/Bibliotecas
13 Group(fr):      X11/Librairies
14 Group(pl):      X11/Biblioteki
15 License:        3dfx Glide General Public License, 3Dfx Interactive Inc.
16 URL:            http://glide.sourceforge.net/
17 Source0:        cvs://anonymous@cvs.glide.sourceforge.net:/cvsroot/glide/glide3x-%{snapdate}.tar.gz
18 Patch0:         glide-ia64.patch
19 Patch1:         glide-ac-workaround.patch
20 Patch2:         glide-h3.patch
21 Patch3:         glide-h5.patch
22 Vendor:         3dfx Interactive Inc.
23 Icon:           3dfx.gif
24 BuildRequires:  XFree86-devel
25 BuildRequires:  automake
26 BuildRequires:  autoconf
27 BuildRequires:  libtool
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description 
31 This library allows the user to use a 3dfx Interactive Voodoo Banshee
32 or Voodoo3 card under Linux with DRI support. The source support DRI
33 or non-DRI versions of Glide.
34
35 %description -l pl
36 Ta biblioteka pozwala u¿ytkownikowi na u¿ywanie kart 3dfx Interactive
37 Voodoo Banshee lub Voodoo3 pod Linux'em z DRI. Ta wersja zawiera
38 wsparcie dla wersji Glide'a z DRI i bez DRI.
39
40 %package devel
41 Summary:        Development headers for Glide 3.x
42 Summary(pl):    Pliki nag³ówkowe Glide 3.x
43 Group:          X11/Development/Libraries
44 Group(de):      X11/Entwicklung/Libraries
45 Group(fr):      X11/Development/Librairies
46 Group(pl):      X11/Programowanie/Biblioteki
47 Requires:       %{name} = %{version}
48
49 %description devel
50 This package includes the headers files, documentation, and test files
51 necessary for developing applications that use the 3Dfx Interactive
52 Voodoo Banshe or Voodoo3 cards.
53
54 %description -l pl devel
55 Ten pakiet zawiera pliki nag³ówkowe, dokumentacje, oraz pliki tekstowe
56 wymagane przez aplikacje deweloperskie, które u¿ywaj± kart 3Dfx
57 Interactive Voodoo Banshe lub Voodoo3.
58
59 %package static
60 Summary:        Static library Glide 3.x
61 Summary(pl):    Statyczne biblioteki Glide 3.x
62 Group:          X11/Development/Libraries
63 Group(de):      X11/Entwicklung/Libraries
64 Group(fr):      X11/Development/Librairies
65 Group(pl):      X11/Programowanie/Biblioteki
66 Requires:       %{name} = %{version}
67
68 %description static
69 This package includes the static Glide3 library.
70
71 %description -l pl static
72 Ten pakiet zawiera statyczne biblioteki Glide3.
73
74 %prep
75 %setup -q -n glide3x-%{snapdate}
76 %patch0 -p1
77 %patch1 -p1
78 %patch2 -p1
79 %patch3 -p1
80
81 %build
82 rm -f missing
83 libtoolize --copy --force
84 aclocal
85 autoconf
86 automake -a -c
87 %configure \
88         --enable-fx-dri-build \
89         --enable-fx-glide-hw=h3 \
90         --enable-fx-debug=no \
91         %{?_with_3dnow:--enable-amd3d}
92
93 %{__make} -f makefile.autoconf all \
94         GLIDE_DEBUG_GCFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer -ffast-math}" \
95         GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
100
101 # something is recompiled - use GCFLAGS too
102 %{__make} -f makefile.autoconf install \
103         GLIDE_DEBUG_GCFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer -ffast-math}" \
104         GLIDE_DEBUG_GDEFS="%{!?debug:-DBIG_OPT} %{?debug:-DGDBG_INFO_ON -DGLIDE_DEBUG}" \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 ln -sf libglide3.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libglide3x_V3.so
108 ln -sf libglide3.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libglide3x.so
109
110 # Install the examples and their source, no binaries
111 install h3/glide3/tests/makefile.distrib $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests/makefile
112 install h3/glide3/tests/*.3df $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
113 install h3/glide3/tests/test??.c $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
114 install h3/glide3/tests/tldata.inc $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
115 install h3/glide3/tests/tlib.[ch] $RPM_BUILD_ROOT%{_examplesdir}/glide3/tests
116
117 gzip -9nf glide_license.txt
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc glide_license.txt.gz
128 %attr(755,root,root) %{_libdir}/libglide3.so.*.*.*
129 %attr(755,root,root) %{_libdir}/libglide3x.so
130 %attr(755,root,root) %{_libdir}/libglide3x_V3.so
131
132 %files devel
133 %defattr(644,root,root,755)
134 #%doc docs/*.pdf
135 %{_examplesdir}/glide3
136 %attr(755,root,root) %{_libdir}/lib*.la
137 %attr(755,root,root) %{_libdir}/libglide3.so
138 %{_includedir}/glide3
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/lib*.a
This page took 0.065895 seconds and 3 git commands to generate.