]> git.pld-linux.org Git - packages/Gauche.git/blob - Gauche.spec
- forgot about source URL
[packages/Gauche.git] / Gauche.spec
1 # $Id: Gauche.spec,v 1.2 2002-06-12 15:53:00 filon Exp $
2 Summary:        Scheme script interpreter with multibyte character handling
3 Summary:        Interpreter Scheme obs³uguj±cy wielobajtowe kodowanie znaków
4 Name:           Gauche
5 Version:        0.5.5
6 Release:        1
7 License:        BSD
8 Group:          Development/Languages
9 Source0:        http://telia.dl.sourceforge.net/sourceforge/gauche/%{name}-%{version}.tgz
10 BuildRequires:  gdbm-devel >= 1.8.0
11 BuildRequires:  slib
12 Requires:       slib
13 URL:            http://www.shiro.dreamhost.com/scheme/gauche/
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Gauche is a Scheme interpreter conforming Revised^5 Report on
18 Algorithmic Language Scheme. It is designed for rapid development of
19 daily tools like system management and text processing. It can handle
20 multibyte character strings natively. This package is compiled with
21 utf-8 as the native character encoding.
22
23 %description -l pl
24 Gauche jest interpreterem jêzyka Scheme zgodnym z "Revised^5 Report on
25 Algorithmic Language Scheme". Jest on zaprojektowany do szybkiego
26 tworzenia codziennych narzêdzi, jak zarz±dzania systemem lub
27 przetwarzanie tekstu. Potrafi on obs³ugiwaæ natywnie wielobajtowe
28 kodowanie znaków (jak na przyk³ad unicode). Ten pakiet jest skompilowany
29 z utf-8 jako natywnym kodowaniem znaków.
30
31 %package static
32 Summary:        Static version of Gauche runtime libary
33 Summary(pl):    Statyczna wersja biblioteki czasu wykonania Gauche
34 Group:          Development/Languages
35 Requires:       %{name} = %{version}
36
37 %description static
38 Static version of Gauche runtime libary.
39
40 %description static -l pl
41 Statyczna wersja biblioteki czasu wykonania Gauche.
42
43 %package dbm
44 Summary:        Gauche bindings for GDBM library
45 Summary(pl):    Wi±zania do biblioteki GDBM dla Gauche
46 Group:          Development/Languages
47 Requires:       %{name} = %{version}
48
49 %description dbm
50 Gauche bindings for GDBM library.
51
52 %description dbm -l pl
53 Wi±zania do biblioteki GDBM dla Gauche.
54
55 %prep
56 %setup -q
57
58 %build
59 %configure \
60         --enable-multibyte=utf-8 \
61         --with-slib=/usr/share/guile/slib \
62         --with-pthread
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT
69
70 %{__make} \
71         LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
72         BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
73         DATA_INSTALL_DIR=$RPM_BUILD_ROOT%{_datadir} \
74         GAUCHE_DATA_DIR=$RPM_BUILD_ROOT%{_datadir}/gauche \
75         GAUCHE_ARCH_DIR=$RPM_BUILD_ROOT%{_libdir}/gauche \
76         install-rpm
77
78 install -d $RPM_BUILD_ROOT%{_includedir}
79 mv $RPM_BUILD_ROOT%{_libdir}/gauche/%{version}/include/* $RPM_BUILD_ROOT%{_includedir}
80
81 install -d $RPM_BUILD_ROOT%{_mandir}/man1
82 install doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
83
84 install -d $RPM_BUILD_ROOT%{_aclocaldir}
85 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/gauche.m4
86
87 %clean
88 rm -rf ${RPM_BUILD_ROOT}
89
90 %post
91 # creates slib catalog, if possible.
92 /usr/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1 || :
93 /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc COPYING ChangeLog
100 %attr(755,root,root) %{_bindir}/gosh
101 %attr(755,root,root) %{_bindir}/gauche-config
102 %attr(755,root,root) %{_libdir}/libgauche.so
103 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/*
104 %exclude %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
105 %dir %{_libdir}/gauche/site/%{version}/*
106 %{_datadir}/gauche/%{version}/lib
107 %exclude %{_datadir}/gauche/%{version}/lib/dbm*
108 %dir %{_datadir}/gauche/site/lib
109 %{_includedir}/gauche
110 %{_includedir}/gauche.h
111 %{_mandir}/man1/*
112 %{_aclocaldir}/*.m4
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libgauche.a
117
118 %files dbm
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/gauche/%{version}/*/[nog]dbm.so
121 %{_datadir}/gauche/%{version}/lib/dbm
122 %{_datadir}/gauche/%{version}/lib/dbm.scm
This page took 0.073325 seconds and 4 git commands to generate.