]> git.pld-linux.org Git - packages/GPI2.git/blob - GPI2.spec
f4b90b6ab96addaa01c2759a3f4e7088e38fe83e
[packages/GPI2.git] / GPI2.spec
1 # TODO: CUDA, MPI, Load Leveler(?)
2 # - find gaspi_logger sources and compile it
3 #
4 # Conditional build:
5 %bcond_without  f90     # Fortran bindings
6 #
7 Summary:        GPI-2 - API for asynchronous communication
8 Summary(pl.UTF-8):      GPI-2 - API do komunikacji asynchronicznej
9 Name:           GPI2
10 Version:        1.1.1
11 Release:        0.1
12 License:        GPL v3
13 Group:          Applications
14 Source0:        https://www.openfabrics.org/downloads/gpi2/%{name}-%{version}.tar.gz
15 # Source0-md5:  83598c7cfacf5b47892af667729a111b
16 Patch0:         %{name}-nosse.patch
17 Patch1:         %{name}-format.patch
18 URL:            http://www.gpi-site.com/gpi2/
19 BuildRequires:  doxygen
20 %{?with_f90:BuildRequires:      gcc-fortran >= 5:4.0}
21 BuildRequires:  libibverbs-devel >= 1.1.6
22 Requires:       libibverbs >= 1.1.6
23 # FIXME: gaspi_logger sources are missing
24 ExclusiveArch:  %{ix86} %{x8664}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 GPI-2 is the second generation of GPI (http://www.gpi-site.com/). GPI-2
29 implements the GASPI specification (http://www.gaspi.de/), an API
30 specification which originates from the ideas and concepts of GPI.
31
32 GPI-2 is an API for asynchronous communication. It provides a
33 flexible, scalable and fault tolerant interface for parallel
34 applications.
35
36 %description -l pl.UTF-8
37 GPI-2 to druga generacja GPI (http://www.gpi-site.com/). GPI-2
38 jest implementacją specyfikacji GASPI (http://www.gaspi.de/) - API
39 wywodzącego się z idei GPI.
40
41 GPI-2 to API do komunikacji asynchronicznej. Zapewnia elastyczny,
42 skalowalny i odporny na awarie interfejs do aplikacji równoległych.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48
49 # precompiled binaries
50 # FIXME: sources are missing
51 #%{__rm} bin/gaspi_logger
52
53 %build
54 %{__make} clean
55 %{__make} -C src depend
56 %{__make} gpi \
57         CC="%{__cc}" \
58         CFLAGS="%{rpmcflags} -Wall -D_GNU_SOURCE"
59 %if %{with f90}
60 %{__make} fortran
61 %endif
62
63 %if %{with tests}
64 %{__make} tests
65 %endif
66
67 %{__make} docs
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
72
73 install bin/gaspi_run.ssh $RPM_BUILD_ROOT%{_bindir}/gaspi_run
74 install bin/ssh.spawner bin/gaspi_cleanup bin/gaspi_logger $RPM_BUILD_ROOT%{_bindir}
75 cp -pr include $RPM_BUILD_ROOT%{_includedir}
76 cp -p lib64/lib* $RPM_BUILD_ROOT%{_libdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README docs/html
84 %attr(755,root,root) %{_bindir}/gaspi_cleanup
85 %attr(755,root,root) %{_bindir}/gaspi_logger
86 %attr(755,root,root) %{_bindir}/gaspi_run
87 %attr(755,root,root) %{_bindir}/ssh.spawner
88 %{_libdir}/libGPI2.a
89 %{_libdir}/libGPI2-dbg.a
90 %{_includedir}/GASPI.h
91 %{_includedir}/GASPI_GPU.h
92 %{_includedir}/GASPI_Threads.h
93 %{_includedir}/PGASPI.h
94 %{_includedir}/gaspi.mod
95 %{_includedir}/gaspi_types.mod
This page took 0.074245 seconds and 2 git commands to generate.