]> git.pld-linux.org Git - packages/FreeMat.git/blob - FreeMat.spec
- lots of BR for optional components
[packages/FreeMat.git] / FreeMat.spec
1 # TODO:
2 # - look at MPI support - doesn't work with lam for me :/
3 # - build with ARPACK, UMFPACK, CYCLE COUNTER (whatever it is)
4 #
5 %define         fversion        %(echo %{version} |tr r -)
6 %define         mversion        %(echo %{version} |cut -f -1 -d r)
7 Summary:        FreeMat - an environment for rapid engineering and scientific processing
8 Summary(pl.UTF-8):      FreeMat - środowisko do szybkiego przetwarzania inżynieryjnego i naukowego
9 Name:           FreeMat
10 Version:        3.5
11 Release:        1
12 License:        MIT
13 Group:          Applications/Math
14 Source0:        http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
15 # Source0-md5:  4cc41c1f9265a86134fd338076d1a65f
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-qt4.patch
18 Patch1:         %{name}-link.patch
19 URL:            http://freemat.sourceforge.net
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  ffcall-devel
23 BuildRequires:  fftw3-devel
24 BuildRequires:  fftw3-single-devel
25 BuildRequires:  gcc-g77
26 BuildRequires:  lapack-devel
27 BuildRequires:  ncurses-devel
28 BuildRequires:  pcre-devel
29 BuildRequires:  portaudio-devel
30 BuildRequires:  QtCore-devel
31 BuildRequires:  QtGui-devel
32 BuildRequires:  QtOpenGL-devel
33 BuildRequires:  QtNetwork-devel
34 BuildRequires:  QtXml-devel
35 BuildRequires:  qt4-build
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 FreeMat is a free environment for rapid entineering and scientific
40 prototyping and data processing. It is similar to commercial systems
41 such as MATLAB from Mathworks, and IDL from Research Systems, but is
42 Open Source. FreeMat includes several novel features such as a
43 codeless interface to external C/C++/FORTRAN code,
44 parallel/distributed algorithm development (via MPI), and plotting and
45 visualiation capabilities.
46
47 %description -l pl.UTF-8
48 FreeMat jest darmowym środowiskiem do szybkiego przetwarzania
49 prototypów i danych dla inżynierów i naukowców. Jest podobny do
50 komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
51 Group, ale na licencji Open Source. FreeMat cechuje się między innymi
52 bezkodowym interfejsem do zewnętrznego kodu C/C++/FORTRAN,
53 równoległym/rozproszonym algorytmem obliczeń (poprzez MPI), oraz
54 rysowaniem i wyświetlaniem możliwości.
55
56 %prep
57 %setup -q -n %{name}-%{mversion}
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
63 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --with-ncurses
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT \
78         prefix=$RPM_BUILD_ROOT%{_prefix}
79
80 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/%{name}
88 %{_datadir}/%{name}-%{version}
89 %{_desktopdir}/%{name}.desktop
This page took 0.037324 seconds and 4 git commands to generate.