]> git.pld-linux.org Git - packages/FreeMat.git/blob - FreeMat.spec
- removed lots of BR
[packages/FreeMat.git] / FreeMat.spec
1 # TODO:
2 # - look at MPI support - doesn't work with lam for me :/
3 # - build with ARPACK, UMFPACK, CYCLE COUNTER (whatever it is)
4 #
5 %define         fversion        %(echo %{version} |tr r -)
6 %define         mversion        %(echo %{version} |cut -f -1 -d r)
7 Summary:        FreeMat - an environment for rapid engineering and scientific processing
8 Summary(pl.UTF-8):      FreeMat - środowisko do szybkiego przetwarzania inżynieryjnego i naukowego
9 Name:           FreeMat
10 Version:        3.5
11 Release:        0.1
12 License:        MIT
13 Group:          Applications/Math
14 Source0:        http://dl.sourceforge.net/freemat/%{name}-%{fversion}.tar.gz
15 # Source0-md5:  4cc41c1f9265a86134fd338076d1a65f
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-qt4.patch
18 Patch1:         %{name}-link.patch
19 URL:            http://freemat.sourceforge.net
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gcc-g77
23 BuildRequires:  lapack-devel
24 BuildRequires:  ncurses-devel
25 BuildRequires:  QtCore-devel
26 BuildRequires:  QtGui-devel
27 BuildRequires:  QtOpenGL-devel
28 BuildRequires:  QtNetwork-devel
29 BuildRequires:  QtXml-devel
30 BuildRequires:  qt4-build
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 FreeMat is a free environment for rapid entineering and scientific
35 prototyping and data processing. It is similar to commercial systems
36 such as MATLAB from Mathworks, and IDL from Research Systems, but is
37 Open Source. FreeMat includes several novel features such as a
38 codeless interface to external C/C++/FORTRAN code,
39 parallel/distributed algorithm development (via MPI), and plotting and
40 visualiation capabilities.
41
42 %description -l pl.UTF-8
43 FreeMat jest darmowym środowiskiem do szybkiego przetwarzania
44 prototypów i danych dla inżynierów i naukowców. Jest podobny do
45 komercyjnych systemów takich jak MATLAB z Mathworks i IDL z Research
46 Group, ale na licencji Open Source. FreeMat cechuje się między innymi
47 bezkodowym interfejsem do zewnętrznego kodu C/C++/FORTRAN,
48 równoległym/rozproszonym algorytmem obliczeń (poprzez MPI), oraz
49 rysowaniem i wyświetlaniem możliwości.
50
51 %prep
52 %setup -q -n %{name}-%{mversion}
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
58 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
59 %{__aclocal}
60 %{__autoconf}
61 %{__automake}
62 %configure \
63         --with-ncurses
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_infodir},%{_desktopdir}}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT \
73         prefix=$RPM_BUILD_ROOT%{_prefix}
74
75 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_bindir}/%{name}
83 %{_datadir}/%{name}-%{version}
84 %{_desktopdir}/%{name}.desktop
This page took 0.091171 seconds and 4 git commands to generate.