]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- explicit files, lib cleanup
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es.UTF-8):      Terminal para Enlightenment
14 Summary(pl.UTF-8):      Terminal dla Enlightenmenta
15 Summary(pt_BR.UTF-8):   Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.6
18 Release:        1
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  90e424584c22d4050496874d14f78bb1
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 Patch2:         %{name}-ac_am.patch
31 Patch3:         %{name}-imlib.patch
32 URL:            http://www.eterm.org/
33 BuildRequires:  autoconf >= 2.53
34 BuildRequires:  automake
35 BuildRequires:  freetype1-devel
36 BuildRequires:  imlib2-devel >= 1.0.3
37 BuildRequires:  libast-devel >= 0.6
38 BuildRequires:  libltdl-devel
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel
41 BuildRequires:  pcre-devel
42 BuildRequires:  screen
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  twin-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Eterm is a color vt102 terminal emulator intended as an xterm(1)
50 replacement for users who want a term program integrated with
51 Enlightenment, or simply want a little more "eye candy". Eterm uses
52 Imlib for advanced graphic abilities.
53
54 %description -l es.UTF-8
55 Eterm es un emulador de terminal vt102 con soporte para colores,
56 desarrollado como un sustituto para el emulador xterm, para los
57 usuarios que deseen un emulador de terminal integrado con la
58 iluminación, o simplemente deseen algo más agradable visualmente. El
59 emulador Eterm usa Imlib para trabajar con gráficos.
60
61 %description -l pl.UTF-8
62 Eterm jest kolorowym emulatorem terminala vt102 mogącym być
63 zamiennikiem xterm(1) dla użytkowników chcących mieć program
64 terminalowy zintegrowany z zarządcą okienek o nazwie Enlightenment lub
65 dla tych którzy chcą mieć trochę bardziej urozmaicony wygląd tego typu
66 programu. Eterm używa biblioteki IMlib do zaawansowanego operowania na
67 grafice.
68
69 %description -l pt_BR.UTF-8
70 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
71 suporte a cores, desenvolvido para ser um substituto para o xterm,
72 para os usuários que queiram um emulador de terminal integrado com o
73 Enlightenment, ou simplesmente queiram algo mais agradável para os
74 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
75
76 %package -n Esetroot
77 Summary:        Utility to set root pixmap
78 Summary(pl.UTF-8):      Aplikacja ustawiająca tło nadrzędnego okna
79 Group:          X11/Window Managers/Tools
80 Provides:       WallpaperChanger
81
82 %description -n Esetroot
83 This program enables non-Enlightenment users to use
84 pseudotransparency.
85
86 %description -n Esetroot -l pl.UTF-8
87 Program ten umożliwia korzystanie z pseudoprzezroczystości
88 użytkownikom zarządców okien innych niż Enlightenment.
89
90 %prep
91 %setup -q -a1
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96
97 find themes/ -name "*.cfg*" -exec \
98         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
99
100 %build
101 %{__libtoolize}
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 # libast 0.8.0 no longer defines MEMSET
107 CPPFLAGS="%{rpmcppflags} -DMEMSET=memset"
108 %configure \
109         --disable-static        \
110         --enable-shared         \
111         --enable-escreen        \
112         --enable-etwin          \
113         --enable-escreen-fx     \
114         --enable-profile        \
115         --enable-trans          \
116 %if %{with mmx}
117         --enable-mmx            \
118 %else
119         --disable-mmx           \
120 %endif
121 %if %{with sse2}
122         --enable-sse2           \
123 %else
124         --disable-sse2          \
125 %endif
126         --enable-utmp           \
127         --enable-auto-encoding  \
128         --enable-multi-charset  \
129         --disable-stack-trace   \
130         --enable-name-reporting-escapes \
131         --without-debugging
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libEterm.{so,la}
142
143 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
144 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
145 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc doc/*.html ReleaseNotes* ChangeLog
156 %attr(755,root,root) %{_bindir}/Eterm
157 %attr(755,root,root) %{_bindir}/Etbg
158 %attr(755,root,root) %{_bindir}/Etcolors
159 %attr(755,root,root) %{_bindir}/Ettable
160 %attr(755,root,root) %{_bindir}/Etbg_update_list
161 %attr(755,root,root) %{_bindir}/Etsearch
162 %attr(755,root,root) %{_libdir}/libEterm-%{version}.so
163 %{_mandir}/man1/Eterm.1*
164 %{_datadir}/Eterm
165 %{_desktopdir}/Escreen.desktop
166 %{_desktopdir}/Eterm.desktop
167 %{_pixmapsdir}/gnome-eterm.png
168
169 %files -n Esetroot
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/Esetroot
172 %attr(755,root,root) %{_bindir}/kEsetroot
This page took 0.076202 seconds and 3 git commands to generate.