]> git.pld-linux.org Git - packages/Eterm.git/blob - Eterm.spec
- release 2
[packages/Eterm.git] / Eterm.spec
1 #
2 # Conditional build:
3 %bcond_with     mmx             # use MMX instructions
4 %bcond_with     sse2            # use SSE2 instructions
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 %ifarch %{x8664}
10 %define         with_sse2       1
11 %endif
12 Summary:        Terminal for Enlightenment
13 Summary(es.UTF-8):      Terminal para Enlightenment
14 Summary(pl.UTF-8):      Terminal dla Enlightenmenta
15 Summary(pt_BR.UTF-8):   Eterm versão %{version}
16 Name:           Eterm
17 Version:        0.9.6
18 Release:        2
19 License:        BSD
20 Group:          X11/Applications
21 Source0:        http://www.eterm.org/download/%{name}-%{version}.tar.gz
22 # Source0-md5:  90e424584c22d4050496874d14f78bb1
23 Source1:        http://www.eterm.org/download/%{name}-bg-%{version}.tar.gz
24 # Source1-md5:  e8c6567b13d7fb760bded56c1d1a181d
25 Source2:        %{name}.desktop
26 Source3:        Escreen.desktop
27 Source4:        gnome-eterm.png
28 Patch0:         %{name}-am_fix.patch
29 Patch1:         %{name}-keys-theme.patch
30 Patch2:         %{name}-ac_am.patch
31 Patch3:         %{name}-imlib.patch
32 URL:            http://www.eterm.org/
33 BuildRequires:  autoconf >= 2.53
34 BuildRequires:  automake
35 BuildRequires:  freetype1-devel
36 BuildRequires:  imlib2-devel >= 1.0.3
37 BuildRequires:  libast-devel >= 0.6
38 BuildRequires:  libltdl-devel
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel
41 BuildRequires:  pcre-devel
42 BuildRequires:  screen
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  twin-devel
45 BuildRequires:  xorg-lib-libX11-devel
46 BuildRequires:  xorg-lib-libXres-devel
47 BuildRequires:  xorg-lib-libXext-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Eterm is a color vt102 terminal emulator intended as an xterm(1)
52 replacement for users who want a term program integrated with
53 Enlightenment, or simply want a little more "eye candy". Eterm uses
54 Imlib for advanced graphic abilities.
55
56 %description -l es.UTF-8
57 Eterm es un emulador de terminal vt102 con soporte para colores,
58 desarrollado como un sustituto para el emulador xterm, para los
59 usuarios que deseen un emulador de terminal integrado con la
60 iluminación, o simplemente deseen algo más agradable visualmente. El
61 emulador Eterm usa Imlib para trabajar con gráficos.
62
63 %description -l pl.UTF-8
64 Eterm jest kolorowym emulatorem terminala vt102 mogącym być
65 zamiennikiem xterm(1) dla użytkowników chcących mieć program
66 terminalowy zintegrowany z zarządcą okienek o nazwie Enlightenment lub
67 dla tych którzy chcą mieć trochę bardziej urozmaicony wygląd tego typu
68 programu. Eterm używa biblioteki IMlib do zaawansowanego operowania na
69 grafice.
70
71 %description -l pt_BR.UTF-8
72 O Eterm -- versão %{version} -- é um emulador de terminal vt102 com
73 suporte a cores, desenvolvido para ser um substituto para o xterm,
74 para os usuários que queiram um emulador de terminal integrado com o
75 Enlightenment, ou simplesmente queiram algo mais agradável para os
76 olhos. O Eterm usa a Imlib para trabalhar com gráficos.
77
78 %package -n Esetroot
79 Summary:        Utility to set root pixmap
80 Summary(pl.UTF-8):      Aplikacja ustawiająca tło nadrzędnego okna
81 Group:          X11/Window Managers/Tools
82 Provides:       WallpaperChanger
83
84 %description -n Esetroot
85 This program enables non-Enlightenment users to use
86 pseudotransparency.
87
88 %description -n Esetroot -l pl.UTF-8
89 Program ten umożliwia korzystanie z pseudoprzezroczystości
90 użytkownikom zarządców okien innych niż Enlightenment.
91
92 %prep
93 %setup -q -a1
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98
99 find themes/ -name "*.cfg*" -exec \
100         sed -i 's/<Eterm-0\.9\..>/<Eterm-%{version}>/' "{}" ";"
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 # libast 0.8.0 no longer defines MEMSET
109 CPPFLAGS="%{rpmcppflags} -DMEMSET=memset"
110 %configure \
111         --disable-static        \
112         --enable-shared         \
113         --enable-escreen        \
114         --enable-etwin          \
115         --enable-escreen-fx     \
116         --enable-profile        \
117         --enable-trans          \
118 %if %{with mmx}
119         --enable-mmx            \
120 %else
121         --disable-mmx           \
122 %endif
123 %if %{with sse2}
124         --enable-sse2           \
125 %else
126         --disable-sse2          \
127 %endif
128         --enable-utmp           \
129         --enable-auto-encoding  \
130         --enable-multi-charset  \
131         --disable-stack-trace   \
132         --enable-name-reporting-escapes \
133         --without-debugging
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_desktopdir},%{_pixmapsdir}}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libEterm.{so,la}
144
145 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
146 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
147 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_pixmapsdir}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc doc/*.html ReleaseNotes* ChangeLog
158 %attr(755,root,root) %{_bindir}/Eterm
159 %attr(755,root,root) %{_bindir}/Etbg
160 %attr(755,root,root) %{_bindir}/Etcolors
161 %attr(755,root,root) %{_bindir}/Ettable
162 %attr(755,root,root) %{_bindir}/Etbg_update_list
163 %attr(755,root,root) %{_bindir}/Etsearch
164 %attr(755,root,root) %{_libdir}/libEterm-%{version}.so
165 %{_mandir}/man1/Eterm.1*
166 %{_datadir}/Eterm
167 %{_desktopdir}/Escreen.desktop
168 %{_desktopdir}/Eterm.desktop
169 %{_pixmapsdir}/gnome-eterm.png
170
171 %files -n Esetroot
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/Esetroot
174 %attr(755,root,root) %{_bindir}/kEsetroot
This page took 0.106506 seconds and 3 git commands to generate.