]> git.pld-linux.org Git - packages/DevIL.git/blob - DevIL.spec
- BR: pkgconfig
[packages/DevIL.git] / DevIL.spec
1 #
2 # TODO: package rest of files
3 #
4 %define         manual_version  1.5.5
5 Summary:        Full featured image library
6 Summary(pl.UTF-8):      Biblioteka obsługi obrazów z mnóstwem funkcji
7 Name:           DevIL
8 Version:        1.7.8
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/openil/%{name}-%{version}.tar.gz
13 # Source0-md5:  7918f215524589435e5ec2e8736d5e1d
14 Source1:        http://downloads.sourceforge.net/openil/%{name}-Manual-%{manual_version}.zip
15 # Source1-md5:  6bb2ddfcbe09930c48ef84b8f99479fe
16 Source2:        http://downloads.sourceforge.net/openil/%{name}-docs.tar.gz
17 # Source2-md5:  eec6ae7a028a3f058bab1a6918428ed5
18 Patch0:         %{name}-gnu-inline.patch
19 Patch1:         libpng14.patch
20 URL:            http://openil.sourceforge.net/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  SDL-devel >= 1.2.5
23 BuildRequires:  allegro-devel >= 4.1.16
24 BuildRequires:  autoconf >= 2.52
25 BuildRequires:  automake
26 BuildRequires:  jasper-devel
27 BuildRequires:  lcms-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libmng-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  libtiff-devel
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.533
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  unzip
37 Requires:       allegro >= 4.1.16
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
41
42 %description
43 Developer's Image Library (DevIL) is a programmer's library to develop
44 applications with very powerful image loading capabilities, yet is
45 easy for a developer to learn and use. Ultimate control of images is
46 left to the developer, so unnecessary conversions, etc. are not
47 performed. DevIL utilizes a simple, yet powerful, syntax. DevIL can
48 load, save, convert, manipulate, filter and display a wide variety of
49 image formats.
50
51 Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .icns,
52 .jp2, .jpg, .lbm, .mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic,
53 .png, .ppm, .psd, .psp, .raw, .sgi, .tga and .tif files.
54
55 Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm,
56 .pcx, .pgm, .png, .ppm, .raw, .sgi, .tga and .tif.
57
58 %description -l pl.UTF-8
59 Developer's Image Library (DevIL) jest biblioteką programisty
60 pozwalającą tworzyć aplikacje z potężnymi możliwościami ładowania
61 obrazów. Pozostaje przy tym łatwa w użyciu i prosta do nauczenia się.
62 Ostateczna kontrola nad obrazami jest zostawiona programiście, nie
63 wprowadza się niepotrzebnych konwersji, itp. DevIL używa prostej, lecz
64 potężnej składni poleceń, wzorowanej na OpenGL-u. DevIL potrafi
65 ładować, zapisywać, konwertować, manipulować, filtrować szeroki
66 wachlarz formatów plików graficznych.
67
68 W chwili obecnej DevIL odczytuje pliki z rozszerzeniami bmp, cut, dds,
69 doom, gif, icns, ico, jp2, jpg, lbm, mdl, mng, pal, pbm, pcd, pcx,
70 pgm, pic, png, ppm, psd, psp, raw, sgi, tga i tif.
71
72 Wspierane jest zapisywanie do plików bmp, dds, h, jpg, pal, pbm, pcx,
73 pgm, png, ppm, raw, sgi, tga i tif.
74
75 %package devel
76 Summary:        DevIL devel files
77 Summary(pl.UTF-8):      Nagłówki DevIL
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       jasper-devel
81 Requires:       lcms-devel
82 Requires:       libjpeg-devel
83 Requires:       libmng-devel
84 Requires:       libpng-devel
85 Requires:       libtiff-devel
86 # libILUT additionally: SDL-devel, allegro-devel, OpenGL-GLU-devel
87
88 %description devel
89 DevIL devel files.
90
91 %description devel -l pl.UTF-8
92 Nagłówki DevIL.
93
94 %package doc
95 Summary:        DevIL documentation
96 Summary(pl.UTF-8):      Dokumentacja DevIL
97 Group:          Documentation
98
99 %description doc
100 DevIL documentation.
101
102 %description doc -l pl.UTF-8
103 Dokumentacja DevIL.
104
105 %prep
106 %setup -q -c -a1 -a2
107 %patch0 -p1
108 %patch1 -p1
109
110 # lpng12 -> lpng
111 %{__sed} -i 's,png12,png,' devil-%{version}/m4/devil-definitions.m4
112
113 # just SDL and messing libtool macros
114 rm -f acinclude.m4
115
116 %build
117 cd devil-%{version}
118 %{__libtoolize}
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 # actual exr support missing in sources, only adds undefined symbol
124 CPPFLAGS="%{rpmcppflags} -DIL_NO_EXR"
125 %configure \
126         --enable-ILU=yes \
127         --enable-ILUT=yes \
128         %{?debug:--disable-release}
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} -C devil-%{version} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %doc devil-%{version}/{AUTHORS,CREDITS,ChangeLog,README.unix}
146 %attr(755,root,root) %{_libdir}/libIL.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libIL.so.1
148 %attr(755,root,root) %{_libdir}/libILU.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libILU.so.1
150 %attr(755,root,root) %{_libdir}/libILUT.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libILUT.so.1
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libIL.so
156 %attr(755,root,root) %{_libdir}/libILU.so
157 %attr(755,root,root) %{_libdir}/libILUT.so
158 %{_libdir}/libIL.la
159 %{_libdir}/libILU.la
160 %{_libdir}/libILUT.la
161 %{_includedir}/IL
162
163 %files doc
164 %defattr(644,root,root,755)
165 %doc DevIL*.pdf
This page took 0.217587 seconds and 3 git commands to generate.