]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
- directfb into bcond and off (unsupported by upstream); updated files
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_without  ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     directb         # unsupported by upstream
7 %bcond_with     samples         # build samples
8 #
9 Summary:        CEGUI - a free library providing windowing and widgets
10 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
11 Name:           CEGUI
12 Version:        0.8.4
13 Release:        1
14 License:        LGPL v2.1+ (with MIT parts)
15 Group:          Libraries
16 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
17 # Source0-md5:  344917301b5ed867a07575ee6a828667
18 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
19 # Source1-md5:  1096bf8c84bf6a22e8892ab9258c22f6
20 Patch0:         pthread.patch
21 Patch1:         %{name}-glfw3.patch
22 URL:            http://www.cegui.org.uk/
23 BuildRequires:  DevIL-devel
24 %{?with_directfb:BuildRequires: DirectFB-devel >= 1.2.0}
25 BuildRequires:  FreeImage-devel
26 BuildRequires:  SILLY-devel >= 0.1.0
27 BuildRequires:  boost-devel >= 1.36.0
28 BuildRequires:  boost-python-devel >= 1.36.0
29 BuildRequires:  cmake >= 2.8
30 BuildRequires:  corona-devel
31 BuildRequires:  doxygen
32 BuildRequires:  expat-devel
33 BuildRequires:  fribidi-devel
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  glfw-devel
36 BuildRequires:  gtk+2-devel >= 2:2.4
37 BuildRequires:  irrlicht-devel >= 1.4
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libxml2-devel >= 1:2.6
41 BuildRequires:  lua51-devel >= 5.1
42 BuildRequires:  minizip-devel
43 %if %{with ogre}
44 BuildRequires:  ogre-devel >= 1.6.0
45 BuildRequires:  ois-devel >= 1.0.0
46 %endif
47 BuildRequires:  pcre-devel >= 5.0
48 BuildRequires:  pkgconfig
49 BuildRequires:  python-devel
50 BuildRequires:  rapidxml
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  tinyxml-devel
53 BuildRequires:  tolua++-devel
54 %{?with_xercesc:BuildRequires:  xerces-c-devel}
55 # for irrlicht renderer
56 BuildRequires:  xorg-lib-libXxf86vm-devel
57 %if %{with opengl}
58 BuildRequires:  GLM
59 BuildRequires:  OpenGL-GLU-devel
60 BuildRequires:  glew-devel
61 BuildRequires:  glfw-devel
62 %endif
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 CEGUI stands for Crazy Eddie's Gui System; a free library providing
67 windowing and widgets for graphics APIs / engines where such
68 functionality is not natively available, or severely lacking. The
69 library is object orientated, written in C++, and targeted at games
70 developers who should be spending their time creating great games, not
71 building GUI sub-systems!
72
73 %description -l pl.UTF-8
74 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
75 zapewniającą okienka i widgety dla graficznych API i silników tam,
76 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
77 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
78 skierowana dla programistów gier, którzy powinni spędzać czas na
79 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
80
81 %package devel
82 Summary:        Development files for CEGUI
83 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       freetype-devel >= 2.0
87 Requires:       libstdc++-devel
88 Requires:       pcre-devel >= 5.0
89
90 %description devel
91 CEGUI headers.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe CEGUI.
95
96 %package docs
97 Summary:        Documentation files for CEGUI
98 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
99 Group:          Documentation
100 Requires:       %{name} = %{version}-%{release}
101
102 %description docs
103 CEGUI documentation.
104
105 %description docs -l pl.UTF-8
106 Dokumentacja CEGUI.
107
108 %package ImageCodec-Corona
109 Summary:        CoronaImageCodec library for CEGUI
110 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
111 Group:          Libraries
112 Requires:       %{name} = %{version}-%{release}
113
114 %description ImageCodec-Corona
115 CoronaImageCodec library for CEGUI.
116
117 %description ImageCodec-Corona -l pl.UTF-8
118 Biblioteka CoronaImageCodec dla CEGUI
119
120 %package ImageCodec-Corona-devel
121 Summary:        Header files for CEGUI CoronaImageCodec library
122 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
123 Group:          Development/Libraries
124 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
125 Requires:       %{name}-devel = %{version}-%{release}
126 Requires:       corona-devel
127
128 %description ImageCodec-Corona-devel
129 Header files for CEGUI CoronaImageCodec library.
130
131 %description ImageCodec-Corona-devel -l pl.UTF-8
132 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
133
134 %package ImageCodec-DevIL
135 Summary:        DevILImageCodec library for CEGUI
136 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139
140 %description ImageCodec-DevIL
141 DevILImageCodec library for CEGUI.
142
143 %description ImageCodec-DevIL -l pl.UTF-8
144 Biblioteka DevILImageCodec dla CEGUI
145
146 %package ImageCodec-DevIL-devel
147 Summary:        Header files for CEGUI DevILImageCodec library
148 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
149 Group:          Development/Libraries
150 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
151 Requires:       %{name}-devel = %{version}-%{release}
152 Requires:       DevIL-devel
153
154 %description ImageCodec-DevIL-devel
155 Header files for CEGUI DevILImageCodec library.
156
157 %description ImageCodec-DevIL-devel -l pl.UTF-8
158 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
159
160 %package ImageCodec-FreeImage
161 Summary:        FreeImageImageCodec library for CEGUI
162 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
163 Group:          Libraries
164 Requires:       %{name} = %{version}-%{release}
165
166 %description ImageCodec-FreeImage
167 FreeImageImageCodec library for CEGUI.
168
169 %description ImageCodec-FreeImage -l pl.UTF-8
170 Biblioteka FreeImageImageCodec dla CEGUI
171
172 %package ImageCodec-FreeImage-devel
173 Summary:        Header files for CEGUI FreeImageImageCodec library
174 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
175 Group:          Development/Libraries
176 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
177 Requires:       %{name}-devel = %{version}-%{release}
178 Requires:       FreeImage-devel
179
180 %description ImageCodec-FreeImage-devel
181 Header files for CEGUI FreeImageImageCodec library.
182
183 %description ImageCodec-FreeImage-devel -l pl.UTF-8
184 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
185
186 %package ImageCodec-SILLY
187 Summary:        SILLYImageCodec library for CEGUI
188 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
189 Group:          Libraries
190 Requires:       %{name} = %{version}-%{release}
191 Requires:       SILLY >= 0.1.0
192
193 %description ImageCodec-SILLY
194 SILLYImageCodec library for CEGUI.
195
196 %description ImageCodec-SILLY -l pl.UTF-8
197 Biblioteka SILLYImageCodec dla CEGUI
198
199 %package ImageCodec-SILLY-devel
200 Summary:        Header files for CEGUI SILLYImageCodec library
201 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
202 Group:          Development/Libraries
203 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
204 Requires:       %{name}-devel = %{version}-%{release}
205 Requires:       SILLY-devel >= 0.1.0
206
207 %description ImageCodec-SILLY-devel
208 Header files for CEGUI SILLYImageCodec library.
209
210 %description ImageCodec-SILLY-devel -l pl.UTF-8
211 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
212
213 %package Parser-Expat
214 Summary:        Expat-based XML parser module
215 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218
219 %description Parser-Expat
220 Expat-based XML parser module.
221
222 %description Parser-Expat -l pl.UTF-8
223 Moduł analizatora XML oparty na bibliotece Expat.
224
225 %package Parser-LibXML
226 Summary:        LibXML-based XML parser module
227 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
228 Group:          Libraries
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       libxml2 >= 1:2.6
231
232 %description Parser-LibXML
233 LibXML-based XML parser module.
234
235 %description Parser-LibXML -l pl.UTF-8
236 Moduł analizatora XML oparty na bibliotece LibXML.
237
238 %package Parser-RapidXML
239 Summary:        RapidXML-based XML parser module
240 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243
244 %description Parser-RapidXML
245 RapidXML-based XML parser module.
246
247 %description Parser-RapidXML -l pl.UTF-8
248 Moduł analizatora XML oparty na bibliotece RapidXML.
249
250 %package Parser-TinyXML
251 Summary:        TinyXML-based XML parser module
252 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255
256 %description Parser-TinyXML
257 TinyXML-based XML parser module.
258
259 %description Parser-TinyXML -l pl.UTF-8
260 Moduł analizatora XML oparty na bibliotece TinyXML.
261
262 %package Parser-Xerces
263 Summary:        Xerces-based XML parser module
264 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267
268 %description Parser-Xerces
269 Xerces-based XML parser module.
270
271 %description Parser-Xerces -l pl.UTF-8
272 Moduł analizatora XML oparty na bibliotece Xerces.
273
274 %package Renderer-DirectFB
275 Summary:        DirectFBRenderer library for CEGUI
276 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       DirectFB >= 1.2.0
280
281 %description Renderer-DirectFB
282 DirectFBRenderer library for CEGUI.
283
284 %description Renderer-DirectFB -l pl.UTF-8
285 Biblioteka DirectFBRenderer dla CEGUI
286
287 %package Renderer-DirectFB-devel
288 Summary:        Header files for CEGUI DirectFBRenderer library
289 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
290 Group:          Development/Libraries
291 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
292 Requires:       %{name}-devel = %{version}-%{release}
293 Requires:       DirectFB-devel >= 1.2.0
294
295 %description Renderer-DirectFB-devel
296 Header files for CEGUI DirectFBRenderer library.
297
298 %description Renderer-DirectFB-devel -l pl.UTF-8
299 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
300
301 %package Renderer-Irrlicht
302 Summary:        IrrlichtRenderer library for CEGUI
303 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
304 Group:          Libraries
305 Requires:       %{name} = %{version}-%{release}
306 Requires:       irrlicht >= 1.4
307
308 %description Renderer-Irrlicht
309 IrrlichtRenderer library for CEGUI.
310
311 %description Renderer-Irrlicht -l pl.UTF-8
312 Biblioteka IrrlichtRenderer dla CEGUI
313
314 %package Renderer-Irrlicht-devel
315 Summary:        Header files for CEGUI IrrlichtRenderer library
316 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
317 Group:          Development/Libraries
318 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
319 Requires:       %{name}-devel = %{version}-%{release}
320 Requires:       irrlicht-devel >= 1.4
321
322 %description Renderer-Irrlicht-devel
323 Header files for CEGUI IrrlichtRenderer library.
324
325 %description Renderer-Irrlicht-devel -l pl.UTF-8
326 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
327
328 %package Renderer-Ogre
329 Summary:        OgreRenderer library for CEGUI
330 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
331 Group:          Libraries
332 Requires:       %{name} = %{version}-%{release}
333 Obsoletes:      CEGUI-Ogre
334
335 %description Renderer-Ogre
336 OgreRenderer library for CEGUI.
337
338 %description Renderer-Ogre -l pl.UTF-8
339 Biblioteka OgreRenderer dla CEGUI
340
341 %package Renderer-Ogre-devel
342 Summary:        Header files for CEGUI OgreRenderer library
343 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
344 Group:          Development/Libraries
345 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
346 Requires:       %{name}-devel = %{version}-%{release}
347 Requires:       ogre-devel >= 1.6.0
348 Obsoletes:      CEGUI-Ogre-devel
349
350 %description Renderer-Ogre-devel
351 Header files for CEGUI OgreRenderer library.
352
353 %description Renderer-Ogre-devel -l pl.UTF-8
354 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
355
356 %package Renderer-OpenGL
357 Summary:        OpenGLRenderer library for CEGUI
358 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
359 Group:          Libraries
360 Requires:       %{name} = %{version}-%{release}
361 Obsoletes:      CEGUI-OpenGL
362
363 %description Renderer-OpenGL
364 OpenGLRenderer library for CEGUI.
365
366 %description Renderer-OpenGL -l pl.UTF-8
367 Biblioteka OpenGLRenderer dla CEGUI.
368
369 %package Renderer-OpenGL-devel
370 Summary:        Header files for CEGUI OpenGLRenderer library
371 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
372 Group:          Development/Libraries
373 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
374 Requires:       %{name}-devel = %{version}-%{release}
375 Requires:       OpenGL-GLU-devel
376 Requires:       OpenGL-glut-devel
377 Requires:       glew-devel
378 Obsoletes:      CEGUI-OpenGL-devel
379
380 %description Renderer-OpenGL-devel
381 Header files for CEGUI OpenGLRenderer library.
382
383 %description Renderer-OpenGL-devel -l pl.UTF-8
384 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
385
386 %package -n python-CEGUI
387 Summary:        Python binding for CEGUI
388 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
389 Group:          Libraries/Python
390 Requires:       %{name} = %{version}-%{release}
391
392 %description -n python-CEGUI
393 Python binding for CEGUI.
394
395 %description -n python-CEGUI -l pl.UTF-8
396 Wiązania Pythona do CEGUI.
397
398 %package -n python-CEGUI-Renderer-Ogre
399 Summary:        Python binding for CEGUI OgreRenderer library
400 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
401 Group:          Libraries/Python
402 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
403 Requires:       python-CEGUI = %{version}-%{release}
404
405 %description -n python-CEGUI-Renderer-Ogre
406 Python binding for CEGUI OgreRenderer library.
407
408 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
409 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
410
411 %package -n python-CEGUI-Renderer-OpenGL
412 Summary:        Python binding for CEGUI OpenGLRenderer library
413 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
414 Group:          Libraries/Python
415 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
416 Requires:       python-CEGUI = %{version}-%{release}
417
418 %description -n python-CEGUI-Renderer-OpenGL
419 Python binding for CEGUI OpenGLRenderer library.
420
421 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
422 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
423
424 %prep
425 %setup -q -a 1 -n cegui-%{version}
426 %patch0 -p1
427 %patch1 -p1
428
429 %build
430 install -d build
431 cd build
432 %cmake .. \
433         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
434         -DCEGUI_BUILD_RENDERER_DIRECTFB:BOOL=%{?with_directfb:ON}%{!?with_directfb:OFF} \
435         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
436         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
437         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
438         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
439         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
440         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
441
442 %{__make} -j1
443
444 %install
445 rm -rf $RPM_BUILD_ROOT
446
447 %{__make} -C build install/fast \
448         DESTDIR=$RPM_BUILD_ROOT
449
450 %if %{without samples}
451 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
452 %endif
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %post   -p /sbin/ldconfig
458 %postun -p /sbin/ldconfig
459
460 %post   Renderer-Irrlicht -p /sbin/ldconfig
461 %postun Renderer-Irrlicht -p /sbin/ldconfig
462 %post   Renderer-Ogre -p /sbin/ldconfig
463 %postun Renderer-Ogre -p /sbin/ldconfig
464 %post   Renderer-OpenGL -p /sbin/ldconfig
465 %postun Renderer-OpenGL -p /sbin/ldconfig
466
467 %files
468 %defattr(644,root,root,755)
469 %doc doc/README.orig
470 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
472 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
474 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
475 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
476 # plugins
477 %dir %{_libdir}/cegui-0.8
478 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
479
480 %files docs
481 %defattr(644,root,root,755)
482 %doc cegui-docs-%{version}/*
483
484 %files devel
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
487 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
488 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
489 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
490 %dir %{_includedir}/cegui-0
491 %dir %{_includedir}/cegui-0/%{name}
492 %{_includedir}/cegui-0/%{name}/*.h
493 %{_includedir}/cegui-0/%{name}/CommonDialogs
494 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
495 %dir %{_includedir}/cegui-0/%{name}/RendererModules
496 %{_includedir}/cegui-0/%{name}/ScriptModules
497 %{_includedir}/cegui-0/%{name}/WindowRendererSets
498 %{_includedir}/cegui-0/%{name}/XMLParserModules
499 %{_includedir}/cegui-0/%{name}/falagard
500 %{_includedir}/cegui-0/%{name}/widgets
501 %{_pkgconfigdir}/CEGUI-0.pc
502 %{_pkgconfigdir}/CEGUI-0-LUA.pc
503
504 %files ImageCodec-Corona
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
507
508 %files ImageCodec-Corona-devel
509 %defattr(644,root,root,755)
510 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
511
512 %files ImageCodec-DevIL
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
515
516 %files ImageCodec-DevIL-devel
517 %defattr(644,root,root,755)
518 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
519
520 %files ImageCodec-FreeImage
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
523
524 %files ImageCodec-FreeImage-devel
525 %defattr(644,root,root,755)
526 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
527
528 %files ImageCodec-SILLY
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
531
532 %files ImageCodec-SILLY-devel
533 %defattr(644,root,root,755)
534 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
535
536 %files Parser-Expat
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
539
540 %files Parser-LibXML
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
543
544 %files Parser-RapidXML
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
547
548 %files Parser-TinyXML
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
551
552 %files Parser-Xerces
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
555
556 %if %{with directfb}
557 %files Renderer-DirectFB
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
561
562 %files Renderer-DirectFB-devel
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
565 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
566 %endif
567
568 %files Renderer-Irrlicht
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
572
573 %files Renderer-Irrlicht-devel
574 %defattr(644,root,root,755)
575 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
576 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
577 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
578
579 %if %{with ogre}
580 %files Renderer-Ogre
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
584
585 %files Renderer-Ogre-devel
586 %defattr(644,root,root,755)
587 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
588 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
589 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
590 %endif
591
592 %if %{with opengl}
593 %files Renderer-OpenGL
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
596 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
597
598 %files Renderer-OpenGL-devel
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
601 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
602 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
603 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
604 %endif
605
606 %files -n python-CEGUI
607 %defattr(644,root,root,755)
608 %dir %{py_sitedir}/cegui-0.8
609 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
610
611 %if %{with ogre}
612 %files -n python-CEGUI-Renderer-Ogre
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
615 %endif
616
617 %if %{with opengl}
618 %files -n python-CEGUI-Renderer-OpenGL
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
621 %endif
This page took 0.061537 seconds and 3 git commands to generate.