]> git.pld-linux.org Git - packages/CEGUI.git/blob - CEGUI.spec
161103746f42d64d303a7038bcc811966a16766a
[packages/CEGUI.git] / CEGUI.spec
1 #
2 # Conditional build:
3 %bcond_without  xercesc         # build XercesParser
4 %bcond_without  ogre            # build without Ogre renderer
5 %bcond_without  opengl          # build without OpenGL renderer
6 %bcond_with     samples         # build samples
7 #
8 Summary:        CEGUI - a free library providing windowing and widgets
9 Summary(pl.UTF-8):      CEGUI - wolnodostępna biblioteka zapewniającą okienka i widgety
10 Name:           CEGUI
11 Version:        0.8.4
12 Release:        1
13 License:        LGPL v2.1+ (with MIT parts)
14 Group:          Libraries
15 Source0:        http://downloads.sourceforge.net/crayzedsgui/cegui-%{version}.tar.bz2
16 # Source0-md5:  344917301b5ed867a07575ee6a828667
17 Source1:        http://downloads.sourceforge.net/crayzedsgui/cegui-docs-%{version}.tar.bz2
18 # Source1-md5:  1096bf8c84bf6a22e8892ab9258c22f6
19 Patch0:         pthread.patch
20 Patch2:         %{name}-glfw3.patch
21 URL:            http://www.cegui.org.uk/
22 BuildRequires:  DevIL-devel
23 BuildRequires:  DirectFB-devel >= 1.2.0
24 BuildRequires:  FreeImage-devel
25 BuildRequires:  SILLY-devel >= 0.1.0
26 BuildRequires:  boost-devel >= 1.36.0
27 BuildRequires:  boost-python-devel >= 1.36.0
28 BuildRequires:  cmake >= 2.8
29 BuildRequires:  corona-devel
30 BuildRequires:  doxygen
31 BuildRequires:  expat-devel
32 BuildRequires:  fribidi-devel
33 BuildRequires:  freetype-devel >= 2.0
34 BuildRequires:  glfw-devel
35 BuildRequires:  gtk+2-devel >= 2:2.4
36 BuildRequires:  irrlicht-devel >= 1.4
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 1:2.6
40 BuildRequires:  lua51-devel >= 5.1
41 BuildRequires:  minizip-devel
42 %if %{with ogre}
43 BuildRequires:  ogre-devel >= 1.6.0
44 BuildRequires:  ois-devel >= 1.0.0
45 %endif
46 BuildRequires:  pcre-devel >= 5.0
47 BuildRequires:  pkgconfig
48 BuildRequires:  python-devel
49 BuildRequires:  rapidxml
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  tinyxml-devel
52 BuildRequires:  tolua++-devel
53 %{?with_xercesc:BuildRequires:  xerces-c-devel}
54 # for irrlicht renderer
55 BuildRequires:  xorg-lib-libXxf86vm-devel
56 %if %{with opengl}
57 BuildRequires:  GLM
58 BuildRequires:  OpenGL-GLU-devel
59 BuildRequires:  glew-devel
60 BuildRequires:  glfw-devel
61 %endif
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 CEGUI stands for Crazy Eddie's Gui System; a free library providing
66 windowing and widgets for graphics APIs / engines where such
67 functionality is not natively available, or severely lacking. The
68 library is object orientated, written in C++, and targeted at games
69 developers who should be spending their time creating great games, not
70 building GUI sub-systems!
71
72 %description -l pl.UTF-8
73 CEGUI oznacza Crazy Eddie's Gui System - wolnodostępną bibliotekę
74 zapewniającą okienka i widgety dla graficznych API i silników tam,
75 gdzie natywnie taka funkcjonalność nie jest dostępna lub ma znaczące
76 braki. Biblioteka jest zorientowana obiektowo, napisana w C++ i
77 skierowana dla programistów gier, którzy powinni spędzać czas na
78 pisaniu świetnych gier, a nie tworzeniu podsystemów GUI!
79
80 %package devel
81 Summary:        Development files for CEGUI
82 Summary(pl.UTF-8):      Pliki programistyczne dla CEGUI
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       freetype-devel >= 2.0
86 Requires:       libstdc++-devel
87 Requires:       pcre-devel >= 5.0
88
89 %description devel
90 CEGUI headers.
91
92 %description devel -l pl.UTF-8
93 Pliki nagłówkowe CEGUI.
94
95 %package docs
96 Summary:        Documentation files for CEGUI
97 Summary(pl.UTF-8):      Pliki dokumentacji CEGUI
98 Group:          Documentation
99 Requires:       %{name} = %{version}-%{release}
100
101 %description docs
102 CEGUI documentation.
103
104 %description docs -l pl.UTF-8
105 Dokumentacja CEGUI.
106
107 %package ImageCodec-Corona
108 Summary:        CoronaImageCodec library for CEGUI
109 Summary(pl.UTF-8):      Biblioteka CoronaImageCodec dla CEGUI
110 Group:          Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description ImageCodec-Corona
114 CoronaImageCodec library for CEGUI.
115
116 %description ImageCodec-Corona -l pl.UTF-8
117 Biblioteka CoronaImageCodec dla CEGUI
118
119 %package ImageCodec-Corona-devel
120 Summary:        Header files for CEGUI CoronaImageCodec library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec
122 Group:          Development/Libraries
123 Requires:       %{name}-ImageCodec-Corona = %{version}-%{release}
124 Requires:       %{name}-devel = %{version}-%{release}
125 Requires:       corona-devel
126
127 %description ImageCodec-Corona-devel
128 Header files for CEGUI CoronaImageCodec library.
129
130 %description ImageCodec-Corona-devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki CEGUI CoronaImageCodec.
132
133 %package ImageCodec-DevIL
134 Summary:        DevILImageCodec library for CEGUI
135 Summary(pl.UTF-8):      Biblioteka DevILImageCodec dla CEGUI
136 Group:          Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description ImageCodec-DevIL
140 DevILImageCodec library for CEGUI.
141
142 %description ImageCodec-DevIL -l pl.UTF-8
143 Biblioteka DevILImageCodec dla CEGUI
144
145 %package ImageCodec-DevIL-devel
146 Summary:        Header files for CEGUI DevILImageCodec library
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DevILImageCodec
148 Group:          Development/Libraries
149 Requires:       %{name}-ImageCodec-DevIL = %{version}-%{release}
150 Requires:       %{name}-devel = %{version}-%{release}
151 Requires:       DevIL-devel
152
153 %description ImageCodec-DevIL-devel
154 Header files for CEGUI DevILImageCodec library.
155
156 %description ImageCodec-DevIL-devel -l pl.UTF-8
157 Pliki nagłówkowe biblioteki CEGUI DevILImageCodec.
158
159 %package ImageCodec-FreeImage
160 Summary:        FreeImageImageCodec library for CEGUI
161 Summary(pl.UTF-8):      Biblioteka FreeImageImageCodec dla CEGUI
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164
165 %description ImageCodec-FreeImage
166 FreeImageImageCodec library for CEGUI.
167
168 %description ImageCodec-FreeImage -l pl.UTF-8
169 Biblioteka FreeImageImageCodec dla CEGUI
170
171 %package ImageCodec-FreeImage-devel
172 Summary:        Header files for CEGUI FreeImageImageCodec library
173 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec
174 Group:          Development/Libraries
175 Requires:       %{name}-ImageCodec-FreeImage = %{version}-%{release}
176 Requires:       %{name}-devel = %{version}-%{release}
177 Requires:       FreeImage-devel
178
179 %description ImageCodec-FreeImage-devel
180 Header files for CEGUI FreeImageImageCodec library.
181
182 %description ImageCodec-FreeImage-devel -l pl.UTF-8
183 Pliki nagłówkowe biblioteki CEGUI FreeImageImageCodec.
184
185 %package ImageCodec-SILLY
186 Summary:        SILLYImageCodec library for CEGUI
187 Summary(pl.UTF-8):      Biblioteka SILLYImageCodec dla CEGUI
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190 Requires:       SILLY >= 0.1.0
191
192 %description ImageCodec-SILLY
193 SILLYImageCodec library for CEGUI.
194
195 %description ImageCodec-SILLY -l pl.UTF-8
196 Biblioteka SILLYImageCodec dla CEGUI
197
198 %package ImageCodec-SILLY-devel
199 Summary:        Header files for CEGUI SILLYImageCodec library
200 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec
201 Group:          Development/Libraries
202 Requires:       %{name}-ImageCodec-SILLY = %{version}-%{release}
203 Requires:       %{name}-devel = %{version}-%{release}
204 Requires:       SILLY-devel >= 0.1.0
205
206 %description ImageCodec-SILLY-devel
207 Header files for CEGUI SILLYImageCodec library.
208
209 %description ImageCodec-SILLY-devel -l pl.UTF-8
210 Pliki nagłówkowe biblioteki CEGUI SILLYImageCodec.
211
212 %package Parser-Expat
213 Summary:        Expat-based XML parser module
214 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Expat
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217
218 %description Parser-Expat
219 Expat-based XML parser module.
220
221 %description Parser-Expat -l pl.UTF-8
222 Moduł analizatora XML oparty na bibliotece Expat.
223
224 %package Parser-LibXML
225 Summary:        LibXML-based XML parser module
226 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece LibXML
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       libxml2 >= 1:2.6
230
231 %description Parser-LibXML
232 LibXML-based XML parser module.
233
234 %description Parser-LibXML -l pl.UTF-8
235 Moduł analizatora XML oparty na bibliotece LibXML.
236
237 %package Parser-RapidXML
238 Summary:        RapidXML-based XML parser module
239 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece RapidXML
240 Group:          Libraries
241 Requires:       %{name} = %{version}-%{release}
242
243 %description Parser-RapidXML
244 RapidXML-based XML parser module.
245
246 %description Parser-RapidXML -l pl.UTF-8
247 Moduł analizatora XML oparty na bibliotece RapidXML.
248
249 %package Parser-TinyXML
250 Summary:        TinyXML-based XML parser module
251 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece TinyXML
252 Group:          Libraries
253 Requires:       %{name} = %{version}-%{release}
254
255 %description Parser-TinyXML
256 TinyXML-based XML parser module.
257
258 %description Parser-TinyXML -l pl.UTF-8
259 Moduł analizatora XML oparty na bibliotece TinyXML.
260
261 %package Parser-Xerces
262 Summary:        Xerces-based XML parser module
263 Summary(pl.UTF-8):      Moduł analizatora XML oparty na bibliotece Xerces
264 Group:          Libraries
265 Requires:       %{name} = %{version}-%{release}
266
267 %description Parser-Xerces
268 Xerces-based XML parser module.
269
270 %description Parser-Xerces -l pl.UTF-8
271 Moduł analizatora XML oparty na bibliotece Xerces.
272
273 %package Renderer-DirectFB
274 Summary:        DirectFBRenderer library for CEGUI
275 Summary(pl.UTF-8):      Biblioteka DirectFBRenderer dla CEGUI
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       DirectFB >= 1.2.0
279
280 %description Renderer-DirectFB
281 DirectFBRenderer library for CEGUI.
282
283 %description Renderer-DirectFB -l pl.UTF-8
284 Biblioteka DirectFBRenderer dla CEGUI
285
286 %package Renderer-DirectFB-devel
287 Summary:        Header files for CEGUI DirectFBRenderer library
288 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer
289 Group:          Development/Libraries
290 Requires:       %{name}-Renderer-DirectFB = %{version}-%{release}
291 Requires:       %{name}-devel = %{version}-%{release}
292 Requires:       DirectFB-devel >= 1.2.0
293
294 %description Renderer-DirectFB-devel
295 Header files for CEGUI DirectFBRenderer library.
296
297 %description Renderer-DirectFB-devel -l pl.UTF-8
298 Pliki nagłówkowe biblioteki CEGUI DirectFBRenderer.
299
300 %package Renderer-Irrlicht
301 Summary:        IrrlichtRenderer library for CEGUI
302 Summary(pl.UTF-8):      Biblioteka IrrlichtRenderer dla CEGUI
303 Group:          Libraries
304 Requires:       %{name} = %{version}-%{release}
305 Requires:       irrlicht >= 1.4
306
307 %description Renderer-Irrlicht
308 IrrlichtRenderer library for CEGUI.
309
310 %description Renderer-Irrlicht -l pl.UTF-8
311 Biblioteka IrrlichtRenderer dla CEGUI
312
313 %package Renderer-Irrlicht-devel
314 Summary:        Header files for CEGUI IrrlichtRenderer library
315 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer
316 Group:          Development/Libraries
317 Requires:       %{name}-Renderer-Irrlicht = %{version}-%{release}
318 Requires:       %{name}-devel = %{version}-%{release}
319 Requires:       irrlicht-devel >= 1.4
320
321 %description Renderer-Irrlicht-devel
322 Header files for CEGUI IrrlichtRenderer library.
323
324 %description Renderer-Irrlicht-devel -l pl.UTF-8
325 Pliki nagłówkowe biblioteki CEGUI IrrlichtRenderer.
326
327 %package Renderer-Ogre
328 Summary:        OgreRenderer library for CEGUI
329 Summary(pl.UTF-8):      Biblioteka OgreRenderer dla CEGUI
330 Group:          Libraries
331 Requires:       %{name} = %{version}-%{release}
332 Obsoletes:      CEGUI-Ogre
333
334 %description Renderer-Ogre
335 OgreRenderer library for CEGUI.
336
337 %description Renderer-Ogre -l pl.UTF-8
338 Biblioteka OgreRenderer dla CEGUI
339
340 %package Renderer-Ogre-devel
341 Summary:        Header files for CEGUI OgreRenderer library
342 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OgreRenderer
343 Group:          Development/Libraries
344 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
345 Requires:       %{name}-devel = %{version}-%{release}
346 Requires:       ogre-devel >= 1.6.0
347 Obsoletes:      CEGUI-Ogre-devel
348
349 %description Renderer-Ogre-devel
350 Header files for CEGUI OgreRenderer library.
351
352 %description Renderer-Ogre-devel -l pl.UTF-8
353 Pliki nagłówkowe biblioteki CEGUI OgreRenderer.
354
355 %package Renderer-OpenGL
356 Summary:        OpenGLRenderer library for CEGUI
357 Summary(pl.UTF-8):      Biblioteka OpenGLRenderer dla CEGUI
358 Group:          Libraries
359 Requires:       %{name} = %{version}-%{release}
360 Obsoletes:      CEGUI-OpenGL
361
362 %description Renderer-OpenGL
363 OpenGLRenderer library for CEGUI.
364
365 %description Renderer-OpenGL -l pl.UTF-8
366 Biblioteka OpenGLRenderer dla CEGUI.
367
368 %package Renderer-OpenGL-devel
369 Summary:        Header files for CEGUI OpenGLRenderer library
370 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer
371 Group:          Development/Libraries
372 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
373 Requires:       %{name}-devel = %{version}-%{release}
374 Requires:       OpenGL-GLU-devel
375 Requires:       OpenGL-glut-devel
376 Requires:       glew-devel
377 Obsoletes:      CEGUI-OpenGL-devel
378
379 %description Renderer-OpenGL-devel
380 Header files for CEGUI OpenGLRenderer library.
381
382 %description Renderer-OpenGL-devel -l pl.UTF-8
383 Pliki nagłówkowe biblioteki CEGUI OpenGLRenderer.
384
385 %package -n python-CEGUI
386 Summary:        Python binding for CEGUI
387 Summary(pl.UTF-8):      Wiązania Pythona do CEGUI
388 Group:          Libraries/Python
389 Requires:       %{name} = %{version}-%{release}
390
391 %description -n python-CEGUI
392 Python binding for CEGUI.
393
394 %description -n python-CEGUI -l pl.UTF-8
395 Wiązania Pythona do CEGUI.
396
397 %package -n python-CEGUI-Renderer-Ogre
398 Summary:        Python binding for CEGUI OgreRenderer library
399 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OgreRenderer
400 Group:          Libraries/Python
401 Requires:       %{name}-Renderer-Ogre = %{version}-%{release}
402 Requires:       python-CEGUI = %{version}-%{release}
403
404 %description -n python-CEGUI-Renderer-Ogre
405 Python binding for CEGUI OgreRenderer library.
406
407 %description -n python-CEGUI-Renderer-Ogre -l pl.UTF-8
408 Wiązania Pythona do biblioteki CEGUI OgreRenderer.
409
410 %package -n python-CEGUI-Renderer-OpenGL
411 Summary:        Python binding for CEGUI OpenGLRenderer library
412 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki CEGUI OpenGLRenderer
413 Group:          Libraries/Python
414 Requires:       %{name}-Renderer-OpenGL = %{version}-%{release}
415 Requires:       python-CEGUI = %{version}-%{release}
416
417 %description -n python-CEGUI-Renderer-OpenGL
418 Python binding for CEGUI OpenGLRenderer library.
419
420 %description -n python-CEGUI-Renderer-OpenGL -l pl.UTF-8
421 Wiązania Pythona do biblioteki CEGUI OpenGLRenderer.
422
423 %prep
424 %setup -q -a 1 -n cegui-%{version}
425 %patch0 -p1
426 %patch2 -p1
427
428 %build
429 install -d build
430 cd build
431 %cmake .. \
432         -DCEGUI_SAMPLES_ENABLED:BOOL=%{?with_samples:ON}%{!?with_samples:OFF} \
433         -DCEGUI_BUILD_RENDERER_OPENGL:BOOL=%{?with_opengl:ON}%{!?with_opengl:OFF} \
434         -DCEGUI_BUILD_RENDERER_OGRE:BOOL=%{?with_ogre:ON}%{!?with_ogre:OFF} \
435         -DCEGUI_BUILD_XMLPARSER_XERCES:BOOL=%{?with_xercesc:ON}%{!?with_xercesc:OFF} \
436         -DCEGUI_OPTION_DEFAULT_IMAGECODEC:STRING=FreeImageImageCodec \
437         -DCEGUI_OPTION_DEFAULT_XMLPARSER:STRING=LibxmlParser \
438         -DCEGUI_PYTHON_INSTALL_DIR=%{py_sitedir}
439
440 %{__make} -j1
441
442 %install
443 rm -rf $RPM_BUILD_ROOT
444
445 %{__make} -C build install/fast \
446         DESTDIR=$RPM_BUILD_ROOT
447
448 %if %{without samples}
449 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/cegui-0/{animations,fonts,imagesets,layouts,looknfeel,lua_scripts,schemes,xml_schemas}
450 %endif
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %post   -p /sbin/ldconfig
456 %postun -p /sbin/ldconfig
457
458 %post   Renderer-Irrlicht -p /sbin/ldconfig
459 %postun Renderer-Irrlicht -p /sbin/ldconfig
460 %post   Renderer-Ogre -p /sbin/ldconfig
461 %postun Renderer-Ogre -p /sbin/ldconfig
462 %post   Renderer-OpenGL -p /sbin/ldconfig
463 %postun Renderer-OpenGL -p /sbin/ldconfig
464
465 %files
466 %defattr(644,root,root,755)
467 %doc doc/README
468 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so.*.*.*
469 %attr(755,root,root) %ghost %{_libdir}/libCEGUIBase-0.so.2
470 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libCEGUICommonDialogs-0.so.2
472 %attr(755,root,root) %{_libdir}/libCEGUINullRenderer-0.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/libCEGUINullRenderer-0.so.2
474 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so.*.*.*
475 %attr(755,root,root) %ghost %{_libdir}/libCEGUILuaScriptModule-0.so.2
476 # plugins
477 %dir %{_libdir}/cegui-0.8
478 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoreWindowRendererSet.so
479 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISTBImageCodec.so
480 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITGAImageCodec.so
481
482 %files docs
483 %defattr(644,root,root,755)
484 %doc cegui-docs-0.8.3/*
485
486 %files devel
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_bindir}/toluappcegui-0.8
489 %attr(755,root,root) %{_libdir}/libCEGUIBase-0.so
490 %attr(755,root,root) %{_libdir}/libCEGUICommonDialogs-0.so
491 %attr(755,root,root) %{_libdir}/libCEGUILuaScriptModule-0.so
492 %attr(755,root,root) %{_libdir}/libCEGUINullRenderer-0.so
493 %dir %{_includedir}/cegui-0
494 %dir %{_includedir}/cegui-0/%{name}
495 %{_includedir}/cegui-0/%{name}/*.h
496 %{_includedir}/cegui-0/%{name}/CommonDialogs
497 %dir %{_includedir}/cegui-0/%{name}/ImageCodecModules
498 %{_includedir}/cegui-0/%{name}/ImageCodecModules/STB
499 %{_includedir}/cegui-0/%{name}/ImageCodecModules/TGA
500 %dir %{_includedir}/cegui-0/%{name}/RendererModules
501 %{_includedir}/cegui-0/%{name}/RendererModules/Null
502 %{_includedir}/cegui-0/%{name}/ScriptModules
503 %{_includedir}/cegui-0/%{name}/WindowRendererSets
504 %{_includedir}/cegui-0/%{name}/XMLParserModules
505 %{_includedir}/cegui-0/%{name}/falagard
506 %{_includedir}/cegui-0/%{name}/widgets
507 %{_pkgconfigdir}/CEGUI-0.pc
508 %{_pkgconfigdir}/CEGUI-0-LUA.pc
509 %{_pkgconfigdir}/CEGUI-0-NULL.pc
510
511 %files ImageCodec-Corona
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUICoronaImageCodec.so
514
515 %files ImageCodec-Corona-devel
516 %defattr(644,root,root,755)
517 %{_includedir}/cegui-0/%{name}/ImageCodecModules/Corona
518
519 %files ImageCodec-DevIL
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIDevILImageCodec.so
522
523 %files ImageCodec-DevIL-devel
524 %defattr(644,root,root,755)
525 %{_includedir}/cegui-0/%{name}/ImageCodecModules/DevIL
526
527 %files ImageCodec-FreeImage
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIFreeImageImageCodec.so
530
531 %files ImageCodec-FreeImage-devel
532 %defattr(644,root,root,755)
533 %{_includedir}/cegui-0/%{name}/ImageCodecModules/FreeImage
534
535 %files ImageCodec-SILLY
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUISILLYImageCodec.so
538
539 %files ImageCodec-SILLY-devel
540 %defattr(644,root,root,755)
541 %{_includedir}/cegui-0/%{name}/ImageCodecModules/SILLY
542
543 %files Parser-Expat
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIExpatParser.so
546
547 %files Parser-LibXML
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUILibXMLParser.so
550
551 %files Parser-RapidXML
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIRapidXMLParser.so
554
555 %files Parser-TinyXML
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUITinyXMLParser.so
558
559 %files Parser-Xerces
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/cegui-0.8/libCEGUIXercesParser.so
562
563 %files Renderer-DirectFB
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libCEGUIDirectFBRenderer-0.so.2
567
568 %files Renderer-DirectFB-devel
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/libCEGUIDirectFBRenderer-0.so
571 %{_includedir}/cegui-0/%{name}/RendererModules/DirectFB
572
573 %files Renderer-Irrlicht
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libCEGUIIrrlichtRenderer-0.so.2
577
578 %files Renderer-Irrlicht-devel
579 %defattr(644,root,root,755)
580 %{_includedir}/cegui-0/%{name}/RendererModules/Irrlicht
581 %attr(755,root,root) %{_libdir}/libCEGUIIrrlichtRenderer-0.so
582 %{_pkgconfigdir}/CEGUI-0-IRRLICHT.pc
583
584 %if %{with ogre}
585 %files Renderer-Ogre
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOgreRenderer-0.so.2
589
590 %files Renderer-Ogre-devel
591 %defattr(644,root,root,755)
592 %{_includedir}/cegui-0/%{name}/RendererModules/Ogre
593 %attr(755,root,root) %{_libdir}/libCEGUIOgreRenderer-0.so
594 %{_pkgconfigdir}/CEGUI-0-OGRE.pc
595 %endif
596
597 %if %{with opengl}
598 %files Renderer-OpenGL
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so.*.*.*
601 %attr(755,root,root) %ghost %{_libdir}/libCEGUIOpenGLRenderer-0.so.2
602
603 %files Renderer-OpenGL-devel
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libCEGUIOpenGLRenderer-0.so
606 %{_includedir}/cegui-0/%{name}/RendererModules/OpenGL
607 %{_pkgconfigdir}/CEGUI-0-OPENGL.pc
608 %{_pkgconfigdir}/CEGUI-0-OPENGL3.pc
609 %endif
610
611 %files -n python-CEGUI
612 %defattr(644,root,root,755)
613 %dir %{py_sitedir}/cegui-0.8
614 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUI.so
615 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUINullRenderer.so
616
617 %if %{with ogre}
618 %files -n python-CEGUI-Renderer-Ogre
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOgreRenderer.so
621 %endif
622
623 %if %{with opengl}
624 %files -n python-CEGUI-Renderer-OpenGL
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{py_sitedir}/cegui-0.8/PyCEGUIOpenGLRenderer.so
627 %endif
This page took 0.139631 seconds and 2 git commands to generate.