]> git.pld-linux.org Git - packages/Apache-Gallery.git/blob - Apache-Gallery.spec
- 1.0RC2 - this version works under new mod_perl...
[packages/Apache-Gallery.git] / Apache-Gallery.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" during build
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         apxs            /usr/sbin/apxs
7 Summary:        An Apache module for creating an online gallery
8 Summary(pl):    Modu³ Apache'a do tworzenia galerii online
9 Name:           Apache-Gallery
10 Version:        1.0
11 %define         _rc     RC2
12 Release:        0.%{_rc}.1
13 License:        Artistic
14 Group:          Applications/Graphics
15 Source0:        http://apachegallery.dk/download/%{name}-%{version}%{_rc}.tar.gz
16 # Source0-md5:  d195f22377276d00d083b1b3e48847bb
17 Source1:        %{name}.conf
18 URL:            http://apachegallery.dk/
19 BuildRequires:  apache-mod_perl >= 1.99
20 %{?with_tests:BuildRequires:    apache1-mod_perl}
21 BuildRequires:  perl-CGI >= 3.08
22 BuildRequires:  perl-Image-Imlib2 >= 1.02
23 BuildRequires:  perl-Image-Info
24 BuildRequires:  perl-Image-Size
25 BuildRequires:  perl-Text-Template
26 BuildRequires:  perl-URI >= 1.23
27 BuildRequires:  perl-devel
28 BuildRequires:  perl-libapreq2
29 BuildRequires:  rpm-perlprov >= 3.0.3-16
30 Requires:       apache-mod_perl >= 1:2.0.0
31 Conflicts:      apache-mod_autoindex
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreq      'perl(APR::Table)' 'perl(Apache2)' 'perl(Apache::Const)' 'perl(Apache::RequestIO)' 'perl(Apache::RequestRec)' 'perl(Apache::SubRequest)'
35 %define         _appdir         %{_datadir}/%{name}
36 %define         _apacheicons    %{_appdir}/icons
37
38 %description
39 Apache::Gallery is a mod_perl handler that sits on top of your
40 DocumentRoot and creates an image gallery of the files and directories
41 there. It creates an thumbnail index of each directory and allows
42 viewing of pictures in different resolutions. Pictures are resized on
43 the fly and cached.
44
45 %description -l pl
46 Apache::Gallery to procedura obs³ugi dla modu³u mod_perl po³o¿ona w
47 DocumentRoot, tworz±ca galeriê obrazów z umieszczonych tam plików i
48 katalogów. Tworzy indeks z miniaturkami z ka¿dego katalogu i pozwala
49 na ogl±danie obrazków w ró¿nych rozdzielczo¶ciach. Obrazki s±
50 przeskalowywane w locie i buforowane.
51
52 %prep
53 %setup -q -n %{name}-%{version}%{_rc}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make} \
60         OPTIMIZE="%{rpmcflags}"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_appdir}/templates/{new,default},%{_apacheicons},/etc/httpd/httpd.conf}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 install templates/new/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/new/
72 install templates/default/*.{css,tpl} $RPM_BUILD_ROOT%{_appdir}/templates/default/
73 install htdocs/*.png $RPM_BUILD_ROOT%{_apacheicons}
74
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/09_%{name}.conf
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 if [ -f /var/lock/subsys/httpd ]; then
82         /etc/rc.d/init.d/httpd reload 1>&2
83 else
84         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
85 fi
86
87 %preun
88 if [ "$1" = "0" ]; then
89         if [ -f /var/lock/subsys/httpd ]; then
90                 /etc/rc.d/init.d/httpd reload 1>&2
91         fi
92 fi
93
94 %files
95 %defattr(644,root,root,755)
96 %doc Changes INSTALL README TODO UPGRADE
97 %attr(640,root,http) %config(noreplace) %verify(not size mtime md5) /etc/httpd/httpd.conf/*%{name}.conf
98 %{perl_vendorlib}/Apache/Gallery.pm
99 %dir %{_appdir}
100 %dir %{_appdir}/templates
101 %dir %{_appdir}/templates/new
102 %{_appdir}/templates/new/*.tpl
103 %{_appdir}/templates/new/*.css
104 %dir %{_appdir}/templates/default
105 %{_appdir}/templates/default/*.tpl
106 %{_appdir}/templates/default/*.css
107 %dir %{_apacheicons}
108 %{_apacheicons}/*.png
109 %{_mandir}/man3/*.3*
This page took 0.067919 seconds and 3 git commands to generate.