]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
- changed all BuildRoot definitons
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers.
2 Summary(pl):    Aplety, których mo¿esz u¿ywaæ z AfterStepem oraz innymi zarz±dcami okien, które s± z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        991125
5 Release:        3
6 Copyright:      GPL
7 Group:          X11/Window Managers/Tools
8 Group(pl):      X11/Zarz±dcy Okien/Narzêdzia
9 Source:         http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
10 Patch0:         AfterStep-APPS-1.5beta1-glibc.patch
11 Patch1:         ascp-paths.patch
12 Patch2:         as-apps-compile.patch
13 Patch3:         aterm-utmp.patch
14 Patch4:         xiterm-utmp.patch
15 Prereq:         /sbin/ldconfig
16 Requires:       /usr/sbin/utempter
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _prefix /usr/X11R6
20 %define         _mandir /usr/X11R6/man
21
22 %description
23 What's a cool window manager without some cool applets?
24 Well... it's still cool, but these applets which can
25 be used in the Wharf module for AfterStep or Window
26 Maker can add both spice and productivity to your
27 preferred window manager, such as a handy clock and
28 information about system resources.
29
30 If you've installed the AfterStep packages, you
31 should also install these packages. Enjoy! 
32
33 %description -l pl
34 Czym jest fajny zarz±dca okien bez fajnych apletów?
35 Có¿... jest nadal fajnym zarz±dc± okien, ale aplety, które mog± byæ u¿ywane
36 w module Wharf AfterStepa lub Window Makera, mog³yby zwiêkszyæ efektywno¶æ
37 i efektowno¶æ twojego ulubionego zarz±dcy okien.
38
39 Je¿eli masz zainstalowanego AfterStepa to powiniene¶ zainstalowaæ tak¿e ten
40 pakiet. Mi³ej zabawy!
41
42 %prep
43 %setup -q -c
44 rm -f *.asc
45 for archive in *.tar.gz ; do
46         tar xzf $archive
47         rm -f $archive
48 done
49 %patch0 -p1
50 %patch1 -p1
51 %patch3 -p0
52 %patch4 -p1
53
54 %build
55 for package in `ls` ; do
56     cd $package 
57     case $package in
58         ascd-* )
59             ./configure << EOF
60 1
61
62 1
63
64 EOF
65             patch -p2 -b --suffix .compile < %{PATCH2}
66             xmkmf
67             make Makefiles CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
68                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
69             make MANDIR=%{_mandir}/man1 \
70                 BINDIR=%{_bindir} \
71                 SHLIBDIR=%{_libdir} \
72                 CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
73                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
74             ;;
75         
76         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
77             # we don't compile these
78             ;;
79
80         aterm*)
81             %configure --enable-utmp
82             make
83             ;;
84
85         xiterm*)
86             # cough cough, hack hack -- ewt
87             %configure \
88                 --enable-xpm-background \
89                 --enable-utmp \
90                 --enable-wtmp \
91                 --enable-menubar \
92                 --enable-next-scroll
93             xmkmf
94             make Makefiles
95             cd src
96             sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
97                Makefile > Makefile.foo
98             sed -e "s/-lsocket //" Makefile.foo > Makefile
99             make CXXDEBUGFLAGS="$RPM_OPT_FLAGS" \
100                 CDEBUGFLAGS="$RPM_OPT_FLAGS"
101             ;;
102         asclock*)
103             CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} << EOF
104 classic
105
106 EOF
107              make CFLAGS="$RPM_OPT_FLAGS"
108              ;;
109         *)
110             #just about every other thing supports autoconf
111             %configure
112             make
113             ;;
114     esac
115     cd ..
116 done
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
121
122 for package in `ls` ; do
123     cd $package 
124     case $package in
125         ascd-* | xiterm*)
126             make install install.man \
127                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
128                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
129                 MANDIR=%{_mandir}/man1 \
130                 BINDIR=%{_bindir} \
131                 SHLIBDIR=%{_libdir} \
132                 DESTDIR=$RPM_BUILD_ROOT 
133             ;;
134
135         asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
136             # we don't install this
137             ;;
138
139         ascp-* )
140             make install \
141                 ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
142                 ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
143                 prefx=$RPM_BUILD_ROOT \
144                 DESTDIR=$RPM_BUILD_ROOT
145             ;;
146         
147         asppp* | aterm* )
148             make install \
149                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
150                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
151                 DESTDIR=$RPM_BUILD_ROOT
152             ;;
153         *)
154             make install install.man \
155                 AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
156                 AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
157                 DESTDIR=$RPM_BUILD_ROOT
158             ;;
159     esac
160     cd ..
161 done
162 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
163 strip --strip-unneeded $RPM_BUILD_ROOT%{_bindir}/*
164
165 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/*
176 %{_datadir}/afterstep/*
177 %{_mandir}/man1/*
This page took 0.093985 seconds and 3 git commands to generate.