]> git.pld-linux.org Git - packages/xmlrpc-c.git/blame_incremental - xmlrpc-c.spec
- x32 rebuild
[packages/xmlrpc-c.git] / xmlrpc-c.spec
... / ...
CommitLineData
1Summary: XML-RPC C library - an implementation of the xmlrpc protocol
2Summary(pl.UTF-8): Biblioteka XML-RPC C - implementacja protokołu xmlrpc
3Name: xmlrpc-c
4Version: 1.32.05
5Release: 3
6License: XML-RPC for C License (BSD-like)
7Group: Libraries
8# svn co http://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced xmlrpc-c
9# Unfortunately, upstream does not tag versions so we must fetch from the branch
10# and check which version was used for it
11# 1.32.05 is svn r2451
12Source0: %{name}-%{version}.tar.xz
13# Source0-md5: c80cfb54a6e26247369de042474e08e0
14Patch0: %{name}-fastdep.patch
15Patch1: %{name}-soname.patch
16Patch2: %{name}-cflags.patch
17Patch3: %{name}-cmake-fix.patch
18Patch4: %{name}-format.patch
19# patches 10+ come from Fedora
20Patch10: %{name}-cmake.patch
21Patch11: %{name}-printf-size_t.patch
22Patch12: %{name}-longlong.patch
23Patch13: %{name}-uninit-curl.patch
24Patch14: %{name}-30x-redirect.patch
25Patch15: %{name}-check-vasprintf-return-value.patch
26Patch16: %{name}-include-string_int.h.patch
27URL: http://xmlrpc-c.sourceforge.net/
28BuildRequires: cmake >= 2.6
29BuildRequires: curl-devel
30BuildRequires: libstdc++-devel
31BuildRequires: libxml2-devel >= 2.0
32BuildRequires: ncurses-devel >= 5.7-21
33BuildRequires: pkgconfig
34BuildRequires: readline-devel
35BuildRequires: rpmbuild(macros) >= 1.577
36BuildRequires: tar >= 1:1.22
37BuildRequires: w3c-libwww-devel >= 5.4.0-11
38BuildRequires: xz
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42XML-RPC is a quick-and-easy way to make procedure calls over the
43Internet. It converts the procedure call into XML document, sends it
44to a remote server using HTTP, and gets back the response as XML.
45
46This library provides a modular implementation of XML-RPC for C.
47
48%description -l pl.UTF-8
49XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
50Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
51zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
52
53Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka C.
54
55%package devel
56Summary: C header files for xmlrpc-c base libraries
57Summary(pl.UTF-8): Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires: curl-devel
61Requires: expat-devel
62Requires: libxml2-devel >= 2.0
63Requires: w3c-libwww-devel
64
65%description devel
66C header files for xmlrpc-c base libraries.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c.
70
71%package client
72Summary: C client library for xmlrpc-c
73Summary(pl.UTF-8): Biblioteka kliencka C xmlrpc-c
74Group: Libraries
75Requires: %{name} = %{version}-%{release}
76
77%description client
78XML-RPC is a quick-and-easy way to make procedure calls over the
79Internet. It converts the procedure call into XML document, sends it
80to a remote server using HTTP, and gets back the response as XML.
81
82This library provides a modular implementation of XML-RPC for C
83clients.
84
85%description client -l pl.UTF-8
86XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
87Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
88zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
89
90Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
91w języku C.
92
93%package client-devel
94Summary: C header files for xmlrpc-c client library
95Summary(pl.UTF-8): Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c
96Group: Development/Libraries
97Requires: %{name}-client = %{version}-%{release}
98Requires: %{name}-devel = %{version}-%{release}
99
100%description client-devel
101C header files for xmlrpc-c client library.
102
103%description client-devel -l pl.UTF-8
104Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c.
105
106%package server
107Summary: C server libraries for xmlrpc-c
108Summary(pl.UTF-8): Biblioteki serwerowe C xmlrpc-c
109Group: Libraries
110Requires: %{name} = %{version}-%{release}
111
112%description server
113XML-RPC is a quick-and-easy way to make procedure calls over the
114Internet. It converts the procedure call into XML document, sends it
115to a remote server using HTTP, and gets back the response as XML.
116
117These libraries provide a modular implementation of XML-RPC for C
118servers.
119
120%description server -l pl.UTF-8
121XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
122Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
123zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
124
125Te biblioteki udostepniają modularną implementacją XML-RPC dla
126serwerów w języku C.
127
128%package server-devel
129Summary: C header files for xmlrpc-c server libraries
130Summary(pl.UTF-8): Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
131Group: Development/Libraries
132Requires: %{name}-server = %{version}-%{release}
133Requires: %{name}-devel = %{version}-%{release}
134
135%description server-devel
136C header files for xmlrpc-c server libraries.
137
138%description server-devel -l pl.UTF-8
139Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c.
140
141%package c++
142Summary: C++ libraries for xmlrpc-c
143Summary(pl.UTF-8): Biblioteki C++ xmlrpc-c
144Group: Libraries
145Requires: %{name} = %{version}-%{release}
146
147%description c++
148XML-RPC is a quick-and-easy way to make procedure calls over the
149Internet. It converts the procedure call into XML document, sends it
150to a remote server using HTTP, and gets back the response as XML.
151
152This library provides a modular implementation of XML-RPC for C++.
153
154%description c++ -l pl.UTF-8
155XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
156Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
157zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
158
159Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka
160C++.
161
162%package c++-devel
163Summary: C++ header files for xmlrpc-c base libraries
164Summary(pl.UTF-8): Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c
165Group: Development/Libraries
166Requires: %{name}-c++ = %{version}-%{release}
167Requires: %{name}-devel = %{version}-%{release}
168Requires: libstdc++-devel
169
170%description c++-devel
171C++ header files for xmlrpc-c base libraries.
172
173%description c++-devel -l pl.UTF-8
174Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c.
175
176%package client++
177Summary: C++ client library for xmlrpc-c
178Summary(pl.UTF-8): Biblioteka kliencka C++ xmlrpc-c
179Group: Libraries
180Requires: %{name}-c++ = %{version}-%{release}
181Requires: %{name}-client = %{version}-%{release}
182
183%description client++
184XML-RPC is a quick-and-easy way to make procedure calls over the
185Internet. It converts the procedure call into XML document, sends it
186to a remote server using HTTP, and gets back the response as XML.
187
188This library provides a modular implementation of XML-RPC for C++
189clients.
190
191%description client++ -l pl.UTF-8
192XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
193Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
194zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
195
196Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
197w języku C++.
198
199%package client++-devel
200Summary: C++ header files for xmlrpc-c client library
201Summary(pl.UTF-8): Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c
202Group: Development/Libraries
203Requires: %{name}-c++-devel = %{version}-%{release}
204Requires: %{name}-client++ = %{version}-%{release}
205Requires: %{name}-client-devel = %{version}-%{release}
206
207%description client++-devel
208C++ header files for xmlrpc-c client library.
209
210%description client++-devel -l pl.UTF-8
211Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c.
212
213%package server++
214Summary: C++ server libraries for xmlrpc-c
215Summary(pl.UTF-8): Biblioteki serwerowe C++ xmlrpc-c
216Group: Libraries
217Requires: %{name}-c++ = %{version}-%{release}
218Requires: %{name}-server = %{version}-%{release}
219
220%description server++
221XML-RPC is a quick-and-easy way to make procedure calls over the
222Internet. It converts the procedure call into XML document, sends it
223to a remote server using HTTP, and gets back the response as XML.
224
225These libraries provide a modular implementation of XML-RPC for C++
226servers.
227
228%description server++ -l pl.UTF-8
229XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
230Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
231zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
232
233Te biblioteki udostepniają modularną implementacją XML-RPC dla
234serwerów w języku C++.
235
236%package server++-devel
237Summary: C++ header files for xmlrpc-c server libraries
238Summary(pl.UTF-8): Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
239Group: Development/Libraries
240Requires: %{name}-c++-devel = %{version}-%{release}
241Requires: %{name}-server++ = %{version}-%{release}
242Requires: %{name}-server-devel = %{version}-%{release}
243
244%description server++-devel
245C++ header files for xmlrpc-c server libraries.
246
247%description server++-devel -l pl.UTF-8
248Pliki nagłówkowe C++ dla bibliotek serwerowych xmlrpc-c.
249
250%package apps
251Summary: Sample XML-RPC applications
252Summary(pl.UTF-8): Przykładowe aplikacje XML-RPC
253Group: Applications/Networking
254Requires: %{name} = %{version}-%{release}
255Requires: %{name}-c++ = %{version}-%{release}
256Requires: %{name}-client = %{version}-%{release}
257Requires: %{name}-client++ = %{version}-%{release}
258
259%description apps
260XML-RPC is a quick-and-easy way to make procedure calls over the
261Internet. It converts the procedure call into XML document, sends it
262to a remote server using HTTP, and gets back the response as XML.
263
264This package contains some handy XML-RPC demo applications.
265
266%description apps -l pl.UTF-8
267XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
268Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
269zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
270
271Ten pakiet zawiera kilka podręcznych aplikacji demonstracyjnych
272XML-RPC.
273
274%prep
275%setup -q -n %{name}
276%patch0 -p1
277%patch2 -p1
278%patch10 -p1
279%patch11 -p1
280%patch12 -p1
281%patch13 -p1
282%patch14 -p1
283%patch15 -p1
284%patch16 -p1
285%patch1 -p1
286%patch3 -p1
287%patch4 -p1
288
289%build
290mkdir -p build
291cd build
292%cmake .. \
293 -D_lib:STRING=%{_lib} \
294 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
295 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
296 -DMUST_BUILD_CURL_CLIENT:BOOL=ON \
297 -DMUST_BUILD_LIBWWW_CLIENT:BOOL=ON \
298 -DBUILD_SHARED_LIBS:BOOL=ON \
299 -DENABLE_TOOLS:BOOL=ON
300
301%{__make}
302
303%install
304rm -rf $RPM_BUILD_ROOT
305
306%{__make} -C build install \
307 DESTDIR=$RPM_BUILD_ROOT \
308
309chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so*
310
311# Win32-specific
312%{__rm} $RPM_BUILD_ROOT%{_includedir}/xmlrpc_server_w32httpsys.h \
313 $RPM_BUILD_ROOT%{_includedir}/xmlrpc-c/server_w32httpsys.h
314
315%clean
316rm -rf $RPM_BUILD_ROOT
317
318%post -p /sbin/ldconfig
319%postun -p /sbin/ldconfig
320
321%post client -p /sbin/ldconfig
322%postun client -p /sbin/ldconfig
323
324%post server -p /sbin/ldconfig
325%postun server -p /sbin/ldconfig
326
327%post c++ -p /sbin/ldconfig
328%postun c++ -p /sbin/ldconfig
329
330%post client++ -p /sbin/ldconfig
331%postun client++ -p /sbin/ldconfig
332
333%post server++ -p /sbin/ldconfig
334%postun server++ -p /sbin/ldconfig
335
336%files
337%defattr(644,root,root,755)
338%doc README doc/{COPYING,CREDITS,HISTORY,SECURITY,TODO}
339%attr(755,root,root) %{_libdir}/libxmlrpc-c.so.*.*
340%attr(755,root,root) %ghost %{_libdir}/libxmlrpc-c.so.3
341%attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so.*.*
342%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss.so.3
343%attr(755,root,root) %{_libdir}/libxmlrpc_util.so.*.*
344%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util.so.3
345
346%files devel
347%defattr(644,root,root,755)
348%doc doc/{DEVELOPING,TESTING}
349%attr(755,root,root) %{_bindir}/xmlrpc-c-config
350%attr(755,root,root) %{_libdir}/libxmlrpc-c.so
351%attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so
352%attr(755,root,root) %{_libdir}/libxmlrpc_util.so
353%dir %{_includedir}/xmlrpc-c
354%{_includedir}/xmlrpc-c/abyss*.h
355%{_includedir}/xmlrpc-c/base.h
356%{_includedir}/xmlrpc-c/c_util.h
357%{_includedir}/xmlrpc-c/config.h
358%{_includedir}/xmlrpc-c/inttypes.h
359%{_includedir}/xmlrpc-c/json.h
360%{_includedir}/xmlrpc-c/oldxmlrpc.h
361%{_includedir}/xmlrpc-c/transport.h
362%{_includedir}/xmlrpc-c/util.h
363%{_includedir}/xmlrpc.h
364%{_pkgconfigdir}/xmlrpc.pc
365%{_pkgconfigdir}/xmlrpc_abyss.pc
366%{_pkgconfigdir}/xmlrpc_util.pc
367
368%files client
369%defattr(644,root,root,755)
370%attr(755,root,root) %{_libdir}/libxmlrpc_client.so.*.*
371%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client.so.3
372
373%files client-devel
374%defattr(644,root,root,755)
375%attr(755,root,root) %{_libdir}/libxmlrpc_client.so
376%{_includedir}/xmlrpc-c/client*.h
377%{_includedir}/xmlrpc_client.h
378%{_pkgconfigdir}/xmlrpc_client.pc
379
380%files server
381%defattr(644,root,root,755)
382%attr(755,root,root) %{_libdir}/libxmlrpc_server.so.*.*
383%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server.so.3
384%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so.*.*
385%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss.so.3
386%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so.*.*
387%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi.so.3
388
389%files server-devel
390%defattr(644,root,root,755)
391%attr(755,root,root) %{_libdir}/libxmlrpc_server.so
392%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so
393%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so
394%{_includedir}/xmlrpc-c/server.h
395%{_includedir}/xmlrpc-c/server_abyss.h
396%{_includedir}/xmlrpc-c/server_cgi.h
397%{_includedir}/xmlrpc_abyss.h
398%{_includedir}/xmlrpc_cgi.h
399%{_includedir}/xmlrpc_server.h
400%{_pkgconfigdir}/xmlrpc_server.pc
401%{_pkgconfigdir}/xmlrpc_server_abyss.pc
402%{_pkgconfigdir}/xmlrpc_server_cgi.pc
403
404%files c++
405%defattr(644,root,root,755)
406%attr(755,root,root) %{_libdir}/libxmlrpc++.so.*.*
407%attr(755,root,root) %ghost %{_libdir}/libxmlrpc++.so.8
408%attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so.*.*
409%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_cpp.so.8
410%attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so.*.*
411%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_packetsocket.so.8
412
413%files c++-devel
414%defattr(644,root,root,755)
415%attr(755,root,root) %{_libdir}/libxmlrpc++.so
416%attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so
417%attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so
418%{_includedir}/xmlrpc-c/base.hpp
419%{_includedir}/xmlrpc-c/girerr.hpp
420%{_includedir}/xmlrpc-c/girmem.hpp
421%{_includedir}/xmlrpc-c/oldcppwrapper.hpp
422%{_includedir}/xmlrpc-c/packetsocket.hpp
423%{_includedir}/xmlrpc-c/registry.hpp
424%{_includedir}/xmlrpc-c/timeout.hpp
425%{_includedir}/xmlrpc-c/xml.hpp
426%{_includedir}/XmlRpcCpp.h
427%{_pkgconfigdir}/xmlrpc++.pc
428%{_pkgconfigdir}/xmlrpc_cpp.pc
429%{_pkgconfigdir}/xmlrpc_packetsocket.pc
430
431%files client++
432%defattr(644,root,root,755)
433%attr(755,root,root) %{_libdir}/libxmlrpc_client++.so.*.*
434%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client++.so.8
435
436%files client++-devel
437%defattr(644,root,root,755)
438%attr(755,root,root) %{_libdir}/libxmlrpc_client++.so
439%{_includedir}/xmlrpc-c/client*.hpp
440%{_pkgconfigdir}/xmlrpc_client++.pc
441
442%files server++
443%defattr(644,root,root,755)
444%attr(755,root,root) %{_libdir}/libxmlrpc_server++.so.*.*
445%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server++.so.8
446%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so.*.*
447%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss++.so.8
448%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so.*.*
449%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi++.so.8
450%attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so.*.*
451%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_pstream++.so.8
452
453%files server++-devel
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_libdir}/libxmlrpc_server++.so
456%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so
457%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so
458%attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so
459%{_includedir}/xmlrpc-c/server_abyss.hpp
460%{_includedir}/xmlrpc-c/server_pstream.hpp
461%{_pkgconfigdir}/xmlrpc_server++.pc
462%{_pkgconfigdir}/xmlrpc_server_abyss++.pc
463%{_pkgconfigdir}/xmlrpc_server_cgi++.pc
464%{_pkgconfigdir}/xmlrpc_server_pstream++.pc
465
466%files apps
467%defattr(644,root,root,755)
468%doc tools/xmlrpc/xmlrpc.html tools/xmlrpc_transport/xmlrpc_transport.html
469%attr(755,root,root) %{_bindir}/xmlrpc
470%attr(755,root,root) %{_bindir}/xmlrpc_parsecall
471%attr(755,root,root) %{_bindir}/xmlrpc_transport
472%attr(755,root,root) %{_bindir}/xml-rpc-api2cpp
473%attr(755,root,root) %{_bindir}/xml-rpc-api2txt
474%attr(755,root,root) %{_bindir}/xmlrpc_cpp_proxy
475%attr(755,root,root) %{_bindir}/xmlrpc_pstream
476%{_mandir}/man1/xml-rpc-api2cpp.1*
477%{_mandir}/man1/xml-rpc-api2txt.1*
This page took 0.101693 seconds and 4 git commands to generate.