]> git.pld-linux.org Git - packages/xmlrpc-c.git/blame_incremental - xmlrpc-c.spec
- updated to 1.39.13
[packages/xmlrpc-c.git] / xmlrpc-c.spec
... / ...
CommitLineData
1Summary: XML-RPC C library - an implementation of the xmlrpc protocol
2Summary(pl.UTF-8): Biblioteka XML-RPC C - implementacja protokołu xmlrpc
3Name: xmlrpc-c
4Version: 1.39.13
5Release: 1
6License: XML-RPC for C License (BSD-like)
7Group: Libraries
8# for feature versions:
9# svn co http://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced xmlrpc-c
10# Unfortunately, upstream does not tag versions so we must fetch from the branch
11# and check which version was used for it.
12# for "super stable" versions:
13Source0: http://downloads.sourceforge.net/xmlrpc-c/%{name}-%{version}.tgz
14# Source0-md5: 393d5450c74baffc94b36a2a0c838c3b
15Patch0: %{name}-fastdep.patch
16Patch1: %{name}-soname.patch
17Patch2: %{name}-cflags.patch
18Patch3: %{name}-format.patch
19# patches 10+ come from Fedora (cmake patch is updated from original version)
20Patch10: %{name}-cmake.patch
21Patch11: %{name}-printf-size_t.patch
22Patch12: %{name}-longlong.patch
23Patch13: %{name}-uninit-curl.patch
24Patch14: %{name}-30x-redirect.patch
25URL: http://xmlrpc-c.sourceforge.net/
26BuildRequires: cmake >= 2.6
27BuildRequires: curl-devel
28BuildRequires: libstdc++-devel
29BuildRequires: libxml2-devel >= 2.0
30BuildRequires: ncurses-devel >= 5.7-21
31BuildRequires: pkgconfig
32BuildRequires: readline-devel
33BuildRequires: rpmbuild(macros) >= 1.577
34BuildRequires: tar >= 1:1.22
35BuildRequires: w3c-libwww-devel >= 5.4.0-20
36BuildRequires: xz
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39%description
40XML-RPC is a quick-and-easy way to make procedure calls over the
41Internet. It converts the procedure call into XML document, sends it
42to a remote server using HTTP, and gets back the response as XML.
43
44This library provides a modular implementation of XML-RPC for C.
45
46%description -l pl.UTF-8
47XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
48Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
49zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
50
51Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka C.
52
53%package devel
54Summary: C header files for xmlrpc-c base libraries
55Summary(pl.UTF-8): Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58Requires: curl-devel
59Requires: expat-devel
60Requires: libxml2-devel >= 2.0
61Requires: w3c-libwww-devel
62
63%description devel
64C header files for xmlrpc-c base libraries.
65
66%description devel -l pl.UTF-8
67Pliki nagłówkowe C dla głównych bibliotek xmlrpc-c.
68
69%package client
70Summary: C client library for xmlrpc-c
71Summary(pl.UTF-8): Biblioteka kliencka C xmlrpc-c
72Group: Libraries
73Requires: %{name} = %{version}-%{release}
74
75%description client
76XML-RPC is a quick-and-easy way to make procedure calls over the
77Internet. It converts the procedure call into XML document, sends it
78to a remote server using HTTP, and gets back the response as XML.
79
80This library provides a modular implementation of XML-RPC for C
81clients.
82
83%description client -l pl.UTF-8
84XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
85Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
86zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
87
88Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
89w języku C.
90
91%package client-devel
92Summary: C header files for xmlrpc-c client library
93Summary(pl.UTF-8): Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c
94Group: Development/Libraries
95Requires: %{name}-client = %{version}-%{release}
96Requires: %{name}-devel = %{version}-%{release}
97
98%description client-devel
99C header files for xmlrpc-c client library.
100
101%description client-devel -l pl.UTF-8
102Pliki nagłówkowe C dla biblioteki klienckiej xmlrpc-c.
103
104%package server
105Summary: C server libraries for xmlrpc-c
106Summary(pl.UTF-8): Biblioteki serwerowe C xmlrpc-c
107Group: Libraries
108Requires: %{name} = %{version}-%{release}
109
110%description server
111XML-RPC is a quick-and-easy way to make procedure calls over the
112Internet. It converts the procedure call into XML document, sends it
113to a remote server using HTTP, and gets back the response as XML.
114
115These libraries provide a modular implementation of XML-RPC for C
116servers.
117
118%description server -l pl.UTF-8
119XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
120Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
121zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
122
123Te biblioteki udostepniają modularną implementacją XML-RPC dla
124serwerów w języku C.
125
126%package server-devel
127Summary: C header files for xmlrpc-c server libraries
128Summary(pl.UTF-8): Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
129Group: Development/Libraries
130Requires: %{name}-server = %{version}-%{release}
131Requires: %{name}-devel = %{version}-%{release}
132
133%description server-devel
134C header files for xmlrpc-c server libraries.
135
136%description server-devel -l pl.UTF-8
137Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c.
138
139%package c++
140Summary: C++ libraries for xmlrpc-c
141Summary(pl.UTF-8): Biblioteki C++ xmlrpc-c
142Group: Libraries
143Requires: %{name} = %{version}-%{release}
144
145%description c++
146XML-RPC is a quick-and-easy way to make procedure calls over the
147Internet. It converts the procedure call into XML document, sends it
148to a remote server using HTTP, and gets back the response as XML.
149
150This library provides a modular implementation of XML-RPC for C++.
151
152%description c++ -l pl.UTF-8
153XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
154Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
155zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
156
157Ta biblioteka udostepnia modularną implementacją XML-RPC dla języka
158C++.
159
160%package c++-devel
161Summary: C++ header files for xmlrpc-c base libraries
162Summary(pl.UTF-8): Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c
163Group: Development/Libraries
164Requires: %{name}-c++ = %{version}-%{release}
165Requires: %{name}-devel = %{version}-%{release}
166Requires: libstdc++-devel
167
168%description c++-devel
169C++ header files for xmlrpc-c base libraries.
170
171%description c++-devel -l pl.UTF-8
172Pliki nagłówkowe C++ głównych bibliotek xmlrpc-c.
173
174%package client++
175Summary: C++ client library for xmlrpc-c
176Summary(pl.UTF-8): Biblioteka kliencka C++ xmlrpc-c
177Group: Libraries
178Requires: %{name}-c++ = %{version}-%{release}
179Requires: %{name}-client = %{version}-%{release}
180
181%description client++
182XML-RPC is a quick-and-easy way to make procedure calls over the
183Internet. It converts the procedure call into XML document, sends it
184to a remote server using HTTP, and gets back the response as XML.
185
186This library provides a modular implementation of XML-RPC for C++
187clients.
188
189%description client++ -l pl.UTF-8
190XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
191Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
192zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
193
194Ta biblioteka udostepnia modularną implementacją XML-RPC dla klientów
195w języku C++.
196
197%package client++-devel
198Summary: C++ header files for xmlrpc-c client library
199Summary(pl.UTF-8): Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c
200Group: Development/Libraries
201Requires: %{name}-c++-devel = %{version}-%{release}
202Requires: %{name}-client++ = %{version}-%{release}
203Requires: %{name}-client-devel = %{version}-%{release}
204
205%description client++-devel
206C++ header files for xmlrpc-c client library.
207
208%description client++-devel -l pl.UTF-8
209Pliki nagłówkowe C++ biblioteki klienckiej xmlrpc-c.
210
211%package server++
212Summary: C++ server libraries for xmlrpc-c
213Summary(pl.UTF-8): Biblioteki serwerowe C++ xmlrpc-c
214Group: Libraries
215Requires: %{name}-c++ = %{version}-%{release}
216Requires: %{name}-server = %{version}-%{release}
217
218%description server++
219XML-RPC is a quick-and-easy way to make procedure calls over the
220Internet. It converts the procedure call into XML document, sends it
221to a remote server using HTTP, and gets back the response as XML.
222
223These libraries provide a modular implementation of XML-RPC for C++
224servers.
225
226%description server++ -l pl.UTF-8
227XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
228Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
229zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
230
231Te biblioteki udostepniają modularną implementacją XML-RPC dla
232serwerów w języku C++.
233
234%package server++-devel
235Summary: C++ header files for xmlrpc-c server libraries
236Summary(pl.UTF-8): Pliki nagłówkowe C dla bibliotek serwerowych xmlrpc-c
237Group: Development/Libraries
238Requires: %{name}-c++-devel = %{version}-%{release}
239Requires: %{name}-server++ = %{version}-%{release}
240Requires: %{name}-server-devel = %{version}-%{release}
241
242%description server++-devel
243C++ header files for xmlrpc-c server libraries.
244
245%description server++-devel -l pl.UTF-8
246Pliki nagłówkowe C++ dla bibliotek serwerowych xmlrpc-c.
247
248%package apps
249Summary: Sample XML-RPC applications
250Summary(pl.UTF-8): Przykładowe aplikacje XML-RPC
251Group: Applications/Networking
252Requires: %{name} = %{version}-%{release}
253Requires: %{name}-c++ = %{version}-%{release}
254Requires: %{name}-client = %{version}-%{release}
255Requires: %{name}-client++ = %{version}-%{release}
256
257%description apps
258XML-RPC is a quick-and-easy way to make procedure calls over the
259Internet. It converts the procedure call into XML document, sends it
260to a remote server using HTTP, and gets back the response as XML.
261
262This package contains some handy XML-RPC demo applications.
263
264%description apps -l pl.UTF-8
265XML-RPC to szybki i łatwy w użyciu sposób wywoływania procedur poprzez
266Internet. Przekształca wywołanie procedury na dokument XML, wysyła do
267zdalnego serwera poprzez HTTP i odbiera odpowiedź jako XML.
268
269Ten pakiet zawiera kilka podręcznych aplikacji demonstracyjnych
270XML-RPC.
271
272%prep
273%setup -q
274%patch0 -p1
275%patch2 -p1
276%patch10 -p1
277%patch11 -p1
278%patch12 -p1
279%patch13 -p1
280%patch14 -p1
281%patch1 -p1
282%patch3 -p1
283
284%build
285mkdir -p build
286cd build
287%cmake .. \
288 -D_lib:STRING=%{_lib} \
289 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
290 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
291 -DMUST_BUILD_CURL_CLIENT:BOOL=ON \
292 -DMUST_BUILD_LIBWWW_CLIENT:BOOL=ON \
293 -DBUILD_SHARED_LIBS:BOOL=ON \
294 -DENABLE_TOOLS:BOOL=ON
295
296%{__make}
297
298%install
299rm -rf $RPM_BUILD_ROOT
300
301%{__make} -C build install \
302 DESTDIR=$RPM_BUILD_ROOT \
303
304chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so*
305
306# Win32-specific
307%{__rm} $RPM_BUILD_ROOT%{_includedir}/xmlrpc_server_w32httpsys.h \
308 $RPM_BUILD_ROOT%{_includedir}/xmlrpc-c/server_w32httpsys.h
309
310%clean
311rm -rf $RPM_BUILD_ROOT
312
313%post -p /sbin/ldconfig
314%postun -p /sbin/ldconfig
315
316%post client -p /sbin/ldconfig
317%postun client -p /sbin/ldconfig
318
319%post server -p /sbin/ldconfig
320%postun server -p /sbin/ldconfig
321
322%post c++ -p /sbin/ldconfig
323%postun c++ -p /sbin/ldconfig
324
325%post client++ -p /sbin/ldconfig
326%postun client++ -p /sbin/ldconfig
327
328%post server++ -p /sbin/ldconfig
329%postun server++ -p /sbin/ldconfig
330
331%files
332%defattr(644,root,root,755)
333%doc README doc/{COPYING,CREDITS,HISTORY,SECURITY,TODO}
334%attr(755,root,root) %{_libdir}/libxmlrpc-c.so.*.*
335%attr(755,root,root) %ghost %{_libdir}/libxmlrpc-c.so.3
336%attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so.*.*
337%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss.so.3
338%attr(755,root,root) %{_libdir}/libxmlrpc_util.so.*.*
339%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util.so.3
340
341%files devel
342%defattr(644,root,root,755)
343%doc doc/{DEVELOPING,TESTING}
344%attr(755,root,root) %{_bindir}/xmlrpc-c-config
345%attr(755,root,root) %{_libdir}/libxmlrpc-c.so
346%attr(755,root,root) %{_libdir}/libxmlrpc_abyss.so
347%attr(755,root,root) %{_libdir}/libxmlrpc_util.so
348%dir %{_includedir}/xmlrpc-c
349%{_includedir}/xmlrpc-c/abyss*.h
350%{_includedir}/xmlrpc-c/base.h
351%{_includedir}/xmlrpc-c/c_util.h
352%{_includedir}/xmlrpc-c/config.h
353%{_includedir}/xmlrpc-c/inttypes.h
354%{_includedir}/xmlrpc-c/json.h
355%{_includedir}/xmlrpc-c/oldxmlrpc.h
356%{_includedir}/xmlrpc-c/transport.h
357%{_includedir}/xmlrpc-c/util.h
358%{_includedir}/xmlrpc.h
359%{_pkgconfigdir}/xmlrpc.pc
360%{_pkgconfigdir}/xmlrpc_abyss.pc
361%{_pkgconfigdir}/xmlrpc_util.pc
362
363%files client
364%defattr(644,root,root,755)
365%attr(755,root,root) %{_libdir}/libxmlrpc_client.so.*.*
366%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client.so.3
367
368%files client-devel
369%defattr(644,root,root,755)
370%attr(755,root,root) %{_libdir}/libxmlrpc_client.so
371%{_includedir}/xmlrpc-c/client*.h
372%{_includedir}/xmlrpc_client.h
373%{_pkgconfigdir}/xmlrpc_client.pc
374
375%files server
376%defattr(644,root,root,755)
377%attr(755,root,root) %{_libdir}/libxmlrpc_server.so.*.*
378%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server.so.3
379%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so.*.*
380%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss.so.3
381%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so.*.*
382%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi.so.3
383
384%files server-devel
385%defattr(644,root,root,755)
386%attr(755,root,root) %{_libdir}/libxmlrpc_server.so
387%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss.so
388%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi.so
389%{_includedir}/xmlrpc-c/server.h
390%{_includedir}/xmlrpc-c/server_abyss.h
391%{_includedir}/xmlrpc-c/server_cgi.h
392%{_includedir}/xmlrpc_abyss.h
393%{_includedir}/xmlrpc_cgi.h
394%{_includedir}/xmlrpc_server.h
395%{_pkgconfigdir}/xmlrpc_server.pc
396%{_pkgconfigdir}/xmlrpc_server_abyss.pc
397%{_pkgconfigdir}/xmlrpc_server_cgi.pc
398
399%files c++
400%defattr(644,root,root,755)
401%attr(755,root,root) %{_libdir}/libxmlrpc++.so.*.*
402%attr(755,root,root) %ghost %{_libdir}/libxmlrpc++.so.8
403%attr(755,root,root) %{_libdir}/libxmlrpc_abyss++.so.*.*
404%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_abyss++.so.8
405%attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so.*.*
406%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_cpp.so.8
407%attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so.*.*
408%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_packetsocket.so.8
409%attr(755,root,root) %{_libdir}/libxmlrpc_util++.so.*.*
410%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_util++.so.8
411
412%files c++-devel
413%defattr(644,root,root,755)
414%attr(755,root,root) %{_libdir}/libxmlrpc++.so
415%attr(755,root,root) %{_libdir}/libxmlrpc_abyss++.so
416%attr(755,root,root) %{_libdir}/libxmlrpc_cpp.so
417%attr(755,root,root) %{_libdir}/libxmlrpc_packetsocket.so
418%attr(755,root,root) %{_libdir}/libxmlrpc_util++.so
419%{_includedir}/xmlrpc-c/base.hpp
420%{_includedir}/xmlrpc-c/base64.hpp
421%{_includedir}/xmlrpc-c/girerr.hpp
422%{_includedir}/xmlrpc-c/girmem.hpp
423%{_includedir}/xmlrpc-c/oldcppwrapper.hpp
424%{_includedir}/xmlrpc-c/packetsocket.hpp
425%{_includedir}/xmlrpc-c/registry.hpp
426%{_includedir}/xmlrpc-c/timeout.hpp
427%{_includedir}/xmlrpc-c/xml.hpp
428%{_includedir}/XmlRpcCpp.h
429%{_pkgconfigdir}/xmlrpc++.pc
430%{_pkgconfigdir}/xmlrpc_abyss++.pc
431%{_pkgconfigdir}/xmlrpc_cpp.pc
432%{_pkgconfigdir}/xmlrpc_packetsocket.pc
433%{_pkgconfigdir}/xmlrpc_util++.pc
434
435%files client++
436%defattr(644,root,root,755)
437%attr(755,root,root) %{_libdir}/libxmlrpc_client++.so.*.*
438%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_client++.so.8
439
440%files client++-devel
441%defattr(644,root,root,755)
442%attr(755,root,root) %{_libdir}/libxmlrpc_client++.so
443%{_includedir}/xmlrpc-c/client*.hpp
444%{_pkgconfigdir}/xmlrpc_client++.pc
445
446%files server++
447%defattr(644,root,root,755)
448%attr(755,root,root) %{_libdir}/libxmlrpc_server++.so.*.*
449%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server++.so.8
450%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so.*.*
451%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_abyss++.so.8
452%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so.*.*
453%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_cgi++.so.8
454%attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so.*.*
455%attr(755,root,root) %ghost %{_libdir}/libxmlrpc_server_pstream++.so.8
456
457%files server++-devel
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_libdir}/libxmlrpc_server++.so
460%attr(755,root,root) %{_libdir}/libxmlrpc_server_abyss++.so
461%attr(755,root,root) %{_libdir}/libxmlrpc_server_cgi++.so
462%attr(755,root,root) %{_libdir}/libxmlrpc_server_pstream++.so
463%{_includedir}/xmlrpc-c/server_abyss.hpp
464%{_includedir}/xmlrpc-c/server_pstream.hpp
465%{_pkgconfigdir}/xmlrpc_server++.pc
466%{_pkgconfigdir}/xmlrpc_server_abyss++.pc
467%{_pkgconfigdir}/xmlrpc_server_cgi++.pc
468%{_pkgconfigdir}/xmlrpc_server_pstream++.pc
469
470%files apps
471%defattr(644,root,root,755)
472%doc tools/xmlrpc_transport/xmlrpc_transport.html
473%attr(755,root,root) %{_bindir}/xmlrpc
474%attr(755,root,root) %{_bindir}/xmlrpc_parsecall
475%attr(755,root,root) %{_bindir}/xmlrpc_transport
476%attr(755,root,root) %{_bindir}/xml-rpc-api2cpp
477%attr(755,root,root) %{_bindir}/xml-rpc-api2txt
478%attr(755,root,root) %{_bindir}/xmlrpc_cpp_proxy
479%attr(755,root,root) %{_bindir}/xmlrpc_pstream
480%{_mandir}/man1/xml-rpc-api2cpp.1*
481%{_mandir}/man1/xml-rpc-api2txt.1*
This page took 0.034368 seconds and 4 git commands to generate.