]> git.pld-linux.org Git - packages/qt4.git/blame_incremental - qt4.spec
- fix amd64 linking.
[packages/qt4.git] / qt4.spec
... / ...
CommitLineData
1#
2# TODO:
3# - better descriptions
4# - more cleanups
5# - check if translations are avilable
6#
7# Conditional build:
8%bcond_with nas # enable NAS audio support
9# static libs disabled for now
10%bcond_with static_libs # build static libraries
11%bcond_without cups # disable CUPS support
12%bcond_without mysql # don't build MySQL plugin
13%bcond_without odbc # don't build unixODBC plugin
14%bcond_without pgsql # don't build PostgreSQL plugin
15%bcond_without designer # don't build designer (it takes long)
16%bcond_without sqlite3 # don't build SQLite3 plugin
17%bcond_without sqlite # don't build SQLite2 plugin
18%bcond_without ibase # don't build ibase (InterBase/Firebird) plugin
19%bcond_without pch # disable pch in qmake
20%bcond_with dont_enable # blocks translations, they are not yet available
21
22%undefine with_dont_enable
23
24%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
25%undefine with_ibase
26%endif
27%define _withsql 1
28%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
29
30Summary: The Qt GUI application framework
31Summary(es): Biblioteca para ejecutar aplicaciones GUI Qt
32Summary(pl): Biblioteka Qt do tworzenia GUI
33