]> git.pld-linux.org Git - packages/qt4.git/blame_incremental - qt4.spec
- for Qt4
[packages/qt4.git] / qt4.spec
... / ...
CommitLineData
1#
2# TODO:
3# - QtUiTools to subpackage
4# (headers in %{_includedir}/qt4/QtUiTools, but (static-only) lib is not installed)
5# - qt4-designer-libs vs QtDesigner-{devel,static} naming inconsistency
6# - better descriptions
7# - more cleanups
8# - check if translations are available
9#
10# Conditional build:
11%bcond_with nas # enable NAS audio support
12%bcond_without static_libs # build static libraries
13%bcond_without cups # disable CUPS support
14%bcond_without mysql # don't build MySQL plugin
15%bcond_without odbc # don't build unixODBC plugin
16%bcond_without pgsql # don't build PostgreSQL plugin
17%bcond_without designer # don't build designer (it takes long)
18%bcond_without sqlite3 # don't build SQLite3 plugin
19%bcond_without sqlite # don't build SQLite2 plugin
20%bcond_without ibase # don't build ibase (InterBase/Firebird) plugin
21%bcond_without pch # disable pch in qmake
22%bcond_with sse # use SSE instructions in gui/painting module
23%bcond_with dont_enable # blocks translations, they are not yet available
24
25%undefine with_dont_enable
26
27%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
28%undefine with_ibase
29%endif
30
31%ifarch pentium3 pentium4 %{x8664}
32%define with_sse 1
33%endif
34
35%define _withsql 1
36%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
37
38Summary: The Qt GUI application framework
39Summary(es): Biblioteca para ejecutar aplicaciones GUI Qt
40Summary(pl): Biblioteka Qt do tworzenia GUI
41