]> git.pld-linux.org Git - packages/qesteidutil.git/blame_incremental - qesteidutil.spec
fix QtSingleApplication link with qt5
[packages/qesteidutil.git] / qesteidutil.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with breakpad # build without breakpad crash reporting
4
5%ifnarch %{arm} %{ix86} %{x8664}
6%undefine with_breakpad
7%endif
8
9Summary: Estonian ID card utility
10Name: qesteidutil
11Version: 3.12.10
12Release: 1
13License: LGPL v2+
14Group: X11/Applications
15Source0: https://github.com/open-eid/qesteidutil/releases/download/v%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: 4e3805d3449e94427a67f5dfe7bae3c9
17Patch0: system_qtsingleapplication.patch
18Patch1: desktop.patch
19URL: https://github.com/open-eid/qesteidutil
20BuildRequires: Qt5Core-devel
21BuildRequires: Qt5Network-devel
22BuildRequires: Qt5SingleApplication-devel
23BuildRequires: Qt5Widgets-devel
24BuildRequires: cmake >= 3.0
25BuildRequires: desktop-file-utils
26BuildRequires: libstdc++-devel
27BuildRequires: openssl-devel
28BuildRequires: pcsc-lite-devel
29BuildRequires: qt5-build
30BuildRequires: qt5-linguist
31BuildRequires: qt5-qmake
32Requires(post,postun): gtk-update-icon-cache
33Requires(post,postun): hicolor-icon-theme
34Requires: hicolor-icon-theme
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38QEsteidUtil is an application for managing Estonian ID Card. In an
39user-friendly interface it is possible to change and unlock PINs,
40examine detailed information about personal data file on the card,
41extract and view certificates, set up mobile ID, and configure
42@eesti.ee email.
43
44%prep
45%setup -q
46%patch0 -p1
47%patch1 -p1
48
49# Remove bundled qtsingleapplication to make sure it isn't used
50rm -r common/qtsingleapplication
51
52%build
53install -d build
54cd build
55%cmake \
56%if %{without breakpad}
57 -DBREAKPAD="" \
58%endif
59 ..
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64%{__make} -C build install \
65 DESTDIR=$RPM_BUILD_ROOT
66
67desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/qesteidutil.desktop
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post
73%update_icon_cache hicolor
74
75%postun
76%update_icon_cache hicolor
77
78%files
79%defattr(644,root,root,755)
80%doc AUTHORS README RELEASE-NOTES.txt
81%attr(755,root,root) %{_bindir}/qesteidutil
82%{_mandir}/man1/qesteidutil.1*
83%{_desktopdir}/qesteidutil.desktop
84%{_iconsdir}/hicolor/*/apps/qesteidutil.png
This page took 0.106953 seconds and 4 git commands to generate.