]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- patch allowing to use fullscreen qemu as a whole workspace in kde
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4# - kqemu could be distributable if somebody bothers to contact qemu
5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
6#
7# Conditional build:
8%bcond_without kqemu # disable QEMU accelerator support
9%bcond_with cflags_passing # with passing rpmcflags to Makefiles
10%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
12%bcond_without dist_kernel # without distribution kernel
13%bcond_with kernel # build kqemu kernel modules
14%bcond_without smp # don't build SMP module
15%bcond_without userspace # don't build userspace utilities
16#
17%define _kqemu_version 1.3.0pre9
18%define _rel 0.4
19Summary: QEMU CPU Emulator
20Summary(pl): QEMU - emulator procesora
21Name: qemu
22Version: 0.8.2
23Release: %{_rel}%{?with_kqemu:k}
24License: GPL
25Group: Applications/Emulators
26#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
27Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
28# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
29Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
30# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
31Patch0: %{name}-nostatic.patch
32Patch1: %{name}-cc.patch
33Patch2: %{name}-longjmp.patch
34Patch3: %{name}-dot.patch
35Patch4: %{name}-gcc4_x86.patch
36Patch5: %{name}-gcc4_ppc.patch
37Patch6: %{name}-nosdlgui.patch
38Patch7: %{name}-ifup.patch
39URL: http://fabrice.bellard.free.fr/qemu/
40%if %{with kernel} && %{with dist_kernel}
41BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
42%endif
43%if %{with userspace}
44BuildRequires: SDL-devel >= 1.2.1
45BuildRequires: alsa-lib-devel
46%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
47BuildRequires: perl-tools-pod
48BuildRequires: rpmbuild(macros) >= 1.330
49BuildRequires: tetex
50BuildRequires: sed >= 4.0
51%endif
52Requires: SDL >= 1.2.1
53# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
54ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57# some SPARC boot image in ELF format
58%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
59
60%description
61QEMU is a FAST! processor emulator. By using dynamic translation it
62achieves a reasonnable speed while being easy to port on new host
63CPUs. QEMU has two operating modes:
64
65- User mode emulation. In this mode, QEMU can launch Linux processes
66 compiled for one CPU on another CPU. Linux system calls are converted
67 because of endianness and 32/64 bit mismatches. Wine (Windows
68 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
69
70- Full system emulation. In this mode, QEMU emulates a full system,
71 including a processor and various peripherials. It can also be used to
72 provide virtual hosting of several virtual PC on a single server.
73
74%description -l pl
75