]> git.pld-linux.org Git - packages/python3-pygments.git/blame_incremental - python3-pygments.spec
- updated to 2.14.0; requires pytest 7
[packages/python3-pygments.git] / python3-pygments.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
5
6%define module pygments
7Summary: A generic syntax highlighter as Python 3 module
8Summary(pl.UTF-8): Moduł Pythona 3 do ogólnego podświetlania składni
9Name: python3-%{module}
10Version: 2.14.0
11Release: 1
12License: BSD
13Group: Development/Languages/Python
14#Source0Download: https://pypi.org/simple/pygments/
15Source0: https://files.pythonhosted.org/packages/source/P/Pygments/Pygments-%{version}.tar.gz
16# Source0-md5: 447be4afb076c8325a7dc659aff5b931
17Patch0: rpmspec.patch
18URL: https://pygments.org/
19BuildRequires: python3 >= 1:3.6
20BuildRequires: python3-devel >= 1:3.6
21BuildRequires: python3-modules >= 1:3.6
22BuildRequires: python3-setuptools
23%if %{with tests}
24BuildRequires: python3-pytest >= 7
25BuildRequires: python3-wcag_contrast_ratio
26%endif
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.714
29%{?with_doc:BuildRequires: sphinx-pdg}
30Requires: python3-modules >= 1:3.6
31Requires: python3-setuptools
32Conflicts: python-pygments < 2.5.2
33BuildArch: noarch
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Pygments is a generic syntax highlighter for general use in all kinds
38of software such as forum systems, wikis or other applications that
39need to prettify source code. Highlights are:
40- a wide range of common languages and markup formats is supported
41- special attention is paid to details that increase highlighting
42 quality
43- support for new languages and formats are added easily; most
44 languages use a simple regex-based lexing mechanism
45- a number of output formats is available, among them HTML, RTF, LaTeX
46 and ANSI sequences
47- it is usable as a command-line tool and as a library
48- ... and it highlights even Brainf*ck!
49
50%description -l pl.UTF-8
51Pygments to moduł Pythona do podświetlania składni ogólnego
52przeznaczenia we wszelkiego rodzaju programach, takich jaka systemy
53forów, wiki i inne plikacje wymagające ładnego wyświetlania kodu
54źródłowego. Zalety Pygments to:
55- obsługiwany szeroki zakres popularnych języków i formatów znaczników
56- zwrócenie szczególnej uwagi na szczegóły zwiększające jakość
57 podświetlania
58- łatwa obsługa nowych języków i formatów; większość języków
59 wykorzystuje prosty mechanizm analizy leksykalnej oparty o wyrażenia
60 regularne
61- dostępność wielu formatów wyjściowych, m.in. HTML, RTF, LaTeX i
62 sekwencje ANSI
63- możliwość używania z linii poleceń oraz jako biblioteki
64- ...a także - podświetla nawet Brainf*cka!
65
66%package apidocs
67Summary: API documentation for Python Pygments module
68Summary(pl.UTF-8): Dokumentacja API modułu Pythona Pygments
69Group: Documentation
70
71%description apidocs
72API documentation for Python Pygments module.
73
74%description apidocs -l pl.UTF-8
75Dokumentacja API modułu Pythona Pygments.
76
77%prep
78%setup -q -n Pygments-%{version}
79%patch0 -p1
80
81%build
82%py3_build
83
84%if %{with tests}
85PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
86%{__python3} -m pytest tests
87%endif
88
89%if %{with doc}
90PYTHONPATH=$(pwd) \
91%{__make} -C doc html
92%endif
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%py3_install
98
99%{__mv} $RPM_BUILD_ROOT%{_bindir}/pygmentize{,-3}
100
101ln -sf pygmentize-3 $RPM_BUILD_ROOT%{_bindir}/pygmentize
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%files
107%defattr(644,root,root,755)
108%doc AUTHORS CHANGES LICENSE README.rst
109%attr(755,root,root) %{_bindir}/pygmentize
110%attr(755,root,root) %{_bindir}/pygmentize-3
111%{py3_sitescriptdir}/pygments
112%{py3_sitescriptdir}/Pygments-%{version}-py*.egg-info
113
114%if %{with doc}
115%files apidocs
116%defattr(644,root,root,755)
117%doc doc/_build/html/{_static,docs,*.html,*.js}
118%endif
This page took 0.043188 seconds and 4 git commands to generate.