]> git.pld-linux.org Git - packages/python-tables.git/blame_incremental - python-tables.spec
automatic change: use py_build/py_install macros
[packages/python-tables.git] / python-tables.spec
... / ...
CommitLineData
1
2%define module tables
3
4Summary: Dealing with large datasets in Python
5Summary(pl.UTF-8): Obsługa dużych zbiorów danych w Pythonie
6Name: python-%{module}
7Version: 1.2.1
8Release: 1
9License: GNU
10Group: Development/Languages/Python
11Source0: http://dl.sourceforge.net/pytables/pytables-%{version}.tar.gz
12# Source0-md5: 0fb331822f27e3cb03d04bd4247e8032
13URL: http://pytables.sourceforge.net/
14BuildRequires: hdf5-devel
15BuildRequires: lzo-devel
16BuildRequires: python
17BuildRequires: python-devel >= 1:2.3
18BuildRequires: python-numarray
19BuildRequires: python-numarray-devel
20BuildRequires: ucl-devel
21%pyrequires_eq python-modules
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25PyTables is a hierarchical database package designed to efficiently
26manage very large amounts of data.
27
28PyTables is built on top of the HDF5 library and the numarray package.
29It features an object-oriented interface that, combined with C
30extensions for the peformance-critical parts of the code (generated
31using Pyrex), makes it a fast, yet extremely easy to use tool for
32interactively save and retrieve very large amounts of data. One
33important feature of PyTables is that it optimizes memory and disk
34resources so that data take much less space (between a factor 3 to 5,
35and more if the data is compressible) than other solutions, like for
36example, relational or object oriented databases.
37
38Besides, it provides a flexible, direct access on disk to anywhere in
39the data you want to go, using a combination of natural naming and
40extended slicing features.
41
42%description -l pl.UTF-8
43PyTables jest hierarchiczną bazą danych zaprojektowaną aby wydajnie
44zarządzać bardzo dużymi ilościami danych.
45
46PyTables jest zbudowany w oparciu o bibliotekę HDF5 i pakiet numarray.
47Zapewnia zorientowany obiektowo interfejs, dzięki któremu, w
48połączeniu z przepisanymi do C krytycznymi częściami kodu, pozwala na
49bardzo szybkie i łatwe używanie tego narzędzia do interaktywnego
50zapisu lub odczytu dużych ilości danych. Jedną z ważniejszych zalet
51PyTables jest optymalizacja zużycia pamięci i przestrzeni dyskowej.
52
53%prep
54%setup -q -n pytables-%{version}
55
56%build
57CFLAGS="%{rpmcflags}"
58export CFLAGS
59python setup.py build_ext --inplace
60
61%install
62rm -rf $RPM_BUILD_ROOT
63
64install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66%py_install
67
68mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | xargs rm
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(644,root,root,755)
77%doc README.txt LICENSE
78%attr(755,root,root) %{_bindir}/*
79%dir %{py_sitedir}/%{module}
80%{py_sitedir}/%{module}/*
81%dir %{_examplesdir}/%{name}-%{version}
82%{_examplesdir}/%{name}-%{version}/*
This page took 0.093045 seconds and 4 git commands to generate.