]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- added missing Requires for php-snmp
[packages/php.git] / php.spec
... / ...
CommitLineData
1#
2# TODO:
3# - loading pgsql+mnogosearch+snmp (only in this order!) causes php -i to SEGV on exit
4# (postgresql-libs-8.0.1-1, net-snmp-libs-5.2.1-0.2, mnogosearch-lib-3.2.32-1)
5# (only php.cli; php.cgi and apache2 module are not affected)
6# same result on mysql+curl+msession (on php.cli -i or php.cgi with empty imput)
7#
8# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
9# - think of including support for:
10# - mcve,
11# - ovrimos,
12# - pfpro,
13# - ircg,
14# These extensions BuildRequires proprietary libraries...
15# - deal with modules removed from php and not moved to PECL
16# (existing only in php4):
17# db, hyperwave, java, mcal, overload, qtdom
18# - enabling sybase+sybase_ct+mssql together causes SEGV beside warnings
19# - mime_magic can't handle new "string/*" entries in magic.mime
20# - make additional headers added by mail patch configurable
21# - apply -hardened patch by default ?
22#
23# Conditional build:
24%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
25%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
26%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
27%bcond_with hwapi # with Hw API support (BR: proprietary libs)
28%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
29%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
30%bcond_with oracle # with oracle extension module (BR: proprietary libs)
31%bcond_with apache1 # build with apache1
32%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
33%bcond_without cpdf # without cpdf extension module
34%bcond_without curl # without CURL extension module
35%bcond_without fam # without FAM (File Alteration Monitor) extension module
36%bcond_without imap # without IMAP extension module
37%bcond_without interbase # without InterBase extension module
38%bcond_without ldap # without LDAP extension module
39%bcond_without mhash # without mhash extension module
40%bcond_without ming # without ming extension module
41%bcond_without mm # without mm support for session storage
42%bcond_without mnogosearch # without mnogosearch extension module
43%bcond_without msession # without msession extension module
44%bcond_without mssql # without MS SQL extension module
45%bcond_without odbc # without ODBC extension module
46%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
47%bcond_without pcre # without PCRE extension module
48%bcond_without pgsql # without PostgreSQL extension module
49%bcond_without pspell # without pspell extension module
50%bcond_without recode # without recode extension module
51%bcond_without snmp # without SNMP extension module
52%bcond_without sqlite # without SQLite extension module
53%bcond_without sybase # without Sybase extension module
54%bcond_without sybase_ct # without Sybase-CT extension module
55%bcond_without tidy # without Tidy extension module
56%bcond_without wddx # without WDDX extension module
57%bcond_without xmlrpc # without XML-RPC extension module
58
59%define _apache2 %{?with_apache1:0}%{!?with_apache1:1}
60%if %{_apache2}
61%define apxs /usr/sbin/apxs
62%else
63%define apxs /usr/sbin/apxs1
64%endif
65# some problems with apache 2.x
66%if %{_apache2}
67%undefine with_mm
68%endif
69%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
70%undefine with_interbase
71%endif
72# x86-only lib
73%ifnarch %{ix86}
74%undefine with_msession
75%endif
76%include /usr/lib/rpm/macros.php
77Summary: The PHP HTML-embedded scripting language for use with Apache
78Summary(fr): Le langage de script embarque-HTML PHP pour Apache
79