]> git.pld-linux.org Git - packages/php-pecl-svn.git/blame_incremental - php-pecl-svn.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-svn.git] / php-pecl-svn.spec
... / ...
CommitLineData
1%define php_name php%{?php_suffix}
2%define modname svn
3%define status stable
4Summary: PHP Bindings for the Subversion Revision control system
5Summary(pl.UTF-8): Dowiązania PHP do systemou kontroli rewizji Subversion
6Name: %{php_name}-pecl-%{modname}
7Version: 1.0.2
8Release: 4
9License: PHP 3.01
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
12# Source0-md5: 45407d43f1055eb72e149d1862f3daa1
13URL: http://pecl.php.net/package/svn/
14BuildRequires: %{php_name}-devel >= 3:5.0.0
15BuildRequires: re2c >= 0.12.0
16BuildRequires: rpmbuild(macros) >= 1.650
17BuildRequires: subversion-devel >= 1.3
18%{?requires_php_extension}
19Requires: php(core) >= 5.0.4
20Provides: php(%{modname}) = %{version}
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Bindings for the Subversion revision control system, providing a
25method for manipulating a working copy or repository with PHP.
26
27In PECL status of this extension is: %{status}.
28
29%description -l pl.UTF-8
30Pakiet ten dostarcza dowiązań do systemu kontroli rewizji Subversion,
31dostarczając metod do obróbki lokalną kopią lub repozytorium z poziomu
32PHP.
33
34To rozszerzenie ma w PECL status: %{status}.
35
36%prep
37%setup -qc
38mv %{modname}-%{version}/* .
39
40%build
41phpize
42%configure
43%{__make} \
44 CFLAGS="%{rpmcflags} $(apu-1-config --includes)"
45
46%install
47rm -rf $RPM_BUILD_ROOT
48install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
49
50%{__make} install \
51 EXTENSION_DIR=%{php_extensiondir} \
52 INSTALL_ROOT=$RPM_BUILD_ROOT
53cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
54; Enable %{modname} extension module
55extension=%{modname}.so
56EOF
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%php_webserver_restart
63
64%postun
65if [ "$1" = 0 ]; then
66 %php_webserver_restart
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc CREDITS EXPERIMENTAL
72%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
73%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.103642 seconds and 4 git commands to generate.