]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blame_incremental - php-pecl-sasl.spec
support building for multiple php versions
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
... / ...
CommitLineData
1%define php_name php%{?php_suffix}
2%define modname sasl
3%define status alpha
4Summary: %{modname} - Cyrus SASL extension
5Summary(pl.UTF-8): %{modname} - rozszerzenie Cyrus SASL
6Name: %{php_name}-pecl-%{modname}
7Version: 0.1.0
8Release: 12
9License: PHP 3.01
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
12# Source0-md5: 8431731cc8a7921a2922af23a57a572f
13Patch0: php-pecl-%{modname}-lib_fix.patch
14Patch1: php-pecl-%{modname}-lib64_fix.patch
15URL: http://pecl.php.net/package/sasl/
16BuildRequires: cyrus-sasl-devel
17BuildRequires: %{php_name}-devel >= 3:5.0.0
18BuildRequires: rpmbuild(macros) >= 1.650
19%{?requires_php_extension}
20Requires: php(core) >= 5.0.4
21Obsoletes: php-pear-%{modname}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25SASL is the Simple Authentication and Security Layer (as defined by
26RFC 2222). It provides a system for adding plugable authenticating
27support to connection-based protocols. The SASL extension for PHP
28makes the Cyrus SASL library functions available to PHP. It aims to
29provide a 1-to-1 wrapper around the SASL library to provide the
30greatest amount of implementation flexibility. To that end, it is
31possible to build both a client-side and server-side SASL
32implementation entirely in PHP.
33
34In PECL status of this extension is: %{status}.
35
36%description -l pl.UTF-8
37SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
38Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
39system do dodawania wtyczek obsługujących uwierzytelnianie do
40protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
41udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
42dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
43największą elastyczność implementacji. W tym celu możliwe jest
44zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
45całkowicie w PHP.
46
47To rozszerzenie ma w PECL status: %{status}.
48
49%prep
50%setup -qc
51mv %{modname}-%{version}/* .
52# Ugly, could be done somehow prettier (one combined patch?)
53%if "%{_lib}" == "lib64"
54%patch1 -p2
55%else
56%patch0 -p2
57%endif
58
59%build
60phpize
61%configure
62%{__make}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
67install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
68cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
69; Enable %{modname} extension module
70extension=%{modname}.so
71EOF
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77%php_webserver_restart
78
79%postun
80if [ "$1" = 0 ]; then
81 %php_webserver_restart
82fi
83
84%files
85%defattr(644,root,root,755)
86%doc docs/TODO
87%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
88%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.526211 seconds and 4 git commands to generate.