]> git.pld-linux.org Git - packages/perl-Guard.git/blame_incremental - perl-Guard.spec
- removed zero-sized .bs file
[packages/perl-Guard.git] / perl-Guard.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Guard
7Summary: Guard - safe cleanup blocks
8Summary(pl.UTF-8): Guard - bezpieczne czyszczenie bloków
9Name: perl-Guard
10Version: 1.022
11Release: 3
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
16# Source0-md5: 8d1d8b942fd5d0240f47906a6d6fac8c
17URL: http://search.cpan.org/dist/Guard/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This module implements so-called "guards". A guard is something
24(usually an object) that "guards" a resource, ensuring that it is
25cleaned up when expected.
26
27Specifically, this module supports two different types of guards:
28guard objects, which execute a given code block when destroyed, and
29scoped guards, which are tied to the scope exit.
30
31%description -l pl.UTF-8
32Moduł ten implementuje tzw. "strażników". Strażnik jest czymś (zwykle
33obiektem), co strzeże zasobu, zapewniając jego usunięcie wtedy, kiedy
34jest ono oczekiwane.
35
36W szczegóności moduł ten obsługuje dwa rodzaje strażników:
37- obiekty strażników, wykonujące dany blok kodu w trakcie niszczenia
38- strażników zakresowych, powiązanych z zakończeniem zakresu (scope).
39
40%prep
41%setup -q -n %{pdir}-%{version}
42
43%build
44%{__perl} Makefile.PL \
45 INSTALLDIRS=vendor
46%{__make} \
47 CC="%{__cc}" \
48 OPTIMIZE="%{rpmcflags}"
49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc COPYING Changes
64%{perl_vendorarch}/Guard.pm
65%dir %{perl_vendorarch}/auto/Guard
66%attr(755,root,root) %{perl_vendorarch}/auto/Guard/Guard.so
67%{_mandir}/man3/Guard.3pm*
This page took 0.425939 seconds and 4 git commands to generate.