]> git.pld-linux.org Git - packages/perl-EV.git/blame_incremental - perl-EV.spec
- perl req/prov fix
[packages/perl-EV.git] / perl-EV.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # perform "make test"
4
5%define pdir EV
6%include /usr/lib/rpm/macros.perl
7Summary: EV - Perl interface to libev, a high performance full-featured event loop
8Summary(pl.UTF-8): EV - perlowy interfejs do libev - wydajnej pętli zdarzeń
9Name: perl-EV
10Version: 4.22
11Release: 5
12Epoch: 1
13# same as Perl, libev: BSD-like
14License: GPL v1+ or Artistic (Perl module), BSD-like (embedded libev)
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
17# Source0-md5: 8bca55688edafcf98ab6d7a86ea195be
18URL: http://search.cpan.org/dist/EV/
19BuildRequires: perl-Canary-Stability
20BuildRequires: perl-common-sense
21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This module provides an interface to libev
27<http://software.schmorp.de/pkg/libev.html>.
28
29This module is very fast and scalable. It is actually so fast that you
30can use it through the AnyEvent module, stay portable to other event
31loops (if you don't rely on any watcher types not available through
32it) and still be faster than with any other event loop currently
33supported in Perl.
34
35%description -l pl.UTF-8
36Moduł ten dostarcza intefejs do libev
37<http://software.schmorp.de/pkg/libev.html>.
38
39Jest bardzo szybki i skalowalny. Właściwie jest na tyle szybki, że
40można go użyć poprzez moduł AnyEvent i pozostawić kod przenośnym na
41inne pętle zdarzeń (jeśli nie jest wymagane użycie typów obserwatorów
42niedostępnych przez AnyEvent), i całość jest nadal szybsza niż inne
43pętle zdarzeń dostępne z poziomu Perla.
44
45%prep
46%setup -q -n %{pdir}-%{version}
47
48%build
49%{__perl} Makefile.PL \
50 INSTALLDIRS=vendor </dev/null
51%{__make} \
52 CC="%{__cc}" \
53 OPTIMIZE="%{rpmcflags}"
54
55%{?with_tests:%{__make} test}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60%{__make} pure_install \
61 DESTDIR=$RPM_BUILD_ROOT
62
63install -d libev-doc
64mv -f libev/{Changes,LICENSE,README} libev-doc
65%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/EV/libev.pod
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc Changes COPYING README libev-doc
73%dir %{perl_vendorarch}/EV
74%{perl_vendorarch}/EV/*.pm
75%{perl_vendorarch}/EV.pm
76%{perl_vendorarch}/EV/EVAPI.h
77%{perl_vendorarch}/EV/ev.h
78%dir %{perl_vendorarch}/auto/EV
79%attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
80%{_mandir}/man3/EV*.3pm*
This page took 0.0389 seconds and 4 git commands to generate.