]> git.pld-linux.org Git - packages/perl-Device-SerialPort.git/blame_incremental - perl-Device-SerialPort.spec
- removed zero-sized .bs file
[packages/perl-Device-SerialPort.git] / perl-Device-SerialPort.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # perform "make test" (uses serial port)
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Device
7%define pnam SerialPort
8Summary: Device::SerialPort - Linux/POSIX emulation of Win32::SerialPort functions
9Summary(pl.UTF-8): Device::SerialPort - zgodna z POSIX emulacja funcji Win32::SerialPort w Linuksie
10Name: perl-Device-SerialPort
11Version: 1.04
12Release: 6
13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17# Source0-md5: 82c698151f934eb28c65d1838cee7d9e
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Device::SerialPort module provides an object-based user interface
24essentially identical to the one provided by the Win32::SerialPort
25module.
26
27%description -l pl.UTF-8
28Moduł Device::SerialPort udostępnia zorientowany obiektowo interfejs,
29zasadniczo identyczny z interfejsem udostępnianym przez moduł
30Win32::SerialPort.
31
32%prep
33%setup -q -n %{pdir}-%{pnam}-%{version}
34
35# hack device test
36%{__perl} -pi -e 's/^ print "\\tchecking.*$/\$file="\$test"; last;/' Makefile.PL
37
38%build
39%{__perl} Makefile.PL \
40 INSTALLDIRS=vendor \
41 TESTPORT="/dev/ttyS1"
42%{__make}
43
44%{?with_tests:%{__make} test}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48
49%{__make} install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%doc Change* README TODO
61%attr(755,root,root) %{_bindir}/modemtest
62%{perl_vendorarch}/Device/*.pm
63%dir %{perl_vendorarch}/auto/Device/SerialPort
64%attr(755,root,root) %{perl_vendorarch}/auto/Device/SerialPort/SerialPort.so
65%attr(755,root,root) %{_examplesdir}/%{name}-%{version}
66%{_mandir}/man[13]/*
This page took 0.044945 seconds and 4 git commands to generate.