]> git.pld-linux.org Git - packages/perl-Crypt-Twofish2.git/blame_incremental - perl-Crypt-Twofish2.spec
- rebuild with perl 5.28.0
[packages/perl-Crypt-Twofish2.git] / perl-Crypt-Twofish2.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without tests # Do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Crypt
7%define pnam Twofish2
8Summary: Crypt::Twofish2 - Crypt::CBC compliant Twofish encryption Perl module
9Summary(pl.UTF-8): Crypt::Twofish2 - perlowy moduł szyfru Twofish zgodny z Crypt::CBC
10Name: perl-Crypt-Twofish2
11Version: 1.02
12Release: 10
13License: GPL v2
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 28efe17baac40c14914912bb3e5932b5
17URL: http://search.cpan.org/dist/Crypt-Twofish2/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23This module implements the Twofish cipher in a less braindamaged
24(read: slow and ugly) way than the existing "Crypt::Twofish" module.
25Although it is "Crypt::CBC" compliant you usually gain nothing by
26using that module (except generality), since "Crypt::Twofish2" can
27work in either ECB or CBC mode.
28
29%description -l pl.UTF-8
30Ten moduł jest implementacją szyfru Twofish w mniej debilny (powolny
31i paskudny) sposób niż moduł Crypt::Twofish. Pomimo tego, że jest
32zgodny z Crypt::CBC, nie ma potrzeby używania tamtego modułu, ponieważ
33Crypt::Twofish2 może działać zarówno w trybie ECB jak i CBC.
34
35%prep
36%setup -q -n %{pdir}-%{pnam}-%{version}
37
38%build
39%{__perl} Makefile.PL \
40 INSTALLDIRS=vendor
41%{__make} \
42 CC="%{__cc}" \
43 OPTIMIZE="%{rpmcflags}"
44
45%{?with_tests:%{__make} test}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49
50%{__make} install \
51 DESTDIR=$RPM_BUILD_ROOT
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Changes README
59%{perl_vendorarch}/Crypt/Twofish2.pm
60%dir %{perl_vendorarch}/auto/Crypt/Twofish2
61%attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish2/*.so
62%{_mandir}/man3/*
This page took 0.048962 seconds and 4 git commands to generate.