]> git.pld-linux.org Git - packages/microcode-data-intel.git/blame_incremental - microcode-data-intel.spec
- up to 20171117
[packages/microcode-data-intel.git] / microcode-data-intel.spec
... / ...
CommitLineData
1Summary: Microcode definitions for Intel processors
2Summary(pl.UTF-8): Definicje mikrokodu dla procesorów Intela
3Name: microcode-data-intel
4Version: 20171117
5Release: 1
6License: INTEL SOFTWARE LICENSE AGREEMENT
7Group: Base
8# http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
9Source0: http://downloadmirror.intel.com/27337/eng/microcode-%{version}.tgz
10# Source0-md5: b294245d1f7f6c20f01edba53185f258
11# Tool for splitting Intel's microcode file. From Fedora
12Source1: intel-microcode2ucode.c
13# Produces single file for use by boot loader (like grub)
14Source2: intel-microcode2ucode-single.c
15BuildRequires: cpio
16Provides: microcode-data
17BuildArch: noarch
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21The microcode data file for Linux contains the latest microcode
22definitions for all Intel processors.
23
24%description -l pl.UTF-8
25Te pliki danych mikrokodu dla Linuksa zawierają najnowsze definicje
26mikrokodu dla procesorów Intela.
27
28%package initrd
29Summary: Microcode for initrd
30Summary(pl.UTF-8): Mikrokod dla initrd
31Group: Base
32
33%description initrd
34Intel microcode for initrd.
35
36%description initrd -l pl.UTF-8
37Mikrokod dla procesorów Intel dla initrd.
38
39%prep
40%setup -qc
41
42
43%build
44if ! grep -q 0x00000000 microcode.dat; then
45 echo >&2 microcode.dat contains giberrish
46 exit 1
47fi
48
49%{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
50%{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode-single %{SOURCE2}
51
52./intel-microcode2ucode microcode.dat > 1.log
53./intel-microcode2ucode-single microcode.dat > 2.log
54
55install -d kernel/x86/microcode
56ln microcode.bin kernel/x86/microcode/GenuineIntel.bin
57echo kernel/x86/microcode/GenuineIntel.bin | cpio -o -H newc -R 0:0 > intel-ucode.img
58
59%install
60rm -rf $RPM_BUILD_ROOT
61install -d $RPM_BUILD_ROOT{/lib/firmware,/boot}
62
63cp -a intel-ucode $RPM_BUILD_ROOT/lib/firmware
64cp -p intel-ucode.img $RPM_BUILD_ROOT/boot
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(644,root,root,755)
71/lib/firmware/intel-ucode
72
73%files initrd
74%defattr(644,root,root,755)
75/boot/intel-ucode.img
This page took 0.061968 seconds and 4 git commands to generate.