]> git.pld-linux.org Git - packages/libnotify.git/blame_incremental - libnotify.spec
Update to 0.7.7
[packages/libnotify.git] / libnotify.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # disable gtk-doc
4%bcond_without static_libs # don't build static library
5%bcond_without tests # build without tests
6
7Summary: Desktop notifications library
8Summary(hu.UTF-8): Desktop értesítő könyvtár
9Summary(pl.UTF-8): Biblioteka powiadomień dla pulpitu
10Name: libnotify
11Version: 0.7.7
12Release: 1
13License: LGPL v2.1+ (library), GPL v2+ (tools)
14Group: Libraries
15Source0: http://ftp.gnome.org/pub/GNOME/sources/libnotify/0.7/%{name}-%{version}.tar.xz
16# Source0-md5: e9d911f6a22435e0b922f2fe71212b59
17URL: http://developer.gnome.org/notification-spec/
18BuildRequires: autoconf >= 2.63
19BuildRequires: automake >= 1:1.10
20BuildRequires: docbook-dtd412-xml
21BuildRequires: gdk-pixbuf2-devel
22BuildRequires: glib2-devel >= 1:2.26.0
23BuildRequires: gobject-introspection-devel >= 0.9.12
24%{?with_tests:BuildRequires: gtk+3-devel >= 3.0.0}
25%{?with_apidocs:BuildRequires: gtk-doc >= 1.14}
26BuildRequires: gtk-doc-automake >= 1.14
27BuildRequires: libtool >= 2:2.2
28BuildRequires: pkgconfig
29BuildRequires: tar >= 1:1.22
30BuildRequires: xz
31Requires: glib2 >= 1:2.26.0
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35A library that sends desktop notifications to a notification daemon,
36as defined in the Desktop Notifications spec. These notifications can
37be used to inform the user about an event or display some form of
38information without getting in the user's way.
39
40%description -l hu.UTF-8
41Könyvtár, amely értesítéseket küld egy üzenetkezelő démonnak, ahogy a
42Desktop Notifications szabványnak megfelel. Ezek az értesítések
43tájékoztathatják a felhasználót eseményről vagy információt jeleníthet
44meg.
45
46%description -l pl.UTF-8
47Biblioteka wysyłająca powiadomienia dla pulpitu do demona powiadomień
48zgodnie ze specyfikacją Desktop Notifications. Powiadomienia te mogą
49być używane do informowania użytkownika o zdarzeniu lub wyświetlania
50jakiejś formy informacji bez wchodzenia użytkownikowi w drogę.
51
52%package devel
53Summary: libnotify header files
54Summary(hu.UTF-8): libnotify fejléc fájlok
55Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libnotify
56License: LGPL v2.1+
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: gdk-pixbuf2-devel
60Requires: glib2-devel >= 1:2.26.0
61
62%description devel
63Header files for libnotify-based programs development.
64
65%description devel -l hu.UTF-8
66Fejléc fájlok libnotify-t használó programok fejlesztéséhez.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe do tworzenia programów opartych o libnotify.
70
71%package static
72Summary: Static libnotify library
73Summary(hu.UTF-8): Libnotify statikus könyvtár
74Summary(pl.UTF-8): Statyczna biblioteka libnotify
75License: LGPL v2.1+
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78
79%description static
80Static libnotify library.
81
82%description static -l hu.UTF-8
83Libnotify statikus könyvtár.
84
85%description static -l pl.UTF-8
86Statyczna biblioteka libnotify.
87
88%package apidocs
89Summary: libnotify API documentation
90Summary(hu.UTF-8): libnotify API dokumentáció
91Summary(pl.UTF-8): Dokumentacja API biblioteki libnotify
92Group: Documentation
93Requires: gtk-doc-common
94%if "%{_rpmversion}" >= "5"
95BuildArch: noarch
96%endif
97
98%description apidocs
99libnotify API documentation.
100
101%description apidocs -l hu.UTF-8
102libnotify API dokumentáció.
103
104%description apidocs -l pl.UTF-8
105Dokumentacja API biblioteki libnotify.
106
107%prep
108%setup -q
109
110%{!?with_tests:%{__sed} -i -e '/SUBDIRS/ s/tests//' Makefile.am}
111%{!?with_tests:%{__sed} -i -e '/PKG_CHECK_MODULES(TESTS/ s/^/#/' configure.ac}
112
113%build
114%{__gtkdocize}
115%{__libtoolize}
116%{__aclocal}
117%{__autoconf}
118%{__autoheader}
119%{__automake}
120%configure \
121 --disable-silent-rules \
122 --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
123 --with-html-dir=%{_gtkdocdir} \
124 %{!?with_static_libs:--disable-static}
125
126%{__make}
127
128%{?with_tests:%{__make} check}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132
133%{__make} install \
134 DESTDIR=$RPM_BUILD_ROOT
135
136%{!?with_apidocs:%{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}/libnotify}
137
138%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
145
146%files
147%defattr(644,root,root,755)
148%doc AUTHORS ChangeLog NEWS
149%attr(755,root,root) %{_bindir}/notify-send
150%attr(755,root,root) %{_libdir}/libnotify.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libnotify.so.4
152%{_libdir}/girepository-1.0/Notify-0.7.typelib
153
154%files devel
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_libdir}/libnotify.so
157%{_pkgconfigdir}/libnotify.pc
158%{_includedir}/libnotify
159%{_datadir}/gir-1.0/Notify-0.7.gir
160
161%if %{with static_libs}
162%files static
163%defattr(644,root,root,755)
164%{_libdir}/libnotify.a
165%endif
166
167%if %{with apidocs}
168%files apidocs
169%defattr(644,root,root,755)
170%{_gtkdocdir}/%{name}
171%endif
This page took 0.063675 seconds and 4 git commands to generate.