]> git.pld-linux.org Git - packages/kf5-sonnet.git/blame_incremental - kf5-sonnet.spec
- updated to 5.53.0
[packages/kf5-sonnet.git] / kf5-sonnet.spec
... / ...
CommitLineData
1# TODO:
2# - fix build with aspell
3%define kdeframever 5.53
4%define qtver 5.9.0
5%define kfname sonnet
6
7Summary: Multi-language spell checker
8Name: kf5-%{kfname}
9Version: 5.53.0
10Release: 1
11License: LGPL v2.1+
12Group: X11/Libraries
13Source0: http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14# Source0-md5: fd28bda2bd2c1c0d40e477930394ed14
15URL: http://www.kde.org/
16BuildRequires: Qt5Core-devel >= %{qtver}
17BuildRequires: Qt5Gui-devel >= %{qtver}
18BuildRequires: Qt5Test-devel >= %{qtver}
19BuildRequires: Qt5Widgets-devel >= %{qtver}
20BuildRequires: aspell
21BuildRequires: aspell-devel
22BuildRequires: cmake >= 2.8.12
23BuildRequires: hspell-devel
24BuildRequires: hunspell-devel
25BuildRequires: kf5-extra-cmake-modules >= 1.4.0
26BuildRequires: qt5-linguist >= %{qtver}
27BuildRequires: rpmbuild(macros) >= 1.164
28BuildRequires: tar >= 1:1.22
29BuildRequires: libvoikko-devel
30BuildRequires: xz
31BuildRequires: zlib-devel
32Requires: kf5-dirs
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define qt5dir %{_libdir}/qt5
36
37%description
38Sonnet is a plugin-based spell checking library for Qt-based
39applications. It supports several different plugins, including HSpell,
40Enchant, ASpell and HUNSPELL.
41
42It also supports automated language detection, based on a combination
43of different algorithms.
44
45The simplest way to use Sonnet in your application is to use the
46SpellCheckDecorator class on your QTextEdit.
47
48%package devel
49Summary: Header files for %{kfname} development
50Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
51Group: X11/Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55Header files for %{kfname} development.
56
57%description devel -l pl.UTF-8
58Pliki nagłówkowe dla programistów używających %{kfname}.
59
60%prep
61%setup -q -n %{kfname}-%{version}
62
63%build
64install -d build
65cd build
66%cmake \
67 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68 ../
69%{__make}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%{__make} -C build/ install \
75 DESTDIR=$RPM_BUILD_ROOT
76
77%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83%postun -p /sbin/ldconfig
84
85%files -f %{kfname}5_qt.lang
86%defattr(644,root,root,755)
87%doc README.md
88%attr(755,root,root) %{_bindir}/gentrigrams
89%attr(755,root,root) %{_bindir}/parsetrigrams
90%attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
91%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
92%attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
93%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
94%dir %{qt5dir}/plugins/kf5/sonnet
95%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
96%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
97%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
98%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
99%dir %{_datadir}/kf5/sonnet
100%{_datadir}/kf5/sonnet/trigrams.map
101/etc/xdg/sonnet.categories
102
103%files devel
104%defattr(644,root,root,755)
105%{_includedir}/KF5/SonnetCore
106%{_includedir}/KF5/SonnetUi
107%{_includedir}/KF5/sonnet_version.h
108%{_libdir}/cmake/KF5Sonnet
109%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
110%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
111%{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
112%{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.069029 seconds and 4 git commands to generate.