]> git.pld-linux.org Git - packages/kf5-kplotting.git/blame_incremental - kf5-kplotting.spec
- updated to 5.110.0
[packages/kf5-kplotting.git] / kf5-kplotting.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%define kdeframever 5.110
5%define qtver 5.15.2
6%define kfname kplotting
7#
8Summary: Data plotting
9Name: kf5-%{kfname}
10Version: 5.110.0
11Release: 1
12License: LGPL v2.1+
13Group: X11/Libraries
14Source0: https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15# Source0-md5: 8d014342611f0d2a50af3886b83f2e66
16URL: http://www.kde.org/
17BuildRequires: Qt5Core-devel
18BuildRequires: Qt5Gui-devel >= 5.3.1
19BuildRequires: Qt5Test-devel
20BuildRequires: Qt5Widgets-devel
21BuildRequires: cmake >= 3.16
22BuildRequires: kf5-extra-cmake-modules >= %{version}
23BuildRequires: ninja
24BuildRequires: rpmbuild(macros) >= 1.164
25BuildRequires: tar >= 1:1.22
26BuildRequires: xz
27Requires: kf5-dirs
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define qt5dir %{_libdir}/qt5
31
32%description
33KPlotWidget is a QWidget-derived class that provides a virtual base
34class for easy data-plotting. The idea behind KPlotWidget is that you
35only have to specify information in "data units"; i.e., the natural
36units of the data being plotted. KPlotWidget automatically converts
37everything to screen pixel units.
38
39KPlotWidget draws X and Y axes with tick marks and tick labels. It
40automatically determines how many tick marks to use and where they
41should be, based on the data limits specified for the plot. You change
42the limits by calling `setLimits(double x1, double x2, double y1,
43double y2)`.
44
45Data to be plotted are stored using the KPlotObject class. KPlotObject
46consists of a QList of QPointF's, each specifying the X,Y coordinates
47of a data point. KPlotObject also specifies the "type" of data to be
48plotted (POINTS or CURVE or POLYGON or LABEL).
49
50%package devel
51Summary: Header files for %{kfname} development
52Summary(pl.UTF-8): Pliki nagłówkowe dla programistów używających %{kfname}
53Group: X11/Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57Header files for %{kfname} development.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe dla programistów używających %{kfname}.
61
62%prep
63%setup -q -n %{kfname}-%{version}
64
65%build
66%cmake -B build \
67 -G Ninja \
68 %{!?with_tests:-DBUILD_TESTING=OFF} \
69 -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
70
71%ninja_build -C build
72
73%if %{with tests}
74%ninja_build -C build test
75%endif
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%ninja_install -C build
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%post -p /sbin/ldconfig
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(644,root,root,755)
90%doc README.md
91%ghost %{_libdir}/libKF5Plotting.so.5
92%attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
93%attr(755,root,root) %{qt5dir}/plugins/designer/kplotting5widgets.so
94
95%files devel
96%defattr(644,root,root,755)
97%{_includedir}/KF5/KPlotting
98%{_libdir}/cmake/KF5Plotting
99%{_libdir}/libKF5Plotting.so
100%{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.535842 seconds and 4 git commands to generate.