]> git.pld-linux.org Git - packages/guichan.git/blame_incremental - guichan.spec
- enable allegro by default (now it works)
[packages/guichan.git] / guichan.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without allegro # without allegro support
4#
5Summary: Guichan - small, efficient C++ GUI library designed for games
6Summary(pl.UTF-8): Guichan - mała, wydajna biblioteka GUI w C++ przeznaczona do gier
7Name: guichan
8Version: 0.8.1
9Release: 1
10License: BSD
11Group: Libraries
12Source0: http://guichan.googlecode.com/files/%{name}-%{version}.tar.gz
13# Source0-md5: f9ace11cc70d3ba60b62347172334a5f
14URL: http://guichan.sourceforge.net/
15BuildRequires: OpenGL-devel
16BuildRequires: SDL-devel
17BuildRequires: SDL_image-devel
18%{?with_allegro:BuildRequires: allegro-devel}
19BuildRequires: autoconf
20BuildRequires: automake
21BuildRequires: libstdc++-devel
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Guichan is a small, efficient C++ GUI library designed for games. It
26comes with a standard set of widgets and can use several different
27objects for displaying graphics and grabbing user input.
28
29%description -l pl.UTF-8
30Guichan to mała, wydajna biblioteka GUI w C++ przeznaczona do gier.
31Zawiera standardowy zestaw widgetów, może używać kilku różnych
32obiektów do wyświetlania grafiki i pobierania wejścia od użytkownika.
33
34%package devel
35Summary: Header files for Guichan library
36Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Guichan
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: libstdc++-devel
40
41%description devel
42Header files for Guichan library.
43
44%description devel -l pl.UTF-8
45Pliki nagłówkowe biblioteki Guichan.
46
47%package static
48Summary: Static version of Guichan libraries
49Summary(pl.UTF-8): Statyczne wersje bibliotek Guichan
50Group: Development/Libraries
51Requires: %{name}-devel = %{version}-%{release}
52
53%description static
54Static version of Guichan libraries.
55
56%description static -l pl.UTF-8
57Statyczne wersje bibliotek Guichan.
58
59%prep
60%setup -q
61
62%build
63%{__aclocal}
64%{__autoconf}
65%{__autoheader}
66%{__automake}
67%configure \
68 %{!?with_allegro:--disable-allegro}
69%{__make} \
70 CFLAGS="%{rpmcflags}"
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75%{__make} install \
76 DESTDIR=$RPM_BUILD_ROOT
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82%postun -p /sbin/ldconfig
83
84%files
85%defattr(644,root,root,755)
86%doc AUTHORS COPYING ChangeLog NEWS README TODO
87%attr(755,root,root) %{_libdir}/libguichan*.so.*.*.*
88%attr(755,root,root) %ghost %{_libdir}/libguichan*.so.1
89
90%files devel
91%defattr(644,root,root,755)
92%attr(755,root,root) %{_libdir}/libguichan*.so
93%{_libdir}/libguichan*.la
94%{_includedir}/guichan*
95
96%files static
97%defattr(644,root,root,755)
98%{_libdir}/libguichan*.a
This page took 0.053811 seconds and 4 git commands to generate.