]> git.pld-linux.org Git - packages/glibc.git/blame_incremental - glibc.spec
- release .2.1 (.2 is on AC-branch)
[packages/glibc.git] / glibc.spec
... / ...
CommitLineData
1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
4#
5# Conditional build:
6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
9 # linux-libc-headers (evil, breakage etc., don't use)
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
12%bcond_without tls # don't support TLS at all (implies no NPTL)
13%bcond_with __thread # use TLS in linuxthreads
14%bcond_without selinux # without SELinux support (in nscd)
15%bcond_with tests # perform "make test"
16%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
17%bcond_without localedb # don't build localedb-all (is time consuming)
18
19%bcond_without comdat # without (unfinished) comdat hacks [for Ac]
20
21#
22# TODO:
23# - localedb-gen man pages(?)
24# - fix what trojan broke while upgreading (getaddrinfo-workaround)
25# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
26# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
27# - problem compiling with --enable-bounded (must be reported to libc-alpha)
28# (is this comment still valid???)
29#
30
31%{!?min_kernel:%global min_kernel 2.4.6}
32%if "%{min_kernel}" < "2.6.0"
33%global nptl_min_kernel 2.6.0
34%else
35%global nptl_min_kernel %{min_kernel}
36%endif
37
38%if %{with tls}
39# sparc temporarily removed (broken)
40%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
41%undefine with_tls
42%endif
43%endif
44
45%if %{with nptl}
46# nptl on x86 uses cmpxchgl (available since i486)
47%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparc64 sparcv9 ppc ppc64
48%undefine with_nptl
49%else
50%if %{without tls}
51%undefine with_nptl
52%endif
53%endif
54%endif
55
56%ifarch sparc64
57%undefine with_memusage
58%endif
59
60%if %{with linuxthreads} && %{with nptl}
61%define with_dual 1
62%endif
63
64%define llh_version 7:2.6.6.0
65%define _snap 20041122
66
67Summary: GNU libc
68Summary(de): GNU libc
69Summary(es): GNU libc
70Summary(fr): GNU libc
71