]> git.pld-linux.org Git - packages/feathercoin.git/blame_incremental - feathercoin.spec
- updated to 0.19.1
[packages/feathercoin.git] / feathercoin.spec
... / ...
CommitLineData
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
9Name: feathercoin
10Version: 0.19.1
11Release: 1
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
16# Source0-md5: 5af573e26b1fc7cb57ef5efc5dd88801
17Patch0: lib.patch
18Patch1: qt-5.15.patch
19Patch2: %{name}-includes.patch
20Patch3: %{name}-univalue.patch
21URL: https://www.feathercoin.com/
22%if %{with gui}
23BuildRequires: Qt5Core-devel >= 5
24BuildRequires: Qt5DBus-devel >= 5
25BuildRequires: Qt5Gui-devel >= 5
26BuildRequires: Qt5Network-devel >= 5
27BuildRequires: Qt5PrintSupport-devel >= 5
28BuildRequires: Qt5Test-devel >= 5
29BuildRequires: Qt5Widgets-devel >= 5
30%endif
31BuildRequires: autoconf >= 2.69
32BuildRequires: automake
33BuildRequires: boost-devel >= 1.47.0
34%{?with_ccache:BuildRequires: ccache}
35BuildRequires: db-cxx-devel >= 4.8
36BuildRequires: gettext-tools
37BuildRequires: libevent-devel
38%{?with_gui:BuildRequires: libpng-devel}
39BuildRequires: libsecp256k1-devel >= 0.1.0.15
40BuildRequires: libstdc++-devel >= 6:4.7
41BuildRequires: libtool >= 2:2
42BuildRequires: libunivalue-devel >= 1.0.4
43BuildRequires: miniupnpc-devel >= 1.5
44BuildRequires: openssl-devel
45BuildRequires: pkgconfig
46BuildRequires: protobuf-devel
47BuildRequires: python3 >= 1:3.5
48BuildRequires: qrencode-devel
49%{?with_gui:BuildRequires: qt5-build >= 5}
50BuildRequires: zeromq-devel >= 4
51%{?with_gui:BuildRequires: zlib-devel}
52BuildRequires: zxing-cpp-devel
53Requires: libsecp256k1 >= 0.1.0.15
54Requires: libunivalue >= 1.0.4
55Requires: perl-base
56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58# uses nNeoScryptOptions symbol from binaries
59%define skip_post_check_so libbitcoinconsensus.so.*
60
61%description
62Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
63central authority issues new money or tracks transactions. These tasks
64are managed collectively by the network.
65
66%description -l pl.UTF-8
67Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
68centralnego urzędu, który emituje nowe pieniądze czy śledzi
69transakcje. Zadania te są obsługiwane zespołowo przez sieć.
70
71%package devel
72Summary: Header file for bitcoinconsensus library
73Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76Requires: openssl-devel
77Conflicts: bitcoin-devel
78
79%description devel
80Header file for bitcoinconsensus library.
81
82%description devel -l pl.UTF-8
83Plik nagłówkowy biblioteki bitcoinconsensus.
84
85%package static
86Summary: Static bitcoinconsensus library
87Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
88Group: Development/Libraries
89Requires: %{name}-devel = %{version}-%{release}
90Conflicts: bitcoin-static
91
92%description static
93Static bitcoinconsensus library.
94
95%description static -l pl.UTF-8
96Statyczna biblioteka bitcoinconsensus.
97
98%package qt
99Summary: Qt-based Feathercoin Wallet
100Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
101Group: X11/Applications
102
103%description qt
104Qt-based Feathercoin Wallet.
105
106%description qt -l pl.UTF-8
107Oparty na Qt portfel Feathercoin.
108
109%prep
110%setup -q -n Feathercoin-%{version}
111%patch0 -p1
112%patch1 -p1
113%patch2 -p1
114%patch3 -p1
115
116%build
117%{__libtoolize}
118%{__aclocal}
119%{__autoconf}
120%{__autoheader}
121%{__automake}
122# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
123%configure \
124 --disable-bench \
125 --enable-bip70 \
126 --enable-ccache%{!?with_ccache:=no} \
127 --disable-gui-tests \
128 --disable-silent-rules \
129 --disable-tests \
130 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
131 --with-incompatible-bdb \
132 --with-system-univalue
133
134%{__make}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138
139%{__make} install \
140 DESTDIR=$RPM_BUILD_ROOT
141
142# obsoleted by pkg-config
143%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
144
145install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
146cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
147[Desktop Entry]
148Encoding=UTF-8
149Name=Feathercoin
150Comment=Feathercoin P2P Cryptocurrency
151Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
152Comment[pl]=Feathercoin - kryptowaluta P2P
153Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
154Exec=feathercoin-qt %u
155Terminal=false
156Type=Application
157Icon=bitcoin128
158MimeType=x-scheme-handler/feathercoin;
159Categories=Office;Finance;
160EOF
161
162cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
163[Protocol]
164exec=feathercoin-qt '%u'
165protocol=feathercoin
166input=none
167output=none
168helper=true
169listing=
170reading=false
171writing=false
172makedir=false
173deleting=false
174EOF
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%post -p /sbin/ldconfig
180%postun -p /sbin/ldconfig
181
182%files
183%defattr(644,root,root,755)
184%doc COPYING README.md doc/*.txt
185%attr(755,root,root) %{_bindir}/feathercoin-cli
186%attr(755,root,root) %{_bindir}/feathercoin-tx
187%attr(755,root,root) %{_bindir}/feathercoin-wallet
188%attr(755,root,root) %{_bindir}/feathercoind
189%{_mandir}/man1/feathercoin-cli.1*
190%{_mandir}/man1/feathercoin-tx.1*
191%{_mandir}/man1/feathercoin-wallet.1*
192%{_mandir}/man1/feathercoind.1*
193%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
194%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
195
196%files devel
197%defattr(644,root,root,755)
198%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
199%{_includedir}/bitcoinconsensus.h
200%{_pkgconfigdir}/libbitcoinconsensus.pc
201
202%files static
203%defattr(644,root,root,755)
204%{_libdir}/libbitcoinconsensus.a
205
206%files qt
207%defattr(644,root,root,755)
208%attr(755,root,root) %{_bindir}/feathercoin-qt
209%{_datadir}/kde4/services/feathercoin-qt.protocol
210%{_desktopdir}/feathercoin-qt.desktop
211%{_mandir}/man1/feathercoin-qt.1*
This page took 0.054668 seconds and 4 git commands to generate.