]> git.pld-linux.org Git - packages/edje.git/blame_incremental - edje.spec
- updated to 1.7.5
[packages/edje.git] / edje.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4%bcond_with remix # remix support (not used now as multisense is disabled)
5#
6%define ecore_ver 1.7.5
7%define eet_ver 1.7.5
8%define eina_ver 1.7.5
9%define eio_ver 1.7.5
10%define embryo_ver 1.7.5
11%define evas_ver 1.7.5
12Summary: Complex Graphical Design/Layout Engine
13Summary(pl.UTF-8): Złożony silnik graficznego projektowania/planowania
14Name: edje
15Version: 1.7.5
16Release: 1
17License: BSD
18Group: X11/Libraries
19Source0: http://download.enlightenment.org/releases/%{name}-%{version}.tar.bz2
20# Source0-md5: 56d7ba080088627773bc6369e9a924fe
21Patch0: %{name}-deps.patch
22URL: http://trac.enlightenment.org/e/wiki/Edje
23# for alsa_snd_player plugin for remix
24%{?with_remix:BuildRequires: alsa-lib-devel >= 1.0.21}
25BuildRequires: autoconf >= 2.52
26BuildRequires: automake >= 1.6
27BuildRequires: ecore-devel >= %{ecore_ver}
28BuildRequires: ecore-evas-devel >= %{ecore_ver}
29BuildRequires: ecore-file-devel >= %{ecore_ver}
30BuildRequires: ecore-imf-devel >= %{ecore_ver}
31BuildRequires: ecore-imf-evas-devel >= %{ecore_ver}
32BuildRequires: eina-devel >= %{eina_ver}
33BuildRequires: eio-devel >= %{eio_ver}
34BuildRequires: eet-devel >= %{eet_ver}
35BuildRequires: embryo-devel >= %{embryo_ver}
36BuildRequires: evas-devel >= %{evas_ver}
37BuildRequires: flac-devel >= 1.2.1
38BuildRequires: libogg-devel >= 1:1.1.4
39BuildRequires: libsndfile-devel >= 1.0.21
40BuildRequires: libvorbis-devel >= 1:1.2.3
41BuildRequires: libtool
42BuildRequires: lua51 >= 5.1.0
43BuildRequires: pkgconfig >= 1:0.22
44BuildRequires: python >= 1:2.5
45%{?with_remix:BuildRequires: remix-devel >= 0.2.4}
46%{?with_remix:Requires: alsa-lib >= 1.0.21}
47Requires: %{name}-libs = %{version}-%{release}
48Requires: evas-engine-buffer >= %{evas_ver}
49Requires: evas-loader-png >= %{evas_ver}
50Requires: flac >= 1.2.1
51Requires: libogg >= 1:1.1.4
52Requires: libvorbis >= 1:1.2.3
53BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55%undefine __cxx
56%define specflags_x86_64 -mfpmath=387
57%define specflags_amd64 -mfpmath=387
58
59%description
60Edje is a complex graphical design and layout engine. It provides a
61mechanism for allowing configuration data to define visual elements in
62terms of layout, behavior, and appearance. Edje allows for multiple
63collections of layouts in one file, allowing a complete set of images,
64animations, and controls to exist as a unified whole.
65
66Edje separates the arrangement, appearance, and behavior logic into
67distinct independent entities. This allows visual objects to share
68image data and configuration information without requiring them to do
69so. This separation and simplistic event driven style of programming
70can produce almost any look and feel one could want for basic visual
71elements. Anything more complex is likely the domain of an application
72or widget set that may use Edje as a convenient way of being able to
73configure parts of the display.
74
75%description -l pl.UTF-8
76Edje to złożony silnik graficznego projektowania i planowania.
77Dostarcza mechanizm pozwalający na definiowanie elementów graficznych
78za pomocą danych konfiguracyjnych poprzez rozmieszczenie, zachowanie i
79wygląd. Edje pozwala na wiele kolekcji projektów w jednym pliku,
80zezwalając na istnienie pełnego zbioru obrazów, animacji i kontrolek
81jako całości.
82
83Edje oddziela rozmieszczenie, wygląd i logikę zachowania na różne,
84niezależne elementy. Pozwala to na współdzielenie danych obrazów i
85informacji o konfiguracji elementów graficznych bez wymagania tego.
86Rozdzielenie to i uproszczony model programowania sterowanego
87zdarzeniami może stworzyć prawie dowolny wygląd i zachowanie
88podstawowych elementów graficznych. Wszystko bardziej złożone jest
89raczej domeną aplikacji lub zbioru widgetów, które mogą używać Edje
90jako wygodnego sposobu konfigurowania części ekranu.
91
92%package libs
93Summary: Edje library
94Summary(pl.UTF-8): Biblioteka edje
95Group: X11/Libraries
96Requires: ecore >= %{ecore_ver}
97Requires: ecore-file >= %{ecore_ver}
98Requires: ecore-imf >= %{ecore_ver}
99Requires: ecore-imf-evas >= %{ecore_ver}
100Requires: eina >= %{eina_ver}
101Requires: eio >= %{eio_ver}
102Requires: eet >= %{eet_ver}
103Requires: embryo >= %{embryo_ver}
104Requires: evas >= %{evas_ver}
105Requires: libsndfile >= 1.0.21
106%{?with_remix:Requires: remix >= 0.2.4}
107
108%description libs
109Edje library.
110
111%description libs -l pl.UTF-8
112Biblioteka edje.
113
114%package devel
115Summary: Edje header files
116Summary(pl.UTF-8): Pliki nagłówkowe Edje
117Group: Development/Libraries
118Requires: %{name}-libs = %{version}-%{release}
119Requires: ecore-devel >= %{ecore_ver}
120Requires: ecore-file-devel >= %{ecore_ver}
121Requires: ecore-imf-devel >= %{ecore_ver}
122Requires: ecore-imf-evas-devel >= %{ecore_ver}
123Requires: eet-devel >= %{eet_ver}
124Requires: eio-devel >= %{eio_ver}
125Requires: embryo-devel >= %{embryo_ver}
126Requires: evas-devel >= %{evas_ver}
127Requires: libsndfile-devel >= 1.0.21
128%{?with_remix:Requires: remix-devel >= 0.2.4}
129
130%description devel
131Header files for Edje.
132
133%description devel -l pl.UTF-8
134Pliki nagłówkowe Edje.
135
136%package static
137Summary: Static Edje library
138Summary(pl.UTF-8): Statyczna biblioteka Edje
139Group: Development/Libraries
140Requires: %{name}-devel = %{version}-%{release}
141
142%description static
143Static Edje library.
144
145%description static -l pl.UTF-8
146Statyczna biblioteka Edje.
147
148%package -n vim-syntax-edc
149Summary: EDC syntax support for Vim
150Summary(pl.UTF-8): Obsługa składni EDC dla Vima
151Group: Applications/Editors/Vim
152Requires: vim-rt
153
154%description -n vim-syntax-edc
155EDC syntax support for Vim.
156
157%description -n vim-syntax-edc -l pl.UTF-8
158Obsługa składni EDC dla Vima.
159
160%prep
161%setup -q
162%patch0 -p1
163
164%build
165%{__libtoolize}
166%{__aclocal} -I m4
167%{__autoconf}
168%{__autoheader}
169%{__automake}
170%configure \
171 --disable-silent-rules \
172 %{!?with_remix:--disable-remix} \
173 %{!?with_static_libs:--disable-static} \
174 --enable-edje-cc \
175 --with-vim=/usr/share/vim/vimfiles
176%{__make}
177
178%install
179rm -rf $RPM_BUILD_ROOT
180
181%{__make} install \
182 DESTDIR=$RPM_BUILD_ROOT
183
184install -d $RPM_BUILD_ROOT%{_libdir}/edje/modules
185install -D data/edc.vim $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/edc.vim
186
187%if %{with remix}
188%{__rm} $RPM_BUILD_ROOT%{_libdir}/remix/*.la
189%endif
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post libs -p /sbin/ldconfig
195%postun libs -p /sbin/ldconfig
196
197%files
198%defattr(644,root,root,755)
199%doc AUTHORS COPYING ChangeLog NEWS README
200%attr(755,root,root) %{_bindir}/edje_cc
201%attr(755,root,root) %{_bindir}/edje_decc
202%attr(755,root,root) %{_bindir}/edje_external_inspector
203%attr(755,root,root) %{_bindir}/edje_inspector
204%attr(755,root,root) %{_bindir}/edje_player
205%attr(755,root,root) %{_bindir}/edje_recc
206%attr(755,root,root) %{_bindir}/edje_watch
207%attr(755,root,root) %{_bindir}/inkscape2edc
208%dir %{_libdir}/%{name}/utils
209%attr(755,root,root) %dir %{_libdir}/%{name}/utils/epp
210%{_datadir}/%{name}
211%{_datadir}/mime/packages/edje.xml
212
213%files libs
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libedje.so.*.*.*
216%attr(755,root,root) %ghost %{_libdir}/libedje.so.1
217%dir %{_libdir}/%{name}
218%dir %{_libdir}/%{name}/modules
219%if %{with remix}
220%attr(755,root,root) %{_libdir}/remix/libalsa_snd_player.so
221%attr(755,root,root) %{_libdir}/remix/libeet_sndfile_reader.so
222%endif
223
224%files devel
225%defattr(644,root,root,755)
226%attr(755,root,root) %{_libdir}/libedje.so
227%{_libdir}/libedje.la
228%{_includedir}/edje-1
229%{_pkgconfigdir}/edje.pc
230
231%if %{with static_libs}
232%files static
233%defattr(644,root,root,755)
234%{_libdir}/libedje.a
235%endif
236
237%files -n vim-syntax-edc
238%defattr(644,root,root,755)
239%{_datadir}/vim/vimfiles/syntax/edc.vim
This page took 0.047708 seconds and 4 git commands to generate.