]> git.pld-linux.org Git - packages/curl.git/blame_incremental - curl.spec
- up to 7.45.0
[packages/curl.git] / curl.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ssh # SSH support
4%bcond_without ssl # SSL support
5%bcond_with gnutls # GnuTLS instead of OpenSSL
6%bcond_without kerberos5 # Heimdal Kerberos 5 support
7%bcond_without ldap # LDAP support
8%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
9%bcond_without metalink # metalink support
10%if "%{pld_release}" != "ac"
11%bcond_without ares # c-ares (asynchronous DNS operations) library support
12%bcond_without rtmp # Real Time Media Protocol support
13%else
14%bcond_with ares # c-ares (asynchronous DNS operations) library support
15%bcond_with rtmp # Real Time Media Protocol support
16%endif
17
18Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
19Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
23Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
24Name: curl
25Version: 7.45.0
26Release: 1
27License: MIT-like
28Group: Applications/Networking
29Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
30# Source0-md5: c9a0a77f71fdc6b0f925bc3e79eb77f6
31Patch0: %{name}-ac.patch
32Patch1: %{name}-krb5flags.patch
33URL: http://curl.haxx.se/
34BuildRequires: autoconf >= 2.57
35BuildRequires: automake
36%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
37%{?with_kerberos5:BuildRequires: heimdal-devel}
38BuildRequires: libidn-devel >= 0.4.1
39%{?with_metalink:BuildRequires: libmetalink-devel}
40%{?with_rtmp:BuildRequires: librtmp-devel}
41%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
42BuildRequires: libtool
43BuildRequires: nettle-devel
44%{?with_http2:BuildRequires: nghttp2-devel >= 1.0}
45%{?with_ldap:BuildRequires: openldap-devel}
46BuildRequires: pkgconfig
47BuildRequires: rpm >= 4.4.9-56
48BuildRequires: rpmbuild(macros) >= 1.527
49%if %{with ssl}
50%if %{with gnutls}
51BuildRequires: gnutls-devel
52%else
53BuildRequires: openssl-devel >= 1.0.1
54%endif
55%endif
56BuildRequires: tar >= 1:1.22
57BuildRequires: zlib-devel
58Requires: %{name}-libs = %{version}-%{release}
59Requires: libidn >= 0.4.1
60Obsoletes: libcurl2
61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63%description
64cURL is a tool for getting files with URL syntax, supporting FTP,
65HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
66POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
67cookies, user+password authentication and a busload of other useful
68tricks. The main use for curl is when you want to get or send files
69automatically to or from a site using one of the supported protocols.
70
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. cURL is designed
73to work without user interaction or any kind of interactivity. cURL
74offers many useful capabilities, like proxy support, user
75authentication, FTP upload, HTTP post, and file transfer resume.
76
77%description -l pl.UTF-8
78cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
79HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
80HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
81oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
82użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
83się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
84pliki z/na serwer używając jednego z dostępnych protokołów.
85%{?with_ssl:Ten pakiet obsługuje także SSL.}
86
87%description -l pt_BR.UTF-8
88Curl é um cliente para baixar/enviar arquivos de/para servidores
89usando um dos protocolos suportados. É projetado para funcionar sem a
90interação do usuário.
91
92Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
93continuar transferências interrompidas, e mais...
94
95%description -l ru.UTF-8
96curl - это клиент с множеством поддерживаемых протоколов для получения
97файлов с серверов, спроектированный для работы как в неинтерактивном
98режиме, так и с возможностью диалога с пользователем.
99
100curl поддерживает много полезных возможностей, среди которых поддержка
101прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
102POST, восстановление прерванной пересылки и многое другое.
103
104curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
105файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
106режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
107
108curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
109прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
110в╕дновлення перервано╖ пересилки та багато ╕ншого.
111
112%package libs
113Summary: curl library
114Summary(pl.UTF-8): Biblioteka curl
115Group: Libraries
116%{?with_ares:Requires: c-ares >= 1.7.0}
117%{?with_ssh:Requires: libssh2 >= 1.2.8}
118%{?with_http2:Requires: nghttp2 >= 1.0}
119%if %{with ssl} && %{without gnutls}
120Requires: openssl >= 1.0.1
121%endif
122Suggests: ca-certificates
123Conflicts: ca-certificates < 20080809-4
124
125%description libs
126curl library.
127
128%description libs -l pl.UTF-8
129Biblioteka curl.
130
131%package devel
132Summary: Header files and development documentation for curl library
133Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
134Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
135Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
136Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
137Group: Development/Libraries
138Requires: %{name}-libs = %{version}-%{release}
139%{?with_ares:Requires: c-ares-devel}
140%{?with_kerberos5:Requires: heimdal-devel}
141Requires: libidn-devel >= 0.4.1
142%{?with_rtmp:Requires: librtmp-devel}
143%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
144%{?with_http2:Requires: nghttp2-devel >= 1.0}
145%{?with_ldap:Requires: openldap-devel}
146%if %{with ssl}
147%if %{with gnutls}
148Requires: gnutls-devel
149%else
150Requires: openssl-devel >= 0.9.7c
151%endif
152%endif
153Requires: zlib-devel
154Obsoletes: libcurl2-devel
155
156%description devel
157Header files and development documentation for curl library.
158
159%description devel -l pl.UTF-8
160Pliki nagłówkowe i dokumentacja do biblioteki curl.
161
162%description devel -l pt_BR.UTF-8
163Arquivos de cabeçalho e bibliotecas de desenvolvimento.
164
165%description devel -l ru.UTF-8
166Этот пакет содержит файлы, необходимые для разработки программ с
167использованием библиотеки curl.
168
169%description devel -l uk.UTF-8
170Цей пакет містить файли, необхідні для розробки програм з
171використанням бібліотеки curl.
172
173%package static
174Summary: Static version of curl library
175Summary(pl.UTF-8): Statyczna wersja biblioteki curl
176Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
177Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
178Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
179Group: Development/Libraries
180Requires: %{name}-devel = %{version}-%{release}
181
182%description static
183Static version of curl library.
184
185%description static -l pl.UTF-8
186Statyczna wersja biblioteki curl.
187
188%description static -l pt_BR.UTF-8
189Bibliotecas estáticas para desenvolvimento com o curl.
190
191%description static -l ru.UTF-8
192Этот пакет содержит статическую библиотеку для разработки программ с
193использованием библиотеки curl.
194
195%description static -l uk.UTF-8
196Цей пакет містить статичну бібліотеку для розробки програм з
197використанням бібліотеки curl.
198
199%prep
200%setup -q
201%patch0 -p1
202%patch1 -p1
203
204%{__rm} m4/lt*.m4 m4/libtool.m4
205
206%build
207%{__libtoolize}
208%{__aclocal} -I m4
209%{__autoconf}
210%{__autoheader}
211%{__automake}
212%configure \
213 ac_cv_header_gss_h=no \
214%if %{with ssl}
215 --with-ca-bundle=/etc/certs/ca-certificates.crt \
216%if %{with gnutls}
217 --with-gnutls --without-ssl \
218%else
219 --with-ssl=%{_prefix} \
220%endif
221%endif
222 %{__with_without kerberos5 gssapi %{_prefix}} \
223 %{__with_without metalink libmetalink} \
224 %{__with_without rtmp librtmp} \
225 %{__with_without http2 nghttp2} \
226 %{__enable_disable ares} \
227 %{__with_without ssh libssh2} \
228 --enable-ipv6 \
229 %{__enable_disable ldap} \
230 %{__enable_disable ldap ldaps}
231
232%{__make}
233
234%install
235rm -rf $RPM_BUILD_ROOT
236%{__make} install \
237 DESTDIR=$RPM_BUILD_ROOT
238
239# no longer in upstream but a lot of apps tries to include it so we create fake one
240[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
241echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
242
243%clean
244rm -rf $RPM_BUILD_ROOT
245
246%post libs -p /sbin/ldconfig
247%postun libs -p /sbin/ldconfig
248
249%files
250%defattr(644,root,root,755)
251%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
252%attr(755,root,root) %{_bindir}/curl
253%{_mandir}/man1/curl.1*
254
255%files libs
256%defattr(644,root,root,755)
257%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
258%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
259
260%files devel
261%defattr(644,root,root,755)
262%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
263%attr(755,root,root) %{_bindir}/curl-config
264%attr(755,root,root) %{_libdir}/libcurl.so
265%{_libdir}/libcurl.la
266%{_includedir}/curl
267%{_pkgconfigdir}/libcurl.pc
268%{_aclocaldir}/libcurl.m4
269%{_mandir}/man1/curl-config.1*
270%{_mandir}/man3/curl_*.3*
271%{_mandir}/man3/libcurl*.3*
272%{_mandir}/man3/CURLINFO_*.3*
273%{_mandir}/man3/CURLOPT_*.3*
274%{_mandir}/man3/CURLMOPT_*.3*
275
276%files static
277%defattr(644,root,root,755)
278%{_libdir}/libcurl.a
This page took 0.026951 seconds and 4 git commands to generate.