]> git.pld-linux.org Git - packages/corosync.git/blame_incremental - corosync.spec
package: %{_datadir}/%{name}/corosync{,notifyd}
[packages/corosync.git] / corosync.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # build apidocs (some man3 pages are provided anyway)
4%bcond_without dbus # DBus events
5%bcond_without rdma # RDMA support
6%bcond_without snmp # SNMP protocol support
7%bcond_without testagents
8%bcond_without watchdog
9%bcond_without monitoring
10%bcond_without xmlconf
11#
12Summary: Corosync - OSI Certified implementation of a complete cluster engine
13Summary(pl.UTF-8): Corosync - implementacja silnika klastrowego certyfikowana przez OSI
14Name: corosync
15Version: 2.1.0
16Release: 1
17License: BSD
18Group: Base
19Source0: https://github.com/downloads/corosync/corosync/corosync-2.1.0.tar.gz
20# Source0-md5: dc5152e6dfdb4638ab544e587884483a
21Source1: %{name}.init
22Source2: %{name}-notifyd.init
23Source3: %{name}-notifyd.sysconfig
24Patch0: %{name}-lib_deps.patch
25Patch1: %{name}-install.patch
26URL: http://www.corosync.org/
27BuildRequires: autoconf >= 2.61
28BuildRequires: automake
29%{?with_dbus:BuildRequires: dbus-devel}
30%{?with_apidocs:BuildRequires: doxygen}
31BuildRequires: libqb-devel
32%{?with_monitoring:BuildRequires: libstatgrab-devel}
33%if %{with rdma}
34BuildRequires: libibverbs-devel
35BuildRequires: libtool
36BuildRequires: librdmacm-devel
37%endif
38%{?with_xmlconf:BuildRequires: libxslt}
39%{?with_snmp:BuildRequires: net-snmp-devel}
40BuildRequires: nss-devel
41BuildRequires: pkgconfig
42Requires: %{name}-libs = %{version}-%{release}
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45# short_service_name_get() is defined in executable
46%define skip_post_check_so libcoroipcs\.so.*
47
48%description
49The Corosync Cluster Engine is an OSI Certified implementation of a
50complete cluster engine.
51
52%description -l pl.UTF-8
53Corosync Cluster Engine to implementacja pełnego silnika klastrowego
54certyfikowana przez OSI.
55
56%package libs
57Summary: Corosync Cluster Engine libraries
58Summary(pl.UTF-8): Biblioteki silnika klastrowego Corosync
59Group: Libraries
60
61%description libs
62This package contains the libraries of Corosync Cluster Engine, an OSI
63Certified implementation of a complete cluster engine.
64
65%description libs -l pl.UTF-8
66Ten pakiet zawiera biblioteki Corosync Cluster Engine - pełnego
67silnika klastrowego certyfikowanego przez OSI.
68
69%package devel
70Summary: Header files for Corosync libraries
71Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Corosync
72Group: Development/Libraries
73Requires: %{name}-libs = %{version}-%{release}
74Conflicts: openais-devel < 1.0
75
76%description devel
77This package contains the include files used to develop using Corosync
78APIs.
79
80%description devel -l pl.UTF-8
81Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów z
82użyciem API Corosync.
83
84%package static
85Summary: Corosync static libraries
86Summary(pl.UTF-8): Statyczne biblioteki Corosync
87Group: Development/Libraries
88Requires: %{name}-devel = %{version}-%{release}
89
90%description static
91This package contains the Corosync static libraries.
92
93%description static -l pl.UTF-8
94Ten pakiet zawiera statyczne biblioteki Corosync.
95
96%package -n mibs-corosync
97Summary: Corosync SNMP MIB data
98Summary(pl.UTF-8): Dane SNMP MIB dla Corosync
99Group: Applications/System
100Requires: mibs-dirs
101
102%description -n mibs-corosync
103Corosync SNMP MIB data.
104
105%description -n mibs-corosync -l pl.UTF-8
106Dane SNMP MIB dla Corosync.
107
108%package -n corosync-testagents
109Summary: The Corosync Cluster Engine Test Agents
110Group: Development/Libraries
111Requires: %{name} = %{version}-%{release}
112
113%description -n corosync-testagents
114This package contains corosync test agents.
115
116%prep
117%setup -q
118%patch0 -p1
119%patch1 -p1
120
121%build
122%{__libtoolize}
123%{__aclocal}
124%{__autoconf}
125%{__autoheader}
126%{__automake}
127%configure \
128 %{?with_testagents:--enable-testagents} \
129 %{?with_watchdog:--enable-watchdog} \
130 %{?with_monitoring:--enable-monitoring} \
131 %{?with_xmlconf:--enable-xmlconf} \
132 %{?with_dbus:--enable-dbus} \
133 %{?with_rdma:--enable-rdma} \
134 %{?with_snmp:--enable-snmp} \
135 --enable-systemd \
136 --with-systemddir=%{systemdunitdir} \
137 --with-initddir=/etc/rc.d/init.d
138
139%{__make}
140
141%{?with_apidocs:%{__make} doxygen}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/sysconfig}
146
147%{__make} install \
148 DESTDIR=$RPM_BUILD_ROOT
149
150%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/corosync
151
152sed -e 's/^/#/' $RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf.example \
153 >$RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf
154%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/corosync/corosync.conf.example*
155
156install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
157install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-notifyd
158install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-notifyd
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%post
164/sbin/chkconfig --add %{name}
165/sbin/chkconfig --add %{name}-notifyd
166%service %{name} restart
167%service %{name}-notifyd restart
168%systemd_post %{name}.service
169%systemd_post %{name}-notifyd.service
170
171%preun
172if [ "$1" = "0" ]; then
173 %service -q %{name} stop
174 /sbin/chkconfig --del %{name}
175 %service -q %{name}-notifyd stop
176 /sbin/chkconfig --del %{name}-notifyd
177fi
178%systemd_preun %{name}.service
179%systemd_preun %{name}-notifyd.service
180
181%postun
182%systemd_reload
183
184%post libs -p /sbin/ldconfig
185%postun libs -p /sbin/ldconfig
186
187%files
188%defattr(644,root,root,755)
189%doc AUTHORS ChangeLog LICENSE README.recovery SECURITY TODO conf/corosync.conf.example*
190%if %{with xmlconf}
191%doc conf/corosync.xml.example*
192%endif
193%attr(754,root,root) /etc/rc.d/init.d/corosync
194%attr(754,root,root) /etc/rc.d/init.d/corosync-notifyd
195%verify(not md5 mtime size) %config(noreplace) /etc/sysconfig/%{name}-notifyd
196%dir %{_sysconfdir}/corosync
197%{systemdunitdir}/corosync.service
198%{systemdunitdir}/corosync-notifyd.service
199%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/corosync/corosync.conf
200%attr(755,root,root) %{_bindir}/corosync-blackbox
201%attr(755,root,root) %{_sbindir}/corosync
202%attr(755,root,root) %{_sbindir}/corosync-cfgtool
203%attr(755,root,root) %{_sbindir}/corosync-cmapctl
204%attr(755,root,root) %{_sbindir}/corosync-cpgtool
205%attr(755,root,root) %{_sbindir}/corosync-keygen
206%attr(755,root,root) %{_sbindir}/corosync-notifyd
207%attr(755,root,root) %{_sbindir}/corosync-quorumtool
208%{_mandir}/man5/corosync.conf.5*
209%{_mandir}/man8/corosync.8*
210%{_mandir}/man8/corosync-blackbox.8*
211%{_mandir}/man8/corosync-cmapctl.8*
212%{_mandir}/man8/corosync-cfgtool.8*
213%{_mandir}/man8/corosync-cpgtool.8*
214%{_mandir}/man8/corosync-keygen.8*
215%{_mandir}/man8/corosync-notifyd.8*
216%{_mandir}/man8/corosync-quorumtool.8*
217%if %{with xmlconf}
218%attr(755,root,root) %{_bindir}/corosync-xmlproc
219%config(noreplace) %{_sysconfdir}/corosync/corosync.xml.example
220%dir %{_datadir}/corosync
221%dir %{_datadir}/corosync/xml2conf.xsl
222%attr(755,root,root) %{_datadir}/%{name}/corosync
223%attr(755,root,root) %{_datadir}/%{name}/corosync-notifyd
224%{_mandir}/man8/corosync-xmlproc.8*
225%{_mandir}/man5/corosync.xml.5*
226%endif
227%if %{with dbus}
228/etc/dbus-1/system.d/corosync-signals.conf
229%endif
230
231%files libs
232%defattr(644,root,root,755)
233%attr(755,root,root) %{_libdir}/libcfg.so.6.*.*
234%attr(755,root,root) %ghost %{_libdir}/libcfg.so.6
235%attr(755,root,root) %{_libdir}/libcmap.so.4.*.*
236%attr(755,root,root) %ghost %{_libdir}/libcmap.so.4
237%attr(755,root,root) %{_libdir}/libcorosync_common.so.4.*.*
238%attr(755,root,root) %ghost %{_libdir}/libcorosync_common.so.4
239%attr(755,root,root) %{_libdir}/libcpg.so.4.*.*
240%attr(755,root,root) %ghost %{_libdir}/libcpg.so.4
241%attr(755,root,root) %{_libdir}/libsam.so.4.*.*
242%attr(755,root,root) %ghost %{_libdir}/libsam.so.4
243%attr(755,root,root) %{_libdir}/libquorum.so.5.*.*
244%attr(755,root,root) %ghost %{_libdir}/libquorum.so.5
245%attr(755,root,root) %{_libdir}/libtotem_pg.so.5.*.*
246%attr(755,root,root) %ghost %{_libdir}/libtotem_pg.so.5
247%attr(755,root,root) %{_libdir}/libvotequorum.so.6.*.*
248%attr(755,root,root) %ghost %{_libdir}/libvotequorum.so.6
249
250%files devel
251%defattr(644,root,root,755)
252%{?with_apidocs:%doc doc/api/html/*}
253%attr(755,root,root) %{_libdir}/libcfg.so
254%attr(755,root,root) %{_libdir}/libcmap.so
255%attr(755,root,root) %{_libdir}/libcorosync_common.so
256%attr(755,root,root) %{_libdir}/libcpg.so
257%attr(755,root,root) %{_libdir}/libsam.so
258%attr(755,root,root) %{_libdir}/libquorum.so
259%attr(755,root,root) %{_libdir}/libtotem_pg.so
260%attr(755,root,root) %{_libdir}/libvotequorum.so
261%{_includedir}/corosync
262%{_pkgconfigdir}/corosync.pc
263%{_pkgconfigdir}/libcfg.pc
264%{_pkgconfigdir}/libcmap.pc
265%{_pkgconfigdir}/libcorosync_common.pc
266%{_pkgconfigdir}/libcpg.pc
267%{_pkgconfigdir}/libquorum.pc
268%{_pkgconfigdir}/libsam.pc
269%{_pkgconfigdir}/libtotem_pg.pc
270%{_pkgconfigdir}/libvotequorum.pc
271%{_mandir}/man3/cmap_*.3*
272%{_mandir}/man3/cpg_*.3*
273%{_mandir}/man3/quorum_*.3*
274%{_mandir}/man3/sam_*.3*
275%{_mandir}/man3/votequorum_*.3*
276%{_mandir}/man5/votequorum.5*
277# should be man7...
278%{_mandir}/man8/cmap_keys.8*
279%{_mandir}/man8/cmap_overview.8*
280%{_mandir}/man8/corosync_overview.8*
281%{_mandir}/man8/cpg_overview.8*
282%{_mandir}/man8/sam_overview.8*
283%{_mandir}/man8/votequorum_overview.8*
284%{_mandir}/man8/quorum_overview.8*
285%files static
286%defattr(644,root,root,755)
287%{_libdir}/libcfg.a
288%{_libdir}/libcmap.a
289%{_libdir}/libcorosync_common.a
290%{_libdir}/libcpg.a
291%{_libdir}/libsam.a
292%{_libdir}/libquorum.a
293%{_libdir}/libtotem_pg.a
294%{_libdir}/libvotequorum.a
295
296%if %{with snmp}
297%files -n mibs-corosync
298%defattr(644,root,root,755)
299%{_datadir}/snmp/mibs/COROSYNC-MIB.txt
300%endif
301
302%if %{with testagents}
303%files -n corosync-testagents
304%defattr(644,root,root,755)
305%{_datadir}/corosync/tests/mem_leak_test.sh
306%{_datadir}/corosync/tests/net_breaker.sh
307%{_datadir}/corosync/tests/cmap-dispatch-deadlock.sh
308%{_datadir}/corosync/tests/shm_leak_audit.sh
309%attr(755,root,root) %{_bindir}/cpg_test_agent
310%attr(755,root,root) %{_bindir}/sam_test_agent
311%attr(755,root,root) %{_bindir}/votequorum_test_agent
312%endif
This page took 0.053313 seconds and 4 git commands to generate.