]> git.pld-linux.org Git - packages/coreutils.git/blame_incremental - coreutils.spec
- cleaned up su-specific patches and pam files
[packages/coreutils.git] / coreutils.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with advcopy # progress bar in cp (orphaned patch)
4%bcond_without tests # do not perform "make test check"
5#
6Summary: GNU Core-utils - basic command line utilities
7Summary(pl.UTF-8): GNU Core-utils - podstawowe narzędzia działające z linii poleceń
8Name: coreutils
9Version: 8.19
10Release: 0.1
11License: GPL v3+
12Group: Applications/System
13Source0: http://ftp.gnu.org/gnu/coreutils/%{name}-%{version}.tar.xz
14# Source0-md5: 1a01231a2f3ed37c0efc073ccdda9375
15Source1: %{name}-non-english-man-pages.tar.bz2
16# Source1-md5: f7c986ebc74ccb8d08ed70141063f14c
17Source2: DIR_COLORS
18Source3: fileutils.sh
19Source4: fileutils.csh
20Source5: mktemp.1.pl
21Patch0: %{name}-info.patch
22Patch1: %{name}-getgid.patch
23Patch2: %{name}-uname-cpuinfo.patch
24Patch3: %{name}-date-man.patch
25Patch4: %{name}-mem.patch
26Patch5: %{name}-7.4-sttytcsadrain.patch
27Patch6: %{name}-fmt-wchars.patch
28Patch7: %{name}-sparc64.patch
29# http://translationproject.org/latest/coreutils/pl.po (pass through msgcat to generate shorter diff)
30Patch8: %{name}-pl.po-update.patch
31# from http://www.beatex.org/web/advancedcopy.html, edited by shadzik
32Patch9: %{name}-advcopy.patch
33URL: http://www.gnu.org/software/coreutils/
34BuildRequires: acl-devel
35BuildRequires: attr-devel
36BuildRequires: autoconf >= 2.64
37BuildRequires: automake >= 1:1.11.1
38BuildRequires: gcc >= 5:3.2
39BuildRequires: gettext-devel >= 0.18.1
40BuildRequires: gmp-devel
41BuildRequires: help2man
42BuildRequires: libcap-devel
43BuildRequires: libselinux-devel
44BuildRequires: rpmbuild(find_lang) >= 1.24
45BuildRequires: tar >= 1:1.22
46BuildRequires: texinfo >= 4.2
47BuildRequires: xz
48%if %{with tests}
49BuildRequires: strace
50%endif
51Requires: setup >= 2.4.6-2
52Provides: fileutils
53Provides: mktemp = %{version}-%{release}
54Provides: sh-utils
55Provides: stat
56Provides: textutils
57Obsoletes: fileutils
58Obsoletes: mktemp
59Obsoletes: sh-utils
60Obsoletes: stat
61Obsoletes: textutils
62Conflicts: shadow < 1:4.0.3-6
63Conflicts: tetex < 1:2.0.2
64# ensure util-linux has su included
65Conflicts: util-linux < 2.22
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68%description
69These are the GNU core utilities. This package is the union of the GNU
70fileutils, sh-utils, and textutils packages.
71
72Most of these programs have significant advantages over their Unix
73counterparts, such as greater speed, additional options, and fewer
74arbitrary limits.
75
76The programs that can be built with this package are:
77
78 [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
79 dd df dir dircolors dirname du echo env expand expr factor false fmt
80 fold install groups head hostid id join link ln logname ls md5sum
81 mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
82 printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
83 stat stty sum sync tac tail tee test touch tr true tsort tty uname
84 unexpand uniq unlink users vdir wc who whoami yes
85
86%description -l pl.UTF-8
87Narzędzia podstawowe (core utilities) GNU to połączone paczki GNU
88fileutils, sh-utils i textutils.
89
90Większość z zawartych programów jest znacznie ulepszona w porównaniu
91z ich uniksowymi odpowiednikami, np. szybciej działają, mają dodatkowe
92opcje i mniej ograniczeń.
93
94Programy zawarte w tym pakiecie to:
95
96 [ basename cat chgrp chmod chown chroot cksum comm cp csplit cut date
97 dd df dir dircolors dirname du echo env expand expr factor false fmt
98 fold ginstall groups head hostid id join link ln logname ls md5sum
99 mkdir mkfifo mknod mv nice nl nohup od paste pathchk pinky pr printenv
100 printf ptx pwd realpath rm rmdir seq sha1sum shred sleep sort split
101 stat stty sum sync tac tail tee test touch tr true tsort tty uname
102 unexpand uniq unlink users vdir wc who whoami yes
103
104%prep
105%setup -q -a1
106%patch8 -p1
107%patch0 -p1
108%patch1 -p1
109%patch2 -p1
110%patch3 -p1
111%patch4 -p1
112%patch5 -p1
113%patch6 -p1
114%ifarch sparc64
115%patch7 -p1
116%endif
117%if %{with advcopy}
118# progress-bar patch, -g,--progress-bar //if in doubt, comment it out
119%patch9 -p1
120%endif
121
122%{__perl} -pi -e 's@GNU/Linux@PLD Linux@' m4/host-os.m4
123
124# allow rebuilding *.gmo
125%{__rm} po/stamp-po
126
127# fails under C locale:
128# LC_ALL=C echo -e "ça\nçb\n"|LC_ALL=C fmt -p 'ç'
129# fmt: memory exhausted
130%{__sed} -i -e 25,27d tests/fmt/base
131
132# /etc/resolv.conf is blocked in pld builders, try some other file
133%{__sed} -i -e 's,/etc/resolv.conf,/etc/hosts,' gnulib-tests/test-read-file.c
134
135# getgid needs to be fixed:
136# getgid: missing operand
137# Try `getgid --help' for more information.
138%{__rm} tests/misc/help-version
139%{__sed} -i -e '/misc\/help-version/d' tests/Makefile.am
140
141# fails on some filesystems (like XFS), where readdir returns d_type=DT_UNKNOWN
142%{__rm} tests/ls/stat-free-color
143%{__sed} -i -e '/ls\/stat-free-color/d' tests/Makefile.am
144
145%build
146%{__gettextize}
147%{__aclocal} -I m4
148%{__autoconf}
149%{__autoheader}
150%{__automake}
151%configure \
152 CFLAGS="%{rpmcflags} -DSYSLOG_SUCCESS -DSYSLOG_FAILURE -DSYSLOG_NON_ROOT" \
153 DEFAULT_POSIX2_VERSION=199209 \
154 --disable-silent-rules \
155 --enable-install-program=arch \
156 --enable-no-install-program=hostname,kill,uptime
157
158%{__make}
159
160%if %{with tests}
161sed -i -e 's#COLUMNS##g' tests/envvar-check
162%{__make} -j1 tests check
163%endif
164
165%install
166rm -rf $RPM_BUILD_ROOT
167install -d $RPM_BUILD_ROOT{/bin,/sbin,%{_bindir},%{_sbindir},/etc/shrc.d}
168
169%{__make} install \
170 DESTDIR=$RPM_BUILD_ROOT
171
172mv -f $RPM_BUILD_ROOT%{_bindir}/{arch,basename,cat,chgrp,chmod,chown,cp,date,dd,\
173df,echo,false,id,link,ln,ls,mkdir,mknod,mktemp,mv,nice,printf,pwd,rm,rmdir,\
174sleep,sort,stat,stty,sync,touch,true,unlink,uname} $RPM_BUILD_ROOT/bin
175
176mv -f $RPM_BUILD_ROOT%{_bindir}/chroot $RPM_BUILD_ROOT%{_sbindir}
177
178cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
179cp -p %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/shrc.d
180
181cp -a man/pt_BR man/pt
182for d in cs da de es fi fr hu id it ja ko nl pl pt ru zh_CN; do
183 install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
184 cp -p man/$d/*.1 $RPM_BUILD_ROOT%{_mandir}/$d/man1
185done
186install %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/pl/man1/mktemp.1
187# unwanted (-f left intentionally - some manuals could have no translations)
188rm -f $RPM_BUILD_ROOT%{_mandir}/*/man1/{hostname,kill,su,uptime}.1
189# always remove, never packaged but sometimes installed
190rm -f $RPM_BUILD_ROOT%{_infodir}/dir
191
192%find_lang %{name}
193
194%clean
195rm -rf $RPM_BUILD_ROOT
196
197%post -p /sbin/postshell
198-/usr/sbin/fix-info-dir -c %{_infodir}
199
200%postun -p /sbin/postshell
201-/usr/sbin/fix-info-dir -c %{_infodir}
202
203%files -f %{name}.lang
204%defattr(644,root,root,755)
205%doc AUTHORS ChangeLog NEWS README THANKS THANKS-to-translators TODO
206%attr(755,root,root) /bin/arch
207%attr(755,root,root) /bin/basename
208%attr(755,root,root) /bin/cat
209%attr(755,root,root) /bin/chgrp
210%attr(755,root,root) /bin/chmod
211%attr(755,root,root) /bin/chown
212%attr(755,root,root) /bin/cp
213%attr(755,root,root) /bin/date
214%attr(755,root,root) /bin/dd
215%attr(755,root,root) /bin/df
216%attr(755,root,root) /bin/echo
217%attr(755,root,root) /bin/false
218%attr(755,root,root) /bin/id
219%attr(755,root,root) /bin/link
220%attr(755,root,root) /bin/ln
221%attr(755,root,root) /bin/ls
222%attr(755,root,root) /bin/mkdir
223%attr(755,root,root) /bin/mknod
224%attr(755,root,root) /bin/mktemp
225%attr(755,root,root) /bin/mv
226%attr(755,root,root) /bin/nice
227%attr(755,root,root) /bin/printf
228%attr(755,root,root) /bin/pwd
229%attr(755,root,root) /bin/rm
230%attr(755,root,root) /bin/rmdir
231%attr(755,root,root) /bin/sleep
232%attr(755,root,root) /bin/sort
233%attr(755,root,root) /bin/stat
234%attr(755,root,root) /bin/stty
235%attr(755,root,root) /bin/sync
236%attr(755,root,root) /bin/touch
237%attr(755,root,root) /bin/true
238%attr(755,root,root) /bin/uname
239%attr(755,root,root) /bin/unlink
240%attr(755,root,root) %{_bindir}/[
241%attr(755,root,root) %{_bindir}/base64
242%attr(755,root,root) %{_bindir}/chcon
243%attr(755,root,root) %{_bindir}/cksum
244%attr(755,root,root) %{_bindir}/comm
245%attr(755,root,root) %{_bindir}/csplit
246%attr(755,root,root) %{_bindir}/cut
247%attr(755,root,root) %{_bindir}/dir
248%attr(755,root,root) %{_bindir}/dircolors
249%attr(755,root,root) %{_bindir}/dirname
250%attr(755,root,root) %{_bindir}/du
251%attr(755,root,root) %{_bindir}/env
252%attr(755,root,root) %{_bindir}/expand
253%attr(755,root,root) %{_bindir}/expr
254%attr(755,root,root) %{_bindir}/factor
255%attr(755,root,root) %{_bindir}/fmt
256%attr(755,root,root) %{_bindir}/fold
257%attr(755,root,root) %{_bindir}/getgid
258%attr(755,root,root) %{_bindir}/groups
259%attr(755,root,root) %{_bindir}/head
260%attr(755,root,root) %{_bindir}/hostid
261%attr(755,root,root) %{_bindir}/install
262%attr(755,root,root) %{_bindir}/join
263%attr(755,root,root) %{_bindir}/logname
264%attr(755,root,root) %{_bindir}/md5sum
265%attr(755,root,root) %{_bindir}/mkfifo
266%attr(755,root,root) %{_bindir}/nl
267%attr(755,root,root) %{_bindir}/nohup
268%attr(755,root,root) %{_bindir}/nproc
269%attr(755,root,root) %{_bindir}/od
270%attr(755,root,root) %{_bindir}/paste
271%attr(755,root,root) %{_bindir}/pathchk
272%attr(755,root,root) %{_bindir}/pinky
273%attr(755,root,root) %{_bindir}/pr
274%attr(755,root,root) %{_bindir}/printenv
275%attr(755,root,root) %{_bindir}/ptx
276%attr(755,root,root) %{_bindir}/readlink
277%attr(755,root,root) %{_bindir}/realpath
278%attr(755,root,root) %{_bindir}/runcon
279%attr(755,root,root) %{_bindir}/seq
280%attr(755,root,root) %{_bindir}/sha1sum
281%attr(755,root,root) %{_bindir}/sha224sum
282%attr(755,root,root) %{_bindir}/sha256sum
283%attr(755,root,root) %{_bindir}/sha384sum
284%attr(755,root,root) %{_bindir}/sha512sum
285%attr(755,root,root) %{_bindir}/shred
286%attr(755,root,root) %{_bindir}/shuf
287%attr(755,root,root) %{_bindir}/split
288%attr(755,root,root) %{_bindir}/stdbuf
289%attr(755,root,root) %{_bindir}/sum
290%attr(755,root,root) %{_bindir}/tac
291%attr(755,root,root) %{_bindir}/tail
292%attr(755,root,root) %{_bindir}/tee
293%attr(755,root,root) %{_bindir}/test
294%attr(755,root,root) %{_bindir}/timeout
295%attr(755,root,root) %{_bindir}/tr
296%attr(755,root,root) %{_bindir}/truncate
297%attr(755,root,root) %{_bindir}/tsort
298%attr(755,root,root) %{_bindir}/tty
299%attr(755,root,root) %{_bindir}/unexpand
300%attr(755,root,root) %{_bindir}/uniq
301%attr(755,root,root) %{_bindir}/users
302%attr(755,root,root) %{_bindir}/vdir
303%attr(755,root,root) %{_bindir}/wc
304%attr(755,root,root) %{_bindir}/who
305%attr(755,root,root) %{_bindir}/whoami
306%attr(755,root,root) %{_bindir}/yes
307%attr(755,root,root) %{_sbindir}/chroot
308%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/DIR_COLORS
309%config(noreplace) /etc/shrc.d/fileutils.csh
310%config(noreplace) /etc/shrc.d/fileutils.sh
311%dir %{_libdir}/coreutils
312%attr(755,root,root) %{_libdir}/coreutils/libstdbuf.so
313%{_mandir}/man1/arch.1*
314%{_mandir}/man1/base64.1*
315%{_mandir}/man1/basename.1*
316%{_mandir}/man1/cat.1*
317%{_mandir}/man1/chcon.1*
318%{_mandir}/man1/chgrp.1*
319%{_mandir}/man1/chmod.1*
320%{_mandir}/man1/chown.1*
321%{_mandir}/man1/chroot.1*
322%{_mandir}/man1/cksum.1*
323%{_mandir}/man1/comm.1*
324%{_mandir}/man1/cp.1*
325%{_mandir}/man1/csplit.1*
326%{_mandir}/man1/cut.1*
327%{_mandir}/man1/date.1*
328%{_mandir}/man1/dd.1*
329%{_mandir}/man1/df.1*
330%{_mandir}/man1/dir.1*
331%{_mandir}/man1/dircolors.1*
332%{_mandir}/man1/dirname.1*
333%{_mandir}/man1/du.1*
334%{_mandir}/man1/echo.1*
335%{_mandir}/man1/env.1*
336%{_mandir}/man1/expand.1*
337%{_mandir}/man1/expr.1*
338%{_mandir}/man1/factor.1*
339%{_mandir}/man1/false.1*
340%{_mandir}/man1/fmt.1*
341%{_mandir}/man1/fold.1*
342%{_mandir}/man1/getgid.1*
343%{_mandir}/man1/groups.1*
344%{_mandir}/man1/head.1*
345%{_mandir}/man1/hostid.1*
346%{_mandir}/man1/id.1*
347%{_mandir}/man1/install.1*
348%{_mandir}/man1/join.1*
349%{_mandir}/man1/link.1*
350%{_mandir}/man1/ln.1*
351%{_mandir}/man1/logname.1*
352%{_mandir}/man1/ls.1*
353%{_mandir}/man1/md5sum.1*
354%{_mandir}/man1/mkdir.1*
355%{_mandir}/man1/mkfifo.1*
356%{_mandir}/man1/mknod.1*
357%{_mandir}/man1/mktemp.1*
358%{_mandir}/man1/mv.1*
359%{_mandir}/man1/nice.1*
360%{_mandir}/man1/nl.1*
361%{_mandir}/man1/nohup.1*
362%{_mandir}/man1/nproc.1*
363%{_mandir}/man1/od.1*
364%{_mandir}/man1/paste.1*
365%{_mandir}/man1/pathchk.1*
366%{_mandir}/man1/pinky.1*
367%{_mandir}/man1/pr.1*
368%{_mandir}/man1/printenv.1*
369%{_mandir}/man1/printf.1*
370%{_mandir}/man1/ptx.1*
371%{_mandir}/man1/pwd.1*
372%{_mandir}/man1/readlink.1*
373%{_mandir}/man1/realpath.1*
374%{_mandir}/man1/rm.1*
375%{_mandir}/man1/rmdir.1*
376%{_mandir}/man1/runcon.1*
377%{_mandir}/man1/seq.1*
378%{_mandir}/man1/sha1sum.1*
379%{_mandir}/man1/sha224sum.1*
380%{_mandir}/man1/sha256sum.1*
381%{_mandir}/man1/sha384sum.1*
382%{_mandir}/man1/sha512sum.1*
383%{_mandir}/man1/shred.1*
384%{_mandir}/man1/shuf.1*
385%{_mandir}/man1/sleep.1*
386%{_mandir}/man1/sort.1*
387%{_mandir}/man1/split.1*
388%{_mandir}/man1/stat.1*
389%{_mandir}/man1/stdbuf.1*
390%{_mandir}/man1/stty.1*
391%{_mandir}/man1/sum.1*
392%{_mandir}/man1/sync.1*
393%{_mandir}/man1/tac.1*
394%{_mandir}/man1/tail.1*
395%{_mandir}/man1/tee.1*
396%{_mandir}/man1/test.1*
397%{_mandir}/man1/timeout.1*
398%{_mandir}/man1/touch.1*
399%{_mandir}/man1/tr.1*
400%{_mandir}/man1/true.1*
401%{_mandir}/man1/truncate.1*
402%{_mandir}/man1/tsort.1*
403%{_mandir}/man1/tty.1*
404%{_mandir}/man1/uname.1*
405%{_mandir}/man1/unexpand.1*
406%{_mandir}/man1/uniq.1*
407%{_mandir}/man1/unlink.1*
408%{_mandir}/man1/users.1*
409%{_mandir}/man1/vdir.1*
410%{_mandir}/man1/wc.1*
411%{_mandir}/man1/who.1*
412%{_mandir}/man1/whoami.1*
413%{_mandir}/man1/yes.1*
414%lang(cs) %{_mandir}/cs/man1/*
415%lang(da) %{_mandir}/da/man1/*
416%lang(de) %{_mandir}/de/man1/*
417%lang(es) %{_mandir}/es/man1/*
418%lang(fi) %{_mandir}/fi/man1/*
419%lang(fr) %{_mandir}/fr/man1/*
420%lang(hu) %{_mandir}/hu/man1/*
421%lang(id) %{_mandir}/id/man1/*
422%lang(it) %{_mandir}/it/man1/*
423%lang(ja) %{_mandir}/ja/man1/*
424%lang(ko) %{_mandir}/ko/man1/*
425%lang(nl) %{_mandir}/nl/man1/*
426%lang(pl) %{_mandir}/pl/man1/*
427%lang(pt) %{_mandir}/pt/man1/*
428%lang(ru) %{_mandir}/ru/man1/*
429%lang(zh_CN) %{_mandir}/zh_CN/man1/*
430%{_infodir}/coreutils.info*
This page took 0.024016 seconds and 4 git commands to generate.