]> git.pld-linux.org Git - packages/bootsplash.git/blame_incremental - bootsplash.spec
- all bootsplash themes provide bootsplash-theme
[packages/bootsplash.git] / bootsplash.spec
... / ...
CommitLineData
1# TODO:
2# - place somewhere info that distkernel support only 16bit splashes (thnx Tomasz Grobelny)
3#
4Summary: Bootsplash - graphical boot process for Linux
5Summary(de.UTF-8): Bootsplash - graphischer System Start
6Summary(pl.UTF-8): Bootsplash - graficzny proces startu systemu dla Linuksa
7Name: bootsplash
8Version: 3.2
9Release: 3
10License: GPL v2
11Group: Applications/System
12Source0: http://www.bootsplash.de/files/splashutils/%{name}-%{version}.tar.bz2
13# Source0-md5: b74c104372fd182d0442b3ed63210e29
14Source1: %{name}.script
15Source2: %{name}-bootanim.script
16Source3: %{name}.sysconfig
17Source4: %{name}.init
18Patch0: %{name}-3.2_makefile_libmng.patch
19URL: http://www.bootsplash.org/
20BuildRequires: freetype-devel >= 2.1
21BuildRequires: libmng-devel
22BuildRequires: rpmbuild(macros) >= 1.268
23Requires(post,preun): /sbin/chkconfig
24Suggests: bootsplash-theme
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%define _bindir /bin
28
29%description
30When you have a kernel with bootsplash capability you can use the
31bootsplash and control its behaviour with this set of userspace
32utilities.
33
34%description -l de.UTF-8
35Wenn du einen Kernel mit der bootsplash Option hast, kannst du diese
36mit diesen Programmen steuern.
37
38%description -l pl.UTF-8
39Mając jądro z opcją bootsplash można uzyskać graficzny ekran podczas
40startu systemu i sterować jego zachowaniem przy użyciu tego zbioru
41narzędzi przestrzeni użytkownika.
42
43%prep
44%setup -q
45%patch0 -p1
46rm -f Utilities/splash.o
47
48%build
49%{__make} -C Utilities \
50 CC="%{__cc}" \
51 CFLAGS="%{rpmcflags} -Wall -I/usr/include/freetype2 -DDEFAULT_FONTNAME=\\\"%{_datadir}/%{name}/luxisri.ttf\\\"" \
52 STRIP=true
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{name},%{_sysconfdir}/bootsplash/themes} \
57 $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
58
59install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/splash
60install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/bootanim
61install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/bootsplash
62install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/bootsplash
63install Scripts/* $RPM_BUILD_ROOT%{_datadir}/%{name}
64install Utilities/splash $RPM_BUILD_ROOT%{_bindir}/splash.bin
65install Utilities/{fbmngplay,fbresolution,fbtruetype} $RPM_BUILD_ROOT%{_bindir}
66install Utilities/*.ttf $RPM_BUILD_ROOT%{_datadir}/%{name}
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post
72/sbin/chkconfig --add bootsplash
73
74%preun
75if [ "$1" = "0" ]; then
76 %service bootsplash stop
77 /sbin/chkconfig --del bootsplash
78fi
79
80%files
81%defattr(644,root,root,755)
82%doc {Documentation,Utilities}/README.*
83%attr(755,root,root) %{_bindir}/*
84%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bootsplash
85%attr(754,root,root) /etc/rc.d/init.d/bootsplash
86%{_datadir}/%{name}
87%dir %{_sysconfdir}/bootsplash
88%dir %{_sysconfdir}/bootsplash/themes
This page took 0.094267 seconds and 4 git commands to generate.