]> git.pld-linux.org Git - packages/aspseek.git/blame_incremental - aspseek.spec
- sed -e "s/%{_sbindir}\/apxs -e/\%{apxs} -e/"
[packages/aspseek.git] / aspseek.spec
... / ...
CommitLineData
1# TODO:
2# - split into indexer and client?
3# - running indexer from cron?
4%define apxs /usr/sbin/apxs
5Summary: Advanced Internet search engine
6Summary(pl): Silnik zaawansowanej wyszukiwarki Internetowej
7Name: aspseek
8Version: 1.2.8
9Release: 1
10License: GPL
11Group: Networking/Utilities
12Source0: http://www.aspseek.org/pkg/src/1.2.8/%{name}-%{version}.tar.gz
13Source1: %{name}-mod_aspseek.conf
14Source2: %{name}.init
15URL: http://www.aspseek.org/
16Requires: webserver
17Requires: %{name}-db-%{version}
18BuildRequires: apache(EAPI)-devel
19BuildRequires: openssl-devel
20BuildRequires: mysql-devel
21BuildRequires: libstdc++-devel
22BuildRequires: zlib-devel
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _sysconfdir /etc/%{name}
26%define _bindir /home/httpd/cgi-bin
27%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
28
29%description
30ASPSeek is an Internet search engine, written in C++ using the STL
31library. It consists of an indexing robot, a search daemon, and a CGI
32search frontend. It can index as many as a few million URLs and search
33for words and phrases, use wildcards, and do a Boolean search. Search
34results can be limited to time period given, site or Web space (set of
35sites) and sorted by relevance (some cool techniques are used) or
36date.
37
38ASPSeek is optimized for multiple sites (threaded index, async DNS
39lookups, grouping results by site, Web spaces), but can be used for
40searching one site as well. ASPSeek can work with multiple
41languages/encodings at once (including multibyte encodings such as
42Chinese) due to Unicode storage mode. Other features include stopwords
43and ispell support, a charset and language guesser, HTML templates for
44search results, excerpts, and query words highlighting.
45
46%description -l pl
47ASPSeek jest silnikiem wyszukiwarki Internetowej, napisany w C++ z
48