]> git.pld-linux.org Git - packages/apinger.git/blame_incremental - apinger.spec
- require target and source IP addresses to be specified in config
[packages/apinger.git] / apinger.spec
... / ...
CommitLineData
1Summary: Alarm Pinger - network monitor with mail notification
2Summary(pl.UTF-8): Alarm Pinger - monitor sieci z powiadamianiem pocztą
3Name: apinger
4Version: 0.6.1
5Release: 6
6License: GPL
7Group: Networking/Utilities
8Source0: https://github.com/downloads/Jajcus/apinger/%{name}-%{version}.tar.gz
9# Source0-md5: 3505e6503ec06363613f16713501bb33
10Source1: %{name}.init
11Source2: %{name}.sysconf
12Patch0: %{name}-user.patch
13Patch1: %{name}-avg_delay.patch
14Patch2: %{name}-config_overwrite_fix.patch
15Patch3: %{name}-rrd_timestamp.patch
16Patch4: %{name}-ac.patch
17Patch5: %{name}-no_exit.patch
18Patch6: %{name}-no_forked_receiver.patch
19Patch7: %{name}-srcip.patch
20Patch8: %{name}-status.patch
21URL: https://github.com/Jajcus/apinger/
22BuildRequires: rpmbuild(macros) >= 1.268
23Requires(post,preun): /sbin/chkconfig
24Requires: rc-scripts
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28Alarm Pinger is a little tool which monitors various IP devices by
29simple ICMP echo requests. There are various other tools, that can do
30this, but most of them are shell or Perl scripts, spawning many
31processes, thus much CPU-expensive, especially when one wants
32continuous monitoring and fast response on target failure. Alarm
33Pinger is a single process written in C, so it doesn't need much CPU
34power even when monitoring many targets with frequent probes. Alarm
35Pinger supports both IPv4 and IPv6.
36
37%description -l pl.UTF-8
38Alarm Pinger to małe narzędzie monitorujące różne urządzenia IP
39wykorzystując pakiety ICMP echo request/reply (tzw. ping). Są różne
40inne narzędzia, które to potrafią, ale większość z nich to skrypty
41shella lub Perla uruchamiające wiele procesów, przez co mocno
42obciążające maszynę, szczególnie gdy ktoś chce ciągłego monitorowania
43i szybkiej informacji o awarii. Alarm Pinger to pojedynczy proces
44napisany w C, więc nie wymaga wielkiej mocy obliczeniowej, nawet gdy
45bada wiele urządzeń częstymi pingami. Alarm Pinger obsługuje zarówno
46IPv4 jak i IPv6.
47
48%prep
49%setup -q
50%patch0 -p1
51%patch1 -p1
52%patch2 -p1
53%patch3 -p1
54%patch4 -p1
55%patch5 -p1
56%patch6 -p1
57%patch7 -p1
58%patch8 -p1
59
60%build
61%{__aclocal}
62%{__autoconf}
63%{__automake}
64%configure
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
70
71%{__make} install \
72 DESTDIR=$RPM_BUILD_ROOT
73
74install src/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
75install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
76install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post
82/sbin/chkconfig --add apinger
83%service apinger restart
84
85%preun
86if [ "$1" = "0" ]; then
87 %service apinger stop
88 /sbin/chkconfig --del apinger
89fi
90
91%files
92%defattr(644,root,root,755)
93%doc AUTHORS NEWS TODO README doc/FAQ.html
94%attr(755,root,root) %{_sbindir}/*
95%attr(754,root,root) %config(noreplace) /etc/rc.d/init.d/apinger
96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apinger
97%attr(640,root,daemon) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
This page took 0.042471 seconds and 4 git commands to generate.