]> git.pld-linux.org Git - packages/apache1-mod_auth_ldap.git/blame_incremental - apache1-mod_auth_ldap.spec
- update to 1.6.1, add ssl bcond
[packages/apache1-mod_auth_ldap.git] / apache1-mod_auth_ldap.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with ssl # build with ssl (requires netscape sdk), tls is available with openldap
4#
5%define mod_name auth_ldap
6%define apxs /usr/sbin/apxs1
7Summary: This is a LDAP authentication module for Apache
8Summary(cs.UTF-8): Autentizační modul LDAP pro WWW server Apache
9Summary(da.UTF-8): En LDAP-autenticeringsmodul for Apache
10Summary(de.UTF-8): Ein LDAP Authentifizierungsmodul für Apache
11Summary(es.UTF-8): Este módulo proporciona autenticación LDAP para Apache
12Summary(fr.UTF-8): Module d'authentification LDAP pour Apache
13Summary(id.UTF-8): Module LDAP authentication untuk Apache
14Summary(it.UTF-8): Modulo di autenticazione LDPA per Apache
15Summary(ja.UTF-8): Apache 用の LDAP 認証モジュール
16Summary(nb.UTF-8): En LDAP-autentiseringsmodul for Apache
17Summary(pl.UTF-8): Moduł uwierzytelnienia LDAP dla Apache
18Summary(pt.UTF-8): Um módulo de autenticação de LDAP para o Apache
19Summary(pt_BR.UTF-8): Este módulo provê autenticação LDAP para o Apache
20Summary(ru.UTF-8): Аутентификационный модуль LDAP для сервера Apache
21Summary(sl.UTF-8): Avtentikacijski modul LDAP za Apache
22Summary(sv.UTF-8): En LDAP autentiseringsmodul för Apache
23Summary(zh_CN.UTF-8): 这是用于 Apache 的 LDAP 验证模块
24Name: apache1-mod_%{mod_name}
25Version: 1.6.1
26Release: 1
27License: BSD
28Group: Networking/Daemons
29Source0: http://www.rudedog.org/auth_ldap/auth_ldap-%{version}.tar.gz
30# Source0-md5: a78d8c5fc77086562ca056c226c97992
31Patch0: %{name}-makefile.patch
32URL: http://www.rudedog.org/auth_ldap/
33BuildRequires: apache1-devel >= 1.3.39
34BuildRequires: autoconf
35BuildRequires: lynx
36BuildRequires: openldap-devel >= 2.3.0
37%{?with_ssl:BuildRequires: mozldap-devel}
38BuildRequires: rpmbuild(macros) >= 1.268
39Requires: apache1(EAPI)
40Requires: apache1-mod_auth
41Obsoletes: apache-mod_auth_ldap < 1.6.0
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
45%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
46
47%description
48This is an authentication module for Apache that allows you to
49authenticate HTTP clients using user entries in an LDAP directory.
50
51%description -l cs.UTF-8
52Balíček obsahuje autentizační modul pro WWW server Apache, který
53umožňuje autentizovat HTTP klienty proti položkám v adresářové službě
54LDAP.
55
56%description -l da.UTF-8
57Denne pakke indeholder en autenticeringsmodul for webtjeneren Apache -
58med auth_ldap installeret kan HTTP-klienter autenticeres mod
59brugerinformation i et LDAP-katalog.
60
61%description -l de.UTF-8
62Dieses Paket enthält ein Authentifizierungs-Modul für den Apache
63Webserver, das Ihnen ermöglicht, HTTP-Clients mit Hilfe von
64Benutzereinträgen in einem LDAP-Verzeichniss zu authentifizieren.
65
66%description -l es.UTF-8
67Este paquete contiene un módulo de autenticación para el servidor
68Apache web que le permite autenticar clientes HTTP usando entradas de
69usuario en un directorio LDAP.
70
71%description -l fr.UTF-8
72Ce paquetage contient un module d'authentification pour le serveur Web
73Apache, qui vous permet d'authentifier les clients HTTP en utilisant
74les entrées utilisateur dans un répertoire LDAP.
75
76%description -l id.UTF-8
77Ini adalah authentication module untuk Apache yang memungkinkan anda
78melakukan otentikasi HTTP client menggunakan user entry di dalam LADP
79directory.
80
81%description -l it.UTF-8
82Questo pacchetto contiene un modulo di autenticazione per il Web
83server Apache che consente di autenticare i client HTTP tramite gli
84inserimenti utente in una directory LDPA.
85
86%description -l ja.UTF-8
87このパッケージには Apache Web サーバーで LDAP ディレクトリ内のユーザー
88エントリを使った HTTP クライアントの認証を可能にするための認証
89モジュールが含まれています。
90
91%description -l nb.UTF-8
92Denne pakken inneholder en autentiseringsmodul for webtjeneren Apache
93- med auth_ldap installert kan HTTP-klienter autentiseres mot
94 brukerinformasjon i en LDAP-katalog.
95
96%description -l pl.UTF-8
97W pakiecie znajduje się moduł do Apache, który pozwala na
98uwierzytelnianie klientów HTTP przy użyciu LDAP.
99
100%description -l pt.UTF-8
101Este pacote contém um módulo de autenticação para o servidor Web
102Apache que lhe permite autenticar os clientes HTTP usando registos de
103utilizadores numa directoria LDAP.
104
105%description -l pt_BR.UTF-8
106Este módulo permite que você autentique clientes HTTP usando o
107diretório LDAP.
108
109%description -l ru.UTF-8
110Это модуль аутентификации для Apache, позволяющий идентифицировать
111HTTP-клиентов на основе записей пользователя в каталоге LDAP.
112
113%description -l sv.UTF-8
114Detta paket innehåller en autenticeringsmodul för webbservern Apache
115som låter dig autenticera HTTP-klienter med använderposter i en
116LDAP-katalog.
117
118%description -l zh_CN.UTF-8
119这是用于 Apache 的验证模块,它允许您使用 LDAP 目录中的用户项验证 HTTP
120客户机。
121
122%prep
123%setup -q -n auth_ldap-%{version}
124%patch0 -p1
125mv -f auth_ldap.c mod_auth_ldap.c
126
127lynx -nolist -dump auth_ldap.html > auth_ldap.txt
128
129%build
130%{__autoconf}
131%configure \
132 --with-apxs=%{apxs} \
133 --with-ldap-sdk=openldap \
134 --with%{!?with_ssl:out}-ssl
135
136%{__make}
137
138%install
139rm -rf $RPM_BUILD_ROOT
140install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
141
142install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
143
144echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
145 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%post
151%service -q apache restart
152
153%postun
154if [ "$1" = "0" ]; then
155 %service -q apache restart
156fi
157
158%triggerpostun -- apache1-mod_%{mod_name} < 1.6.0-1.1
159# check that they're not using old apache.conf
160if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
161 sed -i -e '/^\(Add\|Load\)Module.*mod_%{mod_name}\.\(so\|c\)/d' /etc/apache/apache.conf
162fi
163
164%files
165%defattr(644,root,root,755)
166%doc *.html PROBLEMS auth_ldap.txt
167%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
168%attr(755,root,root) %{_pkglibdir}/mod_auth_ldap.so
This page took 0.062423 seconds and 4 git commands to generate.