]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blame_incremental - apache-mod_ntlm.spec
- fix config dir
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
... / ...
CommitLineData
1# TODO: review security issues
2%define mod_name ntlm
3%define apxs /usr/sbin/apxs
4Summary: This is the NTLM authentication module for Apache
5Summary(pl.UTF-8): Moduł uwierzytelnienia NTLM dla Apache
6Name: apache-mod_%{mod_name}
7Version: 0.1
8Release: 0.1
9Epoch: 1
10License: GPL
11Group: Networking/Daemons/HTTP
12Source0: http://dl.sourceforge.net/modntlm/mod_%{mod_name}2-%{version}.tgz
13# Source0-md5: 8abe4f235af6825f723412e187cac96b
14#Patch0: %{name}-security.patch
15Patch1: %{name}-apr_pool.patch
16URL: http://modntlm.sourceforge.net/
17BuildRequires: %{apxs}
18BuildRequires: apache-devel >= 2.0
19BuildRequires: rpmbuild(macros) >= 1.268
20Requires: apache(modules-api) = %apache_modules_api
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
24%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26%description
27This is an authentication module for Apache that allows you to
28authenticate HTTP clients using samba or windows-like server (using
29NTLM protocol).
30
31%description -l pl.UTF-8
32To jest moduł uwierzytelnienia dla Apache pozwalający na
33uwierzytelnianie klientów HTTP poprzez sambę lub serwer na Windows (z
34użyciem protokołu NTLM).
35
36%prep
37%setup -q -n mod_%{mod_name}2-%{version}
38#%patch -p1
39%patch1 -p0
40
41%build
42%{__make} APXS=%{apxs}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
47
48install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
49echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
50 $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%post
56%service -q httpd restart
57
58%postun
59if [ "$1" = "0" ]; then
60 %service -q httpd restart
61fi
62
63%files
64%defattr(644,root,root,755)
65%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
66%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.024842 seconds and 4 git commands to generate.