]> git.pld-linux.org Git - packages/zabbix.git/blame - zabbix.spec
patch for http poller added
[packages/zabbix.git] / zabbix.spec
CommitLineData
06317756 1# TODO:
d93a02f8 2# - initscript for zabbix-server, zabbix-proxy and zabbix-java
10a854a6
TO
3#
4# Conditional build:
7efbcfc2
JK
5%bcond_without pgsql # enable PostgreSQL support
6%bcond_without sqlite3 # enable sqlite3 support
cd323295 7%bcond_without mysql # enable MySQL support
cd323295
JK
8%bcond_without java # disable java support
9
c4cfaa95 10%define databases %{?with_sqlite3:sqlite3} %{?with_pgsql:postgresql} %{?with_mysql:mysql}
2a82feb1 11%define any_database %{with pgsql}%{with mysql}%{with sqlite3}
2fe2194b 12
0196d0f6 13%define php_min_version 5.4.0
06317756
JK
14Summary: Zabbix - network monitoring software
15Summary(pl.UTF-8): Zabbix - oprogramowanie do monitorowania sieci
10a854a6 16Name: zabbix
e5d5004d 17Version: 4.0.7
7b4db42e 18Release: 1
10a854a6 19License: GPL v2+
d0e25550 20Group: Networking/Utilities
88b80688 21Source0: http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
e5d5004d 22# Source0-md5: 3a53e2e4c18fde9edbe34a89cc7d8297
cd323295 23Source1: %{name}-apache.conf
0196d0f6
ER
24Source2: %{name}_server.service
25Source3: %{name}_agentd.service
26Source4: %{name}_proxy.service
27Source5: %{name}_java.service
28Source6: %{name}.tmpfiles
d93a02f8 29Source7: %{name}_agentd.init
06317756 30Patch0: config.patch
7efbcfc2 31Patch1: sqlite3_dbname.patch
c4cfaa95 32Patch2: always_compile_ipc.patch
4d040055 33Patch3: http_poller_crash.patch
10a854a6 34URL: http://zabbix.sourceforge.net/
d93a02f8 35BuildRequires: OpenIPMI-devel
e27bce28
JK
36BuildRequires: autoconf
37BuildRequires: automake >= 1:1.15
73af344b 38BuildRequires: curl-devel
39BuildRequires: iksemel-devel
cd323295 40%{?with_java:BuildRequires: jdk}
4ffaba52 41BuildRequires: libevent-devel
cd323295 42BuildRequires: libssh2-devel
d93a02f8 43BuildRequires: libtool
0196d0f6 44BuildRequires: libxml2-devel
cd323295 45%{?with_mysql:BuildRequires: mysql-devel}
39709426 46BuildRequires: net-snmp-devel
246efd79 47BuildRequires: openldap-devel >= 2.4.6
2886d983 48BuildRequires: openssl-devel >= 0.9.7d
4ffaba52 49BuildRequires: pcre-devel
9ffbc0d2 50%{?with_pgsql:BuildRequires: postgresql-devel}
0196d0f6 51BuildRequires: rpmbuild(macros) >= 1.671
cd323295
JK
52%{?with_sqlite3:BuildRequires: sqlite3-devel}
53BuildRequires: unixODBC-devel
9e6cf723 54BuildRequires: zlib-devel
0196d0f6
ER
55Requires: %{name}-agentd = %{version}-%{release}
56Requires: %{name}-frontend-php = %{version}-%{release}
57Requires: %{name}-server = %{version}-%{release}
10a854a6
TO
58BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
a5bb35f6 60%define _sysconfdir /etc/%{name}
7dcff817
TP
61%define _appdir %{_datadir}/%{name}
62%define _webapps /etc/webapps
63%define _webapp %{name}
10a854a6
TO
64
65%description
06317756 66Zabbix is software that monitors numerous parameters of a network and
0196d0f6
ER
67the servers on that network. It is a useful tool for monitoring the
68health and integrity of servers. Zabbix uses a flexible notification
69mechanism that allows users to configure email based alerts for
70virtually any event. All monitored parameters are stored in a
71database. Zabbix offers excellent reporting and data visualisation
06317756
JK
72features based on the stored data. Zabbix supports both polling and
73trapping. All Zabbix reports and statistics, as well as configuration
7f4b6a83 74parameters, are accessed through a web-based front end.
75
ff14176a 76%description -l pl.UTF-8
06317756 77Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
1266ba50
TP
78serwerów sieciowych. Jest przydatny przy monitorowaniu działania
79serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
80pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
81dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
06317756 82przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
1266ba50
TP
83oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
84odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
06317756
JK
85statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
86
87%package common
88Summary: Common files for Zabbix monitoring software
89Summary(pl.UTF-8): Wspólne pliki dla oprogramowania monitorującego Zabbix
90Group: Networking/Utilities
91Requires(postun): /usr/sbin/groupdel
92Requires(postun): /usr/sbin/userdel
93Requires(pre): /bin/id
94Requires(pre): /usr/bin/getgid
95Requires(pre): /usr/sbin/groupadd
96Requires(pre): /usr/sbin/useradd
97Provides: group(zabbix)
98Provides: user(zabbix)
99
100%description common
101Common files for Zabbix monitoring software.
102
103%description common -l pl.UTF-8
104Wspólne pliki dla oprogramowania monitorującego Zabbix.
10a854a6 105
cd323295 106%package agentd
06317756
JK
107Summary: Zabbix Agent
108Summary(pl.UTF-8): Agenta Zabbiksa
d0e25550 109Group: Networking/Utilities
06317756 110Requires: %{name}-common = %{version}-%{release}
0196d0f6 111Requires: systemd-units >= 38
96b8972f 112Obsoletes: zabbix-agent-inetd
cd323295 113Obsoletes: zabbix-agent-standalone
d93a02f8
ER
114Requires(post,preun): /sbin/chkconfig
115Requires: rc-scripts
10a854a6 116
cd323295 117%description agentd
06317756 118Zabbix agent collects data from the local system for a Zabbix server.
90e6d4b1 119
cd323295 120%description agentd -l pl.UTF-8
06317756 121Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
7dcff817
TP
122
123%package frontend-php
06317756
JK
124Summary: PHP frontend for Zabbix
125Summary(pl.UTF-8): Interfejs PHP dla Zabbiksa
d0e25550 126Group: Applications/WWW
cd323295 127Requires: php(bcmath)
1d07384b 128Requires: php(core) >= %{php_min_version}
cd323295 129Requires: php(ctype)
1d07384b
JK
130Requires: php(gd)
131Requires: php(gettext)
8cc30dbd 132Requires: php(json)
cd323295
JK
133Requires: php(mbstring)
134Requires: php(pcre)
cd323295 135Requires: php(session)
1d07384b
JK
136Requires: php(sockets)
137Requires: php(xml)
138Requires: php(xmlreader)
139Requires: php(xmlwriter)
7dcff817 140Requires: webapps
cb5654b1 141Requires: webserver(alias)
66fbc8af 142Requires: webserver(indexfile)
7dcff817 143Requires: webserver(php)
7efbcfc2
JK
144Suggests: php(mysql)
145Suggests: php(pgsql)
146Suggests: php(sqlite3)
b8568b0f
AM
147# used with sqlite3
148Suggests: php(sysvsem)
ae9a7f61 149BuildArch: noarch
7dcff817
TP
150
151%description frontend-php
06317756 152This package provides web based (PHP) frontend for Zabbix.
7dcff817
TP
153
154%description frontend-php -l pl.UTF-8
06317756 155Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
7dcff817
TP
156
157%package get
06317756
JK
158Summary: Program retrieving data from Zabbix agent
159Summary(pl.UTF-8): Program odpytujÄcy agenta Zabbiksa
d0e25550 160Group: Networking/Utilities
7dcff817
TP
161
162%description get
06317756 163This package provides a program retrieving data from Zabbix agent.
7dcff817
TP
164
165%description get -l pl.UTF-8
06317756 166Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
10a854a6 167
1b6bdd87 168%package proxy
169Summary: Zabbix proxy
06317756 170Summary(pl.UTF-8): Proxy do Zabbiksa
1b6bdd87 171Group: Networking/Utilities
06317756 172Requires: %{name}-common = %{version}-%{release}
0196d0f6 173Requires: systemd-units >= 38
9a6ace5d 174Requires: zabbix-proxy(db) = %{version}-%{release}
1b6bdd87 175
176%description proxy
06317756 177This package provides the Zabbix proxy.
1b6bdd87 178
179%description proxy -l pl.UTF-8
06317756 180Ten pakiet zawiera proxy Zabbix.
1b6bdd87 181
7efbcfc2
JK
182%package proxy-mysql
183Summary: MySQL support for Zabbix proxy
184Summary(pl.UTF-8): Obsługa MySQL dla proxy do Zabbiksa
185Group: Networking/Utilities
186Provides: %{name}-proxy(db) = %{version}-%{release}
9a6ace5d
ER
187Obsoletes: zabbix-proxy-postgresql
188Obsoletes: zabbix-proxy-sqlite3
7efbcfc2
JK
189
190%description proxy-mysql
191This package provides the Zabbix proxy binary with MySQL support.
192
193%description proxy-mysql -l pl.UTF-8
194Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
195
196%package proxy-postgresql
197Summary: PostgreSQL support for Zabbix proxy
198Summary(pl.UTF-8): Obsługa PostgreSQL dla proxy do Zabbiksa
199Group: Networking/Utilities
200Provides: %{name}-proxy(db) = %{version}-%{release}
9a6ace5d
ER
201Obsoletes: zabbix-proxy-mysql
202Obsoletes: zabbix-proxy-sqlite3
7efbcfc2
JK
203
204%description proxy-postgresql
205This package provides the Zabbix proxy binary with PostgreSQL support.
206
207%description proxy-postgresql -l pl.UTF-8
208Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
209
210%package proxy-sqlite3
211Summary: SQLite 3 support for Zabbix proxy
212Summary(pl.UTF-8): Obsługa SQLite 3 dla proxy do Zabbiksa
213Group: Networking/Utilities
214Provides: %{name}-proxy(db) = %{version}-%{release}
9a6ace5d
ER
215Obsoletes: zabbix-proxy-mysql
216Obsoletes: zabbix-proxy-postgresql
7efbcfc2
JK
217
218%description proxy-sqlite3
219This package provides the Zabbix proxy binary with SQLite 3 support.
220
221%description proxy-sqlite3 -l pl.UTF-8
222Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
223
10a854a6 224%package sender
7dcff817 225Summary: Zabbix sender
06317756 226Summary(pl.UTF-8): Program zawiadamiający Zabbiksa
d0e25550 227Group: Networking/Utilities
10a854a6
TO
228
229%description sender
06317756 230This package provides the Zabbix sender.
10a854a6 231
ff14176a 232%description sender -l pl.UTF-8
06317756 233Ten pakiet zawiera program zawiadamiający Zabbiksa.
a5bb35f6 234
a7e2963d 235%package server
7dcff817 236Summary: Zabbix server
06317756 237Summary(pl.UTF-8): Serwer Zabbiksa
d0e25550 238Group: Networking/Utilities
06317756 239Requires: %{name}-common = %{version}-%{release}
7efbcfc2 240Requires: %{name}-server(db) = %{version}-%{release}
0196d0f6
ER
241Requires: systemd-units >= 38
242Obsoletes: zabbix-suckerd
243Obsoletes: zabbix-trapper-inetd
244Obsoletes: zabbix-trapper-standalone
a7e2963d 245
246%description server
06317756 247This package provides the Zabbix server.
a7e2963d 248
249%description server -l pl.UTF-8
06317756 250Ten pakiet zawiera serwer Zabbiksa.
a7e2963d 251
7efbcfc2
JK
252%package server-mysql
253Summary: MySQL support for Zabbix server
254Summary(pl.UTF-8): Obsługa MySQL sla serwera Zabbiksa
255Group: Networking/Utilities
256Provides: %{name}-server(db) = %{version}-%{release}
9a6ace5d
ER
257Obsoletes: zabbix-server-postgresql
258Obsoletes: zabbix-server-sqlite3
7efbcfc2
JK
259
260%description server-mysql
9a6ace5d
ER
261This package provides the Zabbix server binary for use with MySQL
262database.
7efbcfc2
JK
263
264%description server-mysql -l pl.UTF-8
265Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
266
267%package server-postgresql
268Summary: PostgreSQL support for Zabbix server
269Summary(pl.UTF-8): Obsługa PostgreSQL sla serwera Zabbiksa
270Group: Networking/Utilities
271Provides: %{name}-server(db) = %{version}-%{release}
9a6ace5d
ER
272Obsoletes: zabbix-server-mysql
273Obsoletes: zabbix-server-sqlite3
7efbcfc2
JK
274
275%description server-postgresql
9a6ace5d
ER
276This package provides the Zabbix server binary for use with PostgreSQL
277database.
7efbcfc2
JK
278
279%description server-postgresql -l pl.UTF-8
280Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
281
cd323295
JK
282%package java
283Summary: Zabbix Java Gateway
284Group: Networking/Utilities
06317756 285Requires: %{name}-common = %{version}-%{release}
0196d0f6 286Requires: systemd-units >= 38
cd323295
JK
287
288%description java
289This package provides the Zabbix Java Gateway.
290
10a854a6 291%prep
5d18cc59 292%setup -q
10a854a6 293
06317756 294%patch0 -p1
7efbcfc2 295%patch1 -p1
4ffaba52 296%patch2 -p1
4d040055 297%patch3 -p1
06317756 298
10a854a6 299%build
e27bce28
JK
300%{__libtoolize}
301%{__aclocal} -I m4
302%{__autoconf}
303%{__autoheader}
304%{__automake}
7efbcfc2
JK
305
306configure() {
307 %configure \
2fe2194b 308 --enable-agent \
cd323295
JK
309 --enable-ipv6 \
310 %{__enable_disable java} \
73af344b 311 --with-jabber \
cd323295
JK
312 --with-ldap \
313 --with-libcurl \
314 --with-libxml2 \
315 --with-net-snmp \
316 --with-openipmi \
317 --with-openssl \
318 --with-ssh2 \
7efbcfc2
JK
319 --with-unixodbc \
320 "$@"
321}
322
323configure \
324 --disable-server \
9a6ace5d 325 --disable-proxy
10a854a6
TO
326
327%{__make}
328
7efbcfc2 329for database in %{databases} ; do
c4cfaa95
JK
330 if [ "$database" = "sqlite3" ] ; then
331 enable_server=""
332 else
333 enable_server="--enable-server"
334 fi
7efbcfc2
JK
335 configure \
336 --with-$database \
c4cfaa95 337 $enable_server \
7efbcfc2
JK
338 --enable-proxy
339
7efbcfc2
JK
340 %{__make}
341
c4cfaa95
JK
342 if [ "$enable_server" ] ; then
343 %{__make} install \
344 -C src/zabbix_server \
345 DESTDIR=$PWD/install-${database}
c4cfaa95
JK
346 fi
347
7efbcfc2
JK
348 %{__make} install \
349 -C src/zabbix_proxy \
350 DESTDIR=$PWD/install-${database}
7efbcfc2
JK
351done
352
10a854a6
TO
353%install
354rm -rf $RPM_BUILD_ROOT
d93a02f8 355install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d,/etc/webapps/%{_webapp},%{_appdir}} \
8d0f9b1e 356 $RPM_BUILD_ROOT{/var/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
10a854a6 357
2fe2194b 358%{__make} install \
cd323295
JK
359 DESTDIR=$RPM_BUILD_ROOT \
360 ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
10a854a6 361
7efbcfc2 362for database in %{databases} ; do
c4cfaa95
JK
363 if [ "$database" != "sqlite3" ] ; then
364 cp -p install-$database/%{_sbindir}/zabbix_server \
365 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
366 fi
7efbcfc2
JK
367 cp -p install-$database/%{_sbindir}/zabbix_proxy \
368 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
369done
370
371if [ -n "$database" ] ; then
372 ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
373 ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
374fi
375
376%if %{with sqlite3}
377install -d $RPM_BUILD_ROOT/var/lib/zabbix
378touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
379%endif
380
7dcff817 381cp -r frontends $RPM_BUILD_ROOT%{_appdir}
06317756 382
0196d0f6
ER
383cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
384cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
cd323295 385
06317756
JK
386install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
387install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
d93a02f8 388install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zabbix_agentd
06317756
JK
389install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
390install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
391
6594aa3f 392cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
06317756
JK
393
394mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
395ln -s %{_sysconfdir}/frontend $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf
396touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
397
cd323295
JK
398%if %{with java}
399mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
400ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
06317756
JK
401mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
402ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
403mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
404ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
cd323295
JK
405
406cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
407#!/bin/sh
408
409exec %{_datadir}/zabbix_java/startup.sh "$@"
410EOF
411
412cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
413#!/bin/sh
414
415exec %{_datadir}/zabbix_java/shutdown.sh "$@"
416EOF
417%endif
10a854a6
TO
418
419%clean
420rm -rf $RPM_BUILD_ROOT
421
7dcff817
TP
422%triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
423%webapp_register apache %{_webapp}
424
425%triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
426%webapp_unregister apache %{_webapp}
427
428%triggerin frontend-php -- apache < 2.2.0, apache-base
429%webapp_register httpd %{_webapp}
430
431%triggerun frontend-php -- apache < 2.2.0, apache-base
432%webapp_unregister httpd %{_webapp}
433
06317756 434%pre common
78794d78
ER
435%groupadd -g 111 zabbix
436%useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
68fab610 437%addusertogroup -q zabbix proc
10a854a6 438
06317756
JK
439%postun common
440if [ "$1" = "0" ]; then
441 %userremove zabbix
442 %groupremove zabbix
443fi
444
7efbcfc2 445%post server-mysql
96b8972f 446if [ "$1" = 1 ]; then
cd323295 447 %banner -e %{name}-server <<-EOF
c4962172 448 You should create database for Zabbix.
7efbcfc2 449
cd323295 450 Running these should be fine in most cases:
c4962172 451 mysqladmin create zabbix
7efbcfc2
JK
452 zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
453 zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
454 zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
455EOF
456fi
457ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
458
459%post server-postgresql
460if [ "$1" = 1 ]; then
461 %banner -e %{name}-server <<-EOF
462 You should create database for Zabbix.
463
464 Running these should be fine in most cases:
465
466 createuser zabbix
467 createdb -O zabbix zabbix
468 zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
469 zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
470 zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
471EOF
472fi
473ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
474
7efbcfc2 475%post server
06317756 476%systemd_post zabbix_server.service
c4962172 477
06317756
JK
478%preun server
479%systemd_preun zabbix_server.service
480
481%postun server
7efbcfc2
JK
482if [ "$1" = "0" ]; then
483 if [ -L %{_sbindir}/zabbix_server ] ; then
484 rm -f %{_sbindir}/zabbix_server || :
485 fi
486fi
06317756
JK
487%systemd_reload
488
489%post agentd
d93a02f8
ER
490/sbin/chkconfig --add zabbix_agentd
491%service zabbix_agentd restart
06317756
JK
492%systemd_post zabbix_agentd.service
493
494%preun agentd
d93a02f8
ER
495if [ "$1" = "0" ]; then
496 %service -q zabbix_agentd stop
497 /sbin/chkconfig --del zabbix_agentd
498fi
06317756
JK
499%systemd_preun zabbix_agentd.service
500
501%postun agentd
502%systemd_reload
503
7efbcfc2
JK
504%post proxy-mysql
505ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
506
507%post proxy-postgresql
508ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
509
510%post proxy-sqlite3
511ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
512
06317756
JK
513%post proxy
514%systemd_post zabbix_proxy.service
515
516%preun proxy
517%systemd_preun zabbix_proxy.service
518
519%postun proxy
520%systemd_reload
521
522%post java
523%systemd_post zabbix_java.service
524
525%preun java
526%systemd_preun zabbix_java.service
527
528%postun java
529%systemd_reload
10a854a6 530
10a854a6
TO
531%files
532%defattr(644,root,root,755)
cd323295 533%doc AUTHORS ChangeLog README
06317756
JK
534
535%files common
536%defattr(644,root,root,755)
537%doc AUTHORS ChangeLog README
538%attr(751,root,zabbix) %dir %{_sysconfdir}
539%attr(751,root,http) %dir %{_sysconfdir}/frontend
e4c376d6 540%dir %{_appdir}
7dcff817 541%dir %{_appdir}/frontends
8d0f9b1e 542%dir %attr(770,root,zabbix) /var/run/zabbix
06317756 543%dir %attr(775,root,zabbix) /var/log/zabbix
6594aa3f 544%{systemdtmpfilesdir}/zabbix.conf
10a854a6 545
cd323295 546%files agentd
10a854a6 547%defattr(644,root,root,755)
3e3c35a0 548%doc conf/zabbix_agentd/*.conf
7dcff817 549%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
3e3c35a0 550%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
d93a02f8 551%attr(754,root,root) /etc/rc.d/init.d/zabbix_agentd
b0f13a65 552%attr(755,root,root) %{_sbindir}/zabbix_agentd
ed93a3d2 553%{_mandir}/man8/zabbix_agentd*
06317756 554%{systemdunitdir}/zabbix_agentd.service
10a854a6 555
7dcff817 556%files frontend-php
10a854a6 557%defattr(644,root,root,755)
7dcff817 558%attr(750,root,http) %dir %{_webapps}/%{_webapp}
7132ad20
ER
559%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
560%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
06317756
JK
561%ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
562%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
563%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
564%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
7132ad20 565%{_appdir}/frontends/php
10a854a6 566
a7e2963d 567%files get
10a854a6 568%defattr(644,root,root,755)
ed93a3d2 569%attr(755,root,root) %{_bindir}/zabbix_get
570%{_mandir}/man1/zabbix_get*
10a854a6 571
2a82feb1 572%if %{any_database}
1b6bdd87 573%files proxy
574%defattr(644,root,root,755)
cd323295 575%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
3e3c35a0 576%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
7efbcfc2 577%ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
1b6bdd87 578%{_mandir}/man8/zabbix_proxy*
06317756 579%{systemdunitdir}/zabbix_proxy.service
2a82feb1 580%endif
1b6bdd87 581
7efbcfc2
JK
582%if %{with mysql}
583%files proxy-mysql
584%defattr(644,root,root,755)
585%attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
586%endif
587
588%if %{with pgsql}
589%files proxy-postgresql
590%defattr(644,root,root,755)
591%attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
592%endif
593
594%if %{with sqlite3}
595%files proxy-sqlite3
596%defattr(644,root,root,755)
597%attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
598%endif
599
7dcff817
TP
600%files sender
601%defattr(644,root,root,755)
ed93a3d2 602%attr(755,root,root) %{_bindir}/zabbix_sender
603%{_mandir}/man1/zabbix_sender*
7dcff817 604
2a82feb1 605%if %{any_database}
a7e2963d 606%files server
10a854a6 607%defattr(644,root,root,755)
7efbcfc2 608%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
3e3c35a0 609%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
7efbcfc2
JK
610%ghost %attr(755,root,root) %{_sbindir}/zabbix_server
611%{_mandir}/man8/zabbix_server*
612%{systemdunitdir}/zabbix_server.service
2a82feb1 613%endif
7efbcfc2 614
cd323295 615%if %{with mysql}
7efbcfc2
JK
616%files server-mysql
617%defattr(644,root,root,755)
9e6cf723 618%doc database/mysql/*.sql
7efbcfc2 619%attr(755,root,root) %{_sbindir}/zabbix_server-mysql
cd323295 620%endif
7efbcfc2 621
06317756 622%if %{with pgsql}
7efbcfc2
JK
623%files server-postgresql
624%defattr(644,root,root,755)
9e6cf723 625%doc database/postgresql/*.sql
7efbcfc2 626%attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
cd323295 627%endif
7efbcfc2 628
cd323295
JK
629%if %{with java}
630%files java
631%defattr(644,root,root,755)
632%attr(755,root,root) %{_sbindir}/zabbix_java-start
633%attr(755,root,root) %{_sbindir}/zabbix_java-stop
634%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
06317756
JK
635%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
636%attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
cd323295
JK
637%dir %{_datadir}/zabbix_java
638%{_datadir}/zabbix_java/bin
639%{_datadir}/zabbix_java/lib
640%{_datadir}/zabbix_java/settings.sh
641%attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
642%attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
06317756 643%{systemdunitdir}/zabbix_java.service
cd323295 644%endif
This page took 0.221788 seconds and 4 git commands to generate.