]> git.pld-linux.org Git - packages/xz.git/blame - xz.spec
up to 5.2.8
[packages/xz.git] / xz.spec
CommitLineData
1846bd29
JB
1#
2# Conditional build:
3%bcond_without tests # don't perform make check
8ecd375e 4%bcond_without asm # ix86 asm optimizations
5c4bddac
ER
5
6%ifnarch %{ix86}
7# Speed-optimized CRC64 using slicing-by-four algorithm. This uses only i386
8# instructions, but it is optimized for i686 and later (including e.g. Pentium
9# II/III/IV, Athlon XP, and Core 2).
10%undefine with_asm
11%endif
521b5888
ER
12
13%if "%{pld_release}" == "ac"
14%undefine with_asm
15%endif
16
82d22baf 17Summary: LZMA Encoder/Decoder
34fad00c 18Summary(pl.UTF-8): Koder/Dekoder LZMA
d73f94d2 19Name: xz
3eba7ff9 20Version: 5.2.8
14d069cc 21Release: 1
92626cfe 22Epoch: 1
9acc8826 23License: LGPL v2.1+, helper scripts on GPL v2+
82d22baf 24Group: Applications/Archiving
36228597 25Source0: https://tukaani.org/xz/%{name}-%{version}.tar.bz2
3eba7ff9 26# Source0-md5: bddd86f5f7dca21706f3a5d3fab1b422
aaa8729b 27Patch0: %{name}-parallel.patch
a17a78a4 28Patch1: %{name}-memlimit.patch
36228597 29URL: https://tukaani.org/xz/
521b5888
ER
30%{?with_asm:BuildRequires: gcc >= 5:3.4}
31BuildRequires: rpm >= 4.4.9-56
56d2abb2 32BuildRequires: rpmbuild(macros) >= 1.402
01610c22 33Requires: %{name}-libs = %{epoch}:%{version}-%{release}
521b5888 34Suggests: mktemp
99e7eab7
AM
35Provides: lzma = %{epoch}:%{version}-%{release}
36Obsoletes: lzma < 1:4.999.6
521b5888 37Conflicts: rpm < 4.4.9
82d22baf 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41LZMA is default and general compression method of 7z format in 7-Zip
42program. LZMA provides high compression ratio and very fast
43decompression, so it is very suitable for embedded applications. For
44example, it can be used for ROM (firmware) compressing.
45
46LZMA features:
47
48- Compressing speed: 500 KB/s on 1 GHz CPU
49- Decompressing speed:
50 - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
51 - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
52 CPU.
2f88d337 53- Small memory requirements for decompressing: 8-32 KB + dictionary
54 size
82d22baf 55- Small code size for decompressing: 2-8 KB (depending from speed
56 optimizations)
57
fb275d27
JR
58%description -l pl.UTF-8
59LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
60stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
61bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
62Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
82d22baf 63
64Cechy LZMA:
65
fb275d27
JR
66- Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
67- Szybkość dekompresowania:
82d22baf 68 - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
69 - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
70 prostych RISC-ach,
fb275d27
JR
71- Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
72 słownika,
73- Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
82d22baf 74 optymalizacji).
75
1010510a
ER
76%package libs
77Summary: LZMA shared library
34fad00c 78Summary(pl.UTF-8): Biblioteka współdzielona LZMA
1010510a 79Group: Libraries
99e7eab7
AM
80Provides: lzma-libs = %{epoch}:%{version}-%{release}
81Obsoletes: lzma-libs < 1:4.999.6
1010510a
ER
82
83%description libs
84d12552
JB
84LZMA shared library.
85
fb275d27
JR
86%description libs -l pl.UTF-8
87Biblioteka współdzielona LZMA.
1010510a 88
90fc2073 89%package devel
84d12552 90Summary: Header file for LZMA library
34fad00c 91Summary(pl.UTF-8): Plik nagłówkowy biblioteki LZMA
d9b6428a 92Group: Development/Libraries
b8dda4f2 93Requires: %{name}-libs = %{epoch}:%{version}-%{release}
99e7eab7
AM
94Provides: lzma-devel = %{epoch}:%{version}-%{release}
95Obsoletes: lzma-devel < 1:4.999.6
90fc2073 96
97%description devel
84d12552 98Header file for LZMA library.
6e34e97f 99
fb275d27
JR
100%description devel -l pl.UTF-8
101Plik nagłówkowy biblioteki LZMA.
90fc2073 102
1010510a
ER
103%package static
104Summary: LZMA static library
34fad00c 105Summary(pl.UTF-8): Biblioteka statyczna LZMA
1010510a 106Group: Development/Libraries
b8dda4f2 107Requires: %{name}-devel = %{epoch}:%{version}-%{release}
99e7eab7
AM
108Provides: lzma-static = %{epoch}:%{version}-%{release}
109Obsoletes: lzma-static < 1:4.999.6
1010510a
ER
110
111%description static
84d12552
JB
112LZMA static library.
113
fb275d27 114%description static -l pl.UTF-8
84d12552 115Biblioteka statyczna LZMA.
1010510a 116
82d22baf 117%prep
197d6627 118%setup -q
aaa8729b 119%patch0 -p1
75b7e3b3 120%patch1 -p1
82d22baf 121
122%build
521b5888
ER
123%configure \
124 %{!?with_asm:--disable-assembler}
92626cfe 125%{__make}
90fc2073 126
b7470431
AM
127%{?with_tests:%{__make} check}
128
82d22baf 129%install
130rm -rf $RPM_BUILD_ROOT
e2c9b1ff 131install -d $RPM_BUILD_ROOT{/etc/env.d,/%{_lib}}
bd361cdc 132
92626cfe
AM
133%{__make} install \
134 DESTDIR=$RPM_BUILD_ROOT
135
e2c9b1ff
ER
136%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
137
138install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139cp -a doc/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
140
35e87229 141mv -f $RPM_BUILD_ROOT%{_libdir}/liblzma.so.* $RPM_BUILD_ROOT/%{_lib}
8ecd375e 142ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/liblzma.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/liblzma.so
35e87229 143
d73f94d2 144echo '#XZ_OPT="--threads=2"' > $RPM_BUILD_ROOT/etc/env.d/XZ_OPT
71b73044 145
590de190 146%find_lang %{name}
82d22baf 147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
1010510a
ER
151%post libs -p /sbin/ldconfig
152%postun libs -p /sbin/ldconfig
153
590de190 154%files -f %{name}.lang
82d22baf 155%defattr(644,root,root,755)
d73f94d2 156%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/XZ_OPT
590de190
JB
157%attr(755,root,root) %{_bindir}/lz*
158%attr(755,root,root) %{_bindir}/unlzma
159%attr(755,root,root) %{_bindir}/unxz
160%attr(755,root,root) %{_bindir}/xz*
161%{_mandir}/man1/lz*.1*
162%{_mandir}/man1/unlzma.1*
163%{_mandir}/man1/unxz.1*
164%{_mandir}/man1/xz*.1*
7fc5fe6b
JB
165%lang(de) %{_mandir}/de/man1/lz*.1*
166%lang(de) %{_mandir}/de/man1/unlzma.1*
167%lang(de) %{_mandir}/de/man1/unxz.1*
168%lang(de) %{_mandir}/de/man1/xz*.1*
7f77f452
JP
169%lang(fr) %{_mandir}/fr/man1/lz*.1*
170%lang(fr) %{_mandir}/fr/man1/unlzma.1*
171%lang(fr) %{_mandir}/fr/man1/unxz.1*
172%lang(fr) %{_mandir}/fr/man1/xz*.1*
590de190
JB
173
174%files libs
92626cfe 175%defattr(644,root,root,755)
d73f94d2 176%doc AUTHORS COPYING README THANKS
2e897a0c 177%doc doc/*.txt
35e87229 178%attr(755,root,root) /%{_lib}/liblzma.so.*.*.*
42322a5b 179%attr(755,root,root) %ghost /%{_lib}/liblzma.so.5
1010510a 180
92626cfe
AM
181%files devel
182%defattr(644,root,root,755)
9acc8826
JB
183%attr(755,root,root) %{_libdir}/liblzma.so
184%{_libdir}/liblzma.la
185%{_includedir}/lzma.h
fbb952ac 186%{_includedir}/lzma
d73f94d2 187%{_pkgconfigdir}/liblzma.pc
e2c9b1ff 188%{_examplesdir}/%{name}-%{version}
1010510a 189
92626cfe
AM
190%files static
191%defattr(644,root,root,755)
9acc8826 192%{_libdir}/liblzma.a
This page took 0.274747 seconds and 4 git commands to generate.