]> git.pld-linux.org Git - packages/xsimd.git/blame - xsimd.spec
- updated to 10.0.0
[packages/xsimd.git] / xsimd.spec
CommitLineData
95f7429c
JB
1# TODO: XTL xcomplex support? (BR: xtl-devel >= 0.7.0)
2#
3# Conditional build:
4%bcond_without apidocs # API documentation
5#
6Summary: C++ wrappers for SIMD intrinsics
7Summary(pl.UTF-8): Opakowanie C++ dla operacji SIMD
8Name: xsimd
26fd6495 9Version: 10.0.0
95f7429c
JB
10Release: 1
11License: BSD
12Group: Libraries
13#Source0Download: https://github.com/xtensor-stack/xsimd/tags
14Source0: https://github.com/xtensor-stack/xsimd/archive/%{version}/%{name}-%{version}.tar.gz
26fd6495 15# Source0-md5: e0dfed5da51b0d34d02b42f5b2ddf830
95f7429c
JB
16URL: https://xsimd.readthedocs.io/
17BuildRequires: cmake >= 3.1
18BuildRequires: rpmbuild(macros) >= 1.605
19%if %{with apidocs}
20BuildRequires: doxygen
21BuildRequires: python3-breathe
22BuildRequires: python3-sphinx_rtd_theme
23BuildRequires: sphinx-pdg-3
24%endif
25BuildArch: noarch
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29SIMD (Single Instruction, Multiple Data) is a feature of
30microprocessors that has been available for many years. SIMD
31instructions perform a single operation on a batch of values at once,
32and thus provide a way to significantly accelerate code execution.
33However, these instructions differ between microprocessor vendors and
34compilers.
35
36xsimd provides a unified means for using these features for library
37authors. Namely, it enables manipulation of batches of numbers with
38the same arithmetic operators as for single values. It also provides
39accelerated implementation of common mathematical functions operating
40on batches.
41
42%description -l pl.UTF-8
43SIMD (Single Instruction, Multiple Data - jedna instrukcja, wiele
44danych) to funkcjoalność mikroprocesorów dostępna od wielu lat.
45Instrukcje SIMD wykonują pojedynczą operację na zbiorze wartości w
46jednym czasie, zapewniając mozliwość znaczącego przyspieszenia
47wykonywania kodu. Jednak instrukcje te różnią się w zależności od
48producenta procesora i kompilatora.
49
50xsimd udostępnia autorom bibliotek ujednolicone sposoby używania tych
51funkcji. W szczególności xsimd pozwala operować na zbiorach liczb tymi
52samymi operatorami, co na pojedynczych wartościach. Zapewnia także
53akcelerowaną implementację popularnych funkcji matematycznych
54operujących na zbiorach wartości.
55
56%package devel
57Summary: C++ wrappers for SIMD intrinsics
58Summary(pl.UTF-8): Opakowanie C++ dla operacji SIMD
59Group: Development/Libraries
60Requires: libstdc++-devel
61
62%description devel
63SIMD (Single Instruction, Multiple Data) is a feature of
64microprocessors that has been available for many years. SIMD
65instructions perform a single operation on a batch of values at once,
66and thus provide a way to significantly accelerate code execution.
67However, these instructions differ between microprocessor vendors and
68compilers.
69
70xsimd provides a unified means for using these features for library
71authors. Namely, it enables manipulation of batches of numbers with
72the same arithmetic operators as for single values. It also provides
73accelerated implementation of common mathematical functions operating
74on batches.
75
76%description devel -l pl.UTF-8
77SIMD (Single Instruction, Multiple Data - jedna instrukcja, wiele
78danych) to funkcjoalność mikroprocesorów dostępna od wielu lat.
79Instrukcje SIMD wykonują pojedynczą operację na zbiorze wartości w
80jednym czasie, zapewniając mozliwość znaczącego przyspieszenia
81wykonywania kodu. Jednak instrukcje te różnią się w zależności od
82producenta procesora i kompilatora.
83
84xsimd udostępnia autorom bibliotek ujednolicone sposoby używania tych
85funkcji. W szczególności xsimd pozwala operować na zbiorach liczb tymi
86samymi operatorami, co na pojedynczych wartościach. Zapewnia także
87akcelerowaną implementację popularnych funkcji matematycznych
88operujących na zbiorach wartości.
89
90%package apidocs
91Summary: API documentation for xsimd library
92Summary(pl.UTF-8): Dokumentacja API biblioteki xsimd
93Group: Documentation
94
95%description apidocs
96API documentation for xsimd library.
97
98%description apidocs -l pl.UTF-8
99Dokumentacja API biblioteki xsimd.
100
101%prep
102%setup -q
103
104%build
105install -d build
106cd build
107# fake LIBDIR so we can create noarch package
108%cmake .. \
109 -DCMAKE_INSTALL_LIBDIR=%{_datadir}
110
111%{__make}
112cd ..
113
114%if %{with apidocs}
115%{__make} -C docs html \
116 SPHINXBUILD=sphinx-build-3
117%endif
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} -C build install \
123 DESTDIR=$RPM_BUILD_ROOT
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files devel
129%defattr(644,root,root,755)
130%doc LICENSE README.md
131%{_includedir}/xsimd
132%{_npkgconfigdir}/xsimd.pc
133%{_datadir}/cmake/xsimd
134
135%if %{with apidocs}
136%files apidocs
137%defattr(644,root,root,755)
138%doc docs/build/html/{_images,_static,api,*.html,*.js}
139%endif
This page took 0.155988 seconds and 4 git commands to generate.