]> git.pld-linux.org Git - packages/xorg-driver-video-fglrx.git/blame - xorg-driver-video-fglrx.spec
- drop non-dist kernl support
[packages/xorg-driver-video-fglrx.git] / xorg-driver-video-fglrx.spec
CommitLineData
de93633b 1# Conditional build:
de93633b 2%bcond_without kernel # don't build kernel modules
de93633b 3%bcond_without userspace # don't build userspace tools
4%bcond_with verbose # verbose build (V=1)
de93633b 5
44150540 6%define x11ver xpic
de93633b 7
4f51afba
JR
8# The goal here is to have main, userspace, package built once with
9# simple release number, and only rebuild kernel packages with kernel
10# version as part of release number, without the need to bump release
11# with every kernel change.
12%if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
13%{error:kernel and userspace cannot be built at the same time on PLD builders}
14exit 1
15%endif
16
72311a60 17%if "%{_alt_kernel}" != "%{nil}"
4f51afba
JR
18%if 0%{?build_kernels:1}
19%{error:alt_kernel and build_kernels are mutually exclusive}
20exit 1
21%endif
72311a60 22%undefine with_userspace
4f51afba
JR
23%global _build_kernels %{alt_kernel}
24%else
25%global _build_kernels %{?build_kernels:,%{?build_kernels}}
72311a60 26%endif
4f51afba 27
06b22105
ER
28%if %{without userspace}
29# nothing to be placed to debuginfo package
30%define _enable_debug_packages 0
31%endif
72311a60 32
4f51afba
JR
33%define kbrs %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
34%define kpkg %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
35%define bkpkg %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
36
de93633b 37%ifarch %{ix86}
6800c75d 38%define arch_sufix %{nil}
de93633b 39%define arch_dir x86
40%else
de93633b 41%define arch_sufix _64a
42%define arch_dir x86_64
43%endif
44
09118c22 45%define intver 14.501.1003
5d943d2e 46%define betaver 1.0
58549e73 47#define rel 0.beta%{betaver}.3
20cc48d9 48
09118c22 49%define rel 1
72311a60 50%define pname xorg-driver-video-fglrx
053842d1
JR
51Summary: Linux Drivers for AMD/ATI graphics accelerators
52Summary(pl.UTF-8): Sterowniki do akceleratorów graficznych AMD/ATI
4f51afba 53Name: %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
09118c22 54Version: 14.12
d58f270a 55Release: %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
5d96cd9e 56Epoch: 1
053842d1 57License: AMD Binary (parts are GPL)
de93633b 58Group: X11
059ae373 59# http://support.amd.com/ click through "download drivers", desktop -> radeon hd -> 7xxx -> linux
09118c22
JR
60#Source0: http://www2.ati.com/drivers/linux/amd-catalyst-omega-%{version}-linux-run-installers.zip
61Source0: amd-catalyst-omega-%{version}-linux-run-installers.zip
62# Source0-md5: ced4329274a02712406bda678ffbd743
58549e73 63%define vver %(echo %{version} | tr . -)
5d943d2e 64#Source0: amd-catalyst-%{vver}-linux-x86-x86-64.zip
566515bf
JR
65Source1: atieventsd.init
66Source2: atieventsd.sysconfig
67Source3: gl.pc.in
5aba250d 68Source4: 10-fglrx.conf
3e526379 69Source5: 10-fglrx-modules.conf
72311a60 70Patch0: %{pname}-kh.patch
8b7f9c10 71Patch1: %{pname}-smp.patch
ce2fff9a 72Patch2: %{pname}-x86genericarch.patch
6fab1c66
JR
73Patch3: %{pname}-desktop.patch
74Patch4: %{pname}-nofinger.patch
d62793ba 75Patch5: %{pname}-GPL-only.patch
ef56bf22
JR
76Patch6: %{pname}-intel_iommu.patch
77Patch7: linux-3.17.patch
13897f9c 78URL: http://ati.amd.com/support/drivers/linux/linux-radeon.html
ba608059 79%{?with_kernel:%{expand:%kbrs}}
4f51afba 80BuildRequires: rpmbuild(macros) >= 1.678
051fc62d 81BuildRequires: sed >= 4.0
50c0449c 82Requires: %{pname}-libs = %{epoch}:%{version}-%{rel}
de93633b 83Requires: xorg-xserver-server
5d943d2e 84Requires: xorg-xserver-server(videodrv-abi) <= 18.0
a1d0c0b1 85Requires: xorg-xserver-server(videodrv-abi) >= 2.0
5cd011e2 86Suggests: kernel-video-firegl
b4410e56 87Provides: xorg-driver-video
f72bb093 88Provides: xorg-xserver-module(glx)
d0cb1f8b 89Obsoletes: X11-driver-firegl < 1:7.0.0
d0cb1f8b 90Obsoletes: XFree86-driver-firegl < 1:7.0.0
3a6c6402 91Obsoletes: xorg-driver-video-fglrx-config
ca92b9f5 92Obsoletes: xorg-driver-video-fglrx-libdri
f72bb093 93Obsoletes: xorg-driver-video-fglrx-libglx
de93633b 94ExclusiveArch: i586 i686 athlon pentium3 pentium4 %{x8664}
05988331 95BuildRoot: %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
de93633b 96
185c64d2 97%define _ccver %(rpm -q --qf "%{VERSION}" gcc | sed 's/\\..*//')
98
50ee3256
JR
99%define _noautoreqdep libGL.so.1
100%define no_install_post_check_so 1
de93633b 101
102%description
993147cc
JR
103AMD display driver which allows for hardware accelerated rendering
104with ATI Mobility, FireGL and Desktop GPUs. Some of the Desktop and
105Mobility GPUs supported are the Radeon HD 5xxx series to the
106Radeon HD 7xxx series.
de93633b 107
91bd8dfa 108%description -l pl.UTF-8
993147cc
JR
109Sterownik AMD umożliwiający sprzętowo akcelerowany rendering do kart
110graficznych ATI Mobility, FireGL i Desktopowych. Niektóre ze
111wspieranych Desktopowych i Mobilnych kart to Radeon HD 5xxx do
112Radeon HD 7xxx.
de93633b 113
5b2ffdd6
JR
114%package libs
115Summary: OpenGL (GL and GLX) ATI/AMD libraries
116Summary(pl.UTF-8): Biblioteki OpenGL (GL i GLX) ATI/AMD
117Group: X11/Development/Libraries
118Requires(post,postun): /sbin/ldconfig
119# 4.0 for Radeon HD 5000 Series
120Provides: OpenGL = 3.3
121Provides: OpenGL-GLX = 1.4
5b2ffdd6
JR
122Obsoletes: X11-OpenGL-core < 1:7.0.0
123Obsoletes: X11-OpenGL-libGL < 1:7.0.0
124Obsoletes: XFree86-OpenGL-core < 1:7.0.0
125Obsoletes: XFree86-OpenGL-libGL < 1:7.0.0
126
127%description libs
128ATI/AMD OpenGL (GL and GLX only) implementation libraries.
129
130%description libs -l pl.UTF-8
131Implementacja OpenGL (tylko GL i GLX) firmy ATI/AMD.
132
57e97736 133%package devel
91311dfb 134Summary: Header files for development for the ATI Radeon cards proprietary driver
7bd8110b 135Summary(pl.UTF-8): Pliki nagłówkowe do programowania z użyciem własnościowego sterownika dla kart ATI Radeon
57e97736 136Group: X11/Development/Libraries
50c0449c 137Requires: %{pname}-libs = %{epoch}:%{version}-%{rel}
91311dfb
JB
138# or more?
139Requires: xorg-proto-glproto-devel
5b2ffdd6 140# 4.0 for Radeon HD 5000 Series
5b2ffdd6 141Provides: OpenGL-GLX-devel = 1.4
a1d0c0b1 142Provides: OpenGL-devel = 3.3
5b2ffdd6
JR
143Obsoletes: X11-OpenGL-devel-base
144Obsoletes: XFree86-OpenGL-devel-base
57e97736
PS
145
146%description devel
a1d0c0b1 147Header files for development for the ATI proprietary driver for ATI
148Radeon graphic cards.
91311dfb 149
91bd8dfa
JR
150%description devel -l pl.UTF-8
151Pliki nagłówkowe do programowania z użyciem własnościowego sterownika
91311dfb 152ATI dla kart graficznych Radeon.
57e97736
PS
153
154%package static
91311dfb 155Summary: Static libraries for development for the ATI Radeon cards proprietary driver
7bd8110b 156Summary(pl.UTF-8): Biblioteki statyczne do programowania z użyciem własnościowego sterownika dla kart ATI Radeon
57e97736 157Group: X11/Development/Libraries
50c0449c 158Requires: %{pname}-devel = %{epoch}:%{version}-%{rel}
57e97736
PS
159
160%description static
161Static libraries for development for the ATI proprietary driver for
162ATI Radeon graphic cards.
163
91bd8dfa
JR
164%description static -l pl.UTF-8
165Biblioteki statyczne do programowania z użyciem własnościowego
91311dfb
JB
166sterownika ATI dla kart graficznych ATI Radeon.
167
566515bf
JR
168%package atieventsd
169Summary: ATI external events daemon
1a3464b2 170Summary(pl.UTF-8): Demon zewnętrznych zdarzeń ATI
566515bf 171Group: Daemons
50c0449c 172Requires: %{pname} = %{epoch}:%{version}-%{rel}
566515bf
JR
173Requires: acpid
174Requires(post,preun): /sbin/chkconfig
175Requires: rc-scripts
176
177%description atieventsd
a1d0c0b1 178The ATI External Events Daemon is a user-level application that
179monitors various system events such as ACPI or hotplug, then notifies
180the driver via the X extensions interface that the event has occured.
566515bf
JR
181
182%description atieventsd -l pl.UTF-8
a1d0c0b1 183Demon zewnętrznych zdarzeń ATI jest aplikacją monitorującą różne
184zdarzenia systemowe, takie jak ACPI lub hotplug, a następnie
185informującą sterownik poprzez interfejs rozszerzeń X, że zaszło
186zdarzenie.
566515bf 187
4f51afba
JR
188%define kernel_pkg()\
189%package -n kernel%{_alt_kernel}-video-firegl\
190Summary: ATI kernel module for FireGL support\
191Summary(pl.UTF-8): Moduł jądra oferujący wsparcie dla ATI FireGL\
192Release: %{rel}@%{_kernel_ver_str}\
193License: ATI\
194Group: Base/Kernel\
195Requires(post,postun): /sbin/depmod\
4f51afba
JR
196%requires_releq_kernel\
197Requires(postun): %releq_kernel\
4f51afba
JR
198Provides: kernel%{_alt_kernel}-video-firegl = %{epoch}:%{version}-%{rel}@%{_kernel_ver_str}\
199\
200%description -n kernel%{_alt_kernel}-video-firegl\
201ATI kernel module for FireGL support.\
202\
203%description -n kernel%{_alt_kernel}-video-firegl -l pl.UTF-8\
204Moduł jądra oferujący wsparcie dla ATI FireGL.\
205\
206%if %{with kernel}\
207%files -n kernel%{_alt_kernel}-video-firegl\
208%defattr(644,root,root,755)\
209/lib/modules/%{_kernel_ver}/misc/*.ko*\
210%endif\
211\
212%post -n kernel%{_alt_kernel}-video-firegl\
213%depmod %{_kernel_ver}\
214\
215%postun -n kernel%{_alt_kernel}-video-firegl\
216%depmod %{_kernel_ver}\
217%{nil}
218
219%define build_kernel_pkg()\
220cp -pf common/lib/modules/fglrx/build_mod/2.6.x/Makefile common/lib/modules/fglrx/build_mod\
221%build_kernel_modules -C common/lib/modules/fglrx/build_mod -m fglrx GCC_VER_MAJ=%{_ccver}\
222%install_kernel_modules -D installed -m common/lib/modules/fglrx/build_mod/fglrx -d misc\
223%{nil}
224
225%{?with_kernel:%{expand:%kpkg}}
de93633b 226
de93633b 227%prep
20cc48d9 228%setup -q -c
20cc48d9 229#sh %{SOURCE0} --extract .
22b932f3 230#sh amd-catalyst-%{version}-linux-x86.x86_64.run --extract .
09118c22
JR
231cd fglrx-%{intver}
232sh amd-driver-installer-%{intver}-x86.x86_64.run --extract .
de93633b 233
ec41c566
JR
234cp -p arch/%{arch_dir}/lib/modules/fglrx/build_mod/* common/lib/modules/fglrx/
235cat >>common/lib/modules/fglrx/build_mod/2.6.x/Makefile <<EOF
236\$(M)/libfglrx_ip.a:
237 ln -s \$(LIBIP_PREFIX)/libfglrx_ip.a \$(M)
238EOF
de93633b 239
1e707323 240%patch0 -p1
8b7f9c10 241%patch1 -p0
ce2fff9a 242%patch2 -p0
1e707323
JR
243%patch3 -p1
244%patch4 -p1
d62793ba 245%patch5 -p1
ef56bf22
JR
246%patch6 -p1
247%patch7 -p1
de93633b 248
e27c0f70 249install -d common{%{_prefix}/{%{_lib},bin,sbin},/etc}
5b6e428d 250cp -a %{x11ver}%{arch_sufix}/usr/X11R6/%{_lib}/* common%{_libdir}
dbf2846b 251mv common%{_libdir}/modules/extensions/{fglrx/fglrx-libglx.so,libglx.so}
5b6e428d
ER
252cp -a arch/%{arch_dir}/usr/X11R6/%{_lib}/* common%{_libdir}
253cp -a arch/%{arch_dir}/usr/X11R6/%{_lib}/modules common%{_libdir}/xorg
254cp -a arch/%{arch_dir}/usr/X11R6/bin/* common%{_bindir}
255cp -a arch/%{arch_dir}/usr/bin/* common%{_bindir}
256cp -a arch/%{arch_dir}/usr/sbin/* common%{_sbindir}
257cp -a arch/%{arch_dir}/usr/%{_lib}/*.so* common%{_libdir}
dbf2846b 258mv common%{_libdir}/{fglrx/fglrx-libGL.so.1.2,libGL.so.1.2}
5b6e428d 259cp -a arch/%{arch_dir}/etc/* common/etc
de93633b 260
261%build
09118c22 262cd fglrx-%{intver}
4f51afba 263%{?with_kernel:%{expand:%bkpkg}}
de93633b 264
de93633b 265%install
266rm -rf $RPM_BUILD_ROOT
267
09118c22 268cd fglrx-%{intver}
58549e73 269
de93633b 270%if %{with kernel}
4f51afba
JR
271install -d $RPM_BUILD_ROOT
272cp -a installed/* $RPM_BUILD_ROOT
de93633b 273%endif
274
275%if %{with userspace}
3e526379
JR
276install -d $RPM_BUILD_ROOT%{_sysconfdir}/{ati,env.d,X11/xorg.conf.d,ld.so.conf.d} \
277 $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_includedir}/GL} \
e3dbb82b 278 $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_datadir}/ati,%{_mandir}/man8} \
3e526379 279 $RPM_BUILD_ROOT%{_libdir}/{fglrx,xorg/modules/extensions/fglrx} \
e27c0f70
JR
280 $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
281 $RPM_BUILD_ROOT%{_sysconfdir}/OpenCL/vendors
566515bf 282
5b6e428d
ER
283install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atieventsd
284cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/atieventsd
3e526379 285
5b6e428d
ER
286cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/X11/xorg.conf.d
287cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/X11/xorg.conf.d
3e526379
JR
288sed -i -e 's|@@LIBDIR@@|%{_libdir}|g' $RPM_BUILD_ROOT/etc/X11/xorg.conf.d/10-fglrx-modules.conf
289
5b6e428d 290cp -a common%{_datadir}/doc/fglrx/examples/etc/acpi $RPM_BUILD_ROOT/etc
e27c0f70 291install -p common/etc/OpenCL/vendors/*.icd $RPM_BUILD_ROOT%{_sysconfdir}/OpenCL/vendors
e3dbb82b 292
5b6e428d
ER
293install -p common%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
294install -p common/usr/X11R6/bin/* $RPM_BUILD_ROOT%{_bindir}
295install -p common%{_sbindir}/* $RPM_BUILD_ROOT%{_sbindir}
e3dbb82b
JR
296
297rm $RPM_BUILD_ROOT%{_sbindir}/atigetsysteminfo.sh
de93633b 298
5b6e428d 299cp -a common%{_libdir}/modules/* $RPM_BUILD_ROOT%{_libdir}/xorg/modules
fa23496e 300ln -s %{_libdir}/xorg/modules/dri $RPM_BUILD_ROOT%{_libdir}
5b6e428d
ER
301cp -a common%{_sysconfdir}/ati/control $RPM_BUILD_ROOT%{_sysconfdir}/ati/control
302cp -a common%{_sysconfdir}/ati/signature $RPM_BUILD_ROOT%{_sysconfdir}/ati/signature
303cp -a common%{_sysconfdir}/ati/amdpcsdb.default $RPM_BUILD_ROOT%{_sysconfdir}/ati/amdpcsdb.default
de93633b 304
5b6e428d
ER
305cp -a common%{_datadir}/ati/* $RPM_BUILD_ROOT%{_datadir}/ati
306cp -a common%{_datadir}/icons/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
a0e674b9 307
1e707323
JR
308cp -r common%{_desktopdir}/*.desktop $RPM_BUILD_ROOT%{_desktopdir}
309
5b6e428d 310cp -a common%{_mandir}/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
e3dbb82b 311
d76ff2e1 312%ifarch %{x8664}
5b6e428d 313echo %{_libdir}/fglrx > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/fglrx64.conf
d76ff2e1 314%else
5b6e428d 315echo %{_libdir}/fglrx > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/fglrx.conf
d76ff2e1 316%endif
bd12a4d2 317
5b6e428d 318cp -a common%{_libdir}/lib* $RPM_BUILD_ROOT%{_libdir}/fglrx
bd12a4d2 319
3e526379 320mv -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions/{,fglrx}/libglx.so
f9cbcfd5 321
63192f6b 322/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}/fglrx
3e526379 323ln -sf libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/fglrx/libGL.so
bb25c48e 324(cd $RPM_BUILD_ROOT%{_libdir}/fglrx ; ln -sf libfglrx_dm.so.*.* libfglrx_dm.so)
9d6674ac 325
5b6e428d 326cp -p common%{_includedir}/GL/*.h $RPM_BUILD_ROOT%{_includedir}/GL
57e97736
PS
327echo "LIBGL_DRIVERS_PATH=%{_libdir}/xorg/modules/dri" > $RPM_BUILD_ROOT%{_sysconfdir}/env.d/LIBGL_DRIVERS_PATH
328
566515bf 329install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
051fc62d 330%{__sed} -e 's|@@prefix@@|%{_prefix}|g;s|@@libdir@@|%{_libdir}|g;s|@@includedir@@|%{_includedir}|g;s|@@version@@|%{version}|g' < %{SOURCE3} \
566515bf 331 > $RPM_BUILD_ROOT%{_pkgconfigdir}/gl.pc
03e0c9e0 332%endif
566515bf 333
de93633b 334%clean
335rm -rf $RPM_BUILD_ROOT
336
5b2ffdd6
JR
337%post libs -p /sbin/ldconfig
338%postun libs -p /sbin/ldconfig
de93633b 339
566515bf
JR
340%post atieventsd
341/sbin/chkconfig --add atieventsd
342%service atieventsd restart
343
344%preun atieventsd
345if [ "$1" = "0" ]; then
346 %service -q atieventsd stop
347 /sbin/chkconfig --del atieventsd
348fi
349
de93633b 350%if %{with userspace}
351%files
352%defattr(644,root,root,755)
09118c22 353%doc fglrx-%{intver}/{LICENSE.TXT,common%{_docdir}/fglrx/*.html,common%{_docdir}/fglrx/articles,common%{_docdir}/fglrx/user-manual}
cc34c4f1 354%dir %{_sysconfdir}/ati
eb789250 355%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ati/control
1cf8b52c 356%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ati/signature
217c853b 357%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ati/amdpcsdb.default
57e97736 358%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/env.d/LIBGL_DRIVERS_PATH
de93633b 359%attr(755,root,root) %{_bindir}/*
566515bf 360%attr(755,root,root) %{_sbindir}/amdnotifyui
b94c2073 361%{_desktopdir}/*.desktop
a0e674b9
BZ
362%{_pixmapsdir}/*.xpm
363%{_datadir}/ati
3e526379
JR
364%dir %{_libdir}/xorg/modules/extensions/fglrx
365%attr(755,root,root) %{_libdir}/xorg/modules/extensions/fglrx/libglx.so
5b2ffdd6
JR
366%{_libdir}/dri
367%attr(755,root,root) %{_libdir}/xorg/modules/dri/fglrx_dri.so
368%attr(755,root,root) %{_libdir}/xorg/modules/drivers/fglrx_drv.so
bb2b340f 369%dir %{_libdir}/xorg/modules/linux
5b2ffdd6
JR
370%attr(755,root,root) %{_libdir}/xorg/modules/linux/libfglrxdrm.so
371%attr(755,root,root) %{_libdir}/xorg/modules/amdxmm.so
372%attr(755,root,root) %{_libdir}/xorg/modules/glesx.so
3a6c6402
JR
373%{_sysconfdir}/X11/xorg.conf.d/10-fglrx.conf
374%{_sysconfdir}/X11/xorg.conf.d/10-fglrx-modules.conf
5b2ffdd6
JR
375
376%files libs
377%defattr(644,root,root,755)
e27c0f70
JR
378%dir %{_sysconfdir}/OpenCL
379%dir %{_sysconfdir}/OpenCL/vendors
380%{_sysconfdir}/OpenCL/vendors/*.icd
d76ff2e1 381%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/fglrx*.conf
bd12a4d2 382%dir %{_libdir}/fglrx
424a1cb0 383%attr(755,root,root) %{_libdir}/fglrx/libAMDXvBA.so.*.*
3e526379 384%attr(755,root,root) %ghost %{_libdir}/fglrx/libAMDXvBA.so.1
e27c0f70 385%attr(755,root,root) %{_libdir}/fglrx/libOpenCL.so.1
ab5aac73 386%attr(755,root,root) %{_libdir}/fglrx/libXvBAW.so.*.*
3e526379 387%attr(755,root,root) %ghost %{_libdir}/fglrx/libXvBAW.so.1
63192f6b 388%{_libdir}/fglrx/libAMDXvBA.cap
e27c0f70 389%attr(755,root,root) %{_libdir}/fglrx/libamdocl*.so
09118c22 390%attr(755,root,root) %{_libdir}/fglrx/libamdhsasc*.so
c37980c7 391%attr(755,root,root) %{_libdir}/fglrx/libatiadlxx.so
d49fb583
AA
392%attr(755,root,root) %{_libdir}/fglrx/libaticalcl.so
393%attr(755,root,root) %{_libdir}/fglrx/libaticaldd.so
394%attr(755,root,root) %{_libdir}/fglrx/libaticalrt.so
ca92b9f5 395%attr(755,root,root) %{_libdir}/fglrx/libatiuki.so.*.*
3e526379 396%attr(755,root,root) %ghost %{_libdir}/fglrx/libatiuki.so.1
bd12a4d2 397%attr(755,root,root) %{_libdir}/fglrx/libGL.so.*.*
3e526379 398%attr(755,root,root) %ghost %{_libdir}/fglrx/libGL.so.1
bd12a4d2 399%attr(755,root,root) %{_libdir}/fglrx/libfglrx_dm.so.*.*
b8dac3df 400
57e97736
PS
401%files devel
402%defattr(644,root,root,755)
3e526379
JR
403%attr(755,root,root) %{_libdir}/fglrx/libfglrx_dm.so
404%attr(755,root,root) %{_libdir}/fglrx/libGL.so
f3848da1 405%{_includedir}/GL
566515bf 406%{_pkgconfigdir}/gl.pc
de93633b 407
57e97736
PS
408%files static
409%defattr(644,root,root,755)
3e526379 410%{_libdir}/fglrx/libfglrx_dm.a
de93633b 411
566515bf
JR
412%files atieventsd
413%defattr(644,root,root,755)
414%attr(754,root,root) /etc/rc.d/init.d/atieventsd
415%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/atieventsd
416%attr(755,root,root) %{_sbindir}/atieventsd
417%attr(755,root,root) %{_sysconfdir}/acpi/ati-powermode.sh
418%{_sysconfdir}/acpi/events/*
419%{_mandir}/man8/atieventsd.8*
5ebc6789 420%endif
This page took 0.125245 seconds and 4 git commands to generate.